Avisos
Vaciar todo

Index.php formulario 404  

 
Alexandra
 Alexandra
Noble Member

Hola,

Veo que tengo un problema que se genera en mi prestashop que es el index.php no entiendo por que navegando por la tienda por distintas categorías y de la nada me sale el mensaje del formulario 404 "que no se encuentra" ver mensaje:

Luego en la herramienta del webmasters tolls me sale lo mismo en errores de urls y comprobando efectivamente son las mismas páginas en casi todas las categorías.

Qué puedo hacer?

Este mismo error lo he visto en otras plantillas también como carmé.
Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/05/2015 2:15 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Veo que esto ocurre cuando se pulsa sobre el elemento de menú "Inicio", lo que indica que está mal configurado.

Vete en la administración de PrestaShop a Módulos y edita el módulo que estás utilizando para el menú de tu web. Como se trata de una plantilla de pago puede que sea un módulo especial.

Una vez dentro del módulo tendrías que cambiar el enlace de ese elemento de menú "Inicio" para que en lugar de ser index.php pase a ser /index.php (con la barra / delante). Esto debería solucionar el problema.

ResponderCitar
Respondido : 19/05/2015 3:48 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alexandra
 Alexandra
Noble Member

Hola Pablo, gracias por tu pronta respuesta.

Esta plantilla se trabaja con este módulo para el menu:

Y dentro del módulo son estas opciones:

Como puedes ver en la captura la url está sin la barra /. es decir /index.php a eso te refieres?.
Además observando este error que se produce en la home (página de inicio) también se produce en las categorías, pero revisando las opciones dentro del menú no me sale la opción url como en el caso de la página de inicio, la opción está ya puesta como categoría.
Como está aqui:

Luego en preferencias > SEO y Urls tengo estas opciones:

Mi pregunta es, ¿se corrige en el módulo menu o en preferencias en seo y urls? otra duda que tengo como corrijo las categorías que también está ese problema y por lo que veo a través de menú no se puede sino en preferencias seo y urls.

Por favor aclara estas dudas antes de hacer cualquier cambio.
Gracias! 😉

ResponderCitar
Respondido : 20/05/2015 5:22 pm
Julen
 Julen
Miembro Admin

Hola,

Tras revisar tu sitio web, veo que los problemas que comentas sobre la pagina de inicio se han solventado. Respecto a las categorías, indicanos la URL de algunos ejemplos, donde se visualice dicho error.

Saludos

ResponderCitar
Respondido : 20/05/2015 5:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alexandra
 Alexandra
Noble Member

Esto sucede cuando estás navegando por categorías en todas además de la home. Y aún no se ha resuelto en la página de inicio. Este error se repite en la home y en las distintas categorías.

Saludos

ResponderCitar
Respondido : 20/05/2015 5:45 pm
Julen
 Julen
Miembro Admin

Hola,

Tras navegar por tu sitio web, no me ha dado errores, puedo acceder a todas las categorías sin problemas. Como te comente en el anterior mensaje, envianos las URL de algunos ejemplos, para comprobar si se trata de un problema con tu conexion o un tema global. No obstante, te recomendamos limpiar la cache de tu navegador y si es posible verificar su web desde otro equipo.

Saludos

ResponderCitar
Respondido : 20/05/2015 6:02 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alexandra
 Alexandra
Noble Member

Por ejemplo navegando en la web entro a las bailarinas veo un producto voy hacia atrás y no pasa. Pero si veo el producto y en lugar de ir hacia atrás voy a inicio pasa esto:
http://danasheels.com/bailarinas-de-mujer/index.php

Y me sale este error.

Prueba ir en varias categorías, vuelve hacia atrás después vete a inicio y casi siempre suele pasar.

Saludos

ResponderCitar
Respondido : 20/05/2015 6:58 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

ESto es por que estas usando la url relativa para irte al inicio, debes usar la url absoluta tal como te comentó Pablo poner /inicio.php en lugar de inicio.php, en la captura de pantalla en el campo url

Saludos.

ResponderCitar
Respondido : 20/05/2015 7:28 pm

Cursos Gratuitos WordPress

Alexandra
 Alexandra
Noble Member

Hola, parece ser que se ha solucionado. Una consulta con las categorías es necesario añadir /index.php a las categorías de productos? por ejemplo: http://danasheels.com/36-zapatos-con-cuna

Me surge esta duda ya que en la captura de pantalla anterior donde sale varios formularios 404 me gustaría entender el por qué? ya que esas categorías si existen y están operativas.
Gracias

ResponderCitar
Respondido : 03/06/2015 8:32 pm
Rafael
 Rafael
Miembro Moderator

¡Hola Alejandra!

No tienes que usar /index.php más categoría en tu sitio Prestashop, bastaría con la siguiente estructura:

midominio.com/nombredelacategoria

-> en tu caso Contenido solo visible a usuarios registrados

Por lo que no debes añadir index.php a las direcciones de la categorias.

¿Podrías facilitarnos los enlaces de qué categorias ( y formularios ) te fallan?

Actualmente vemos que tu sitio web carga sin problemas.

Saludos

ResponderCitar
Respondido : 03/06/2015 10:10 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tal como te comenta, el index.php es el archivo que teoricamente se carga por defecto, es decir si colocas una url con un directorio y al final index.php , es lo mismo que si solo colocaras el directorio

www.ejemplo.com/directorio/

es lo mismo que

www.ejemplo.com/directorio/index.php

Saludos.

ResponderCitar
Respondido : 03/06/2015 10:13 pm
Alexandra
 Alexandra
Noble Member

Hola Rafael,

Por ejemplo una de las categorías que falla es la de cuñas, este es el link: http://danasheels.com/cunas/index.php

y esta url de aquí: http://danasheels.com/prices-drop?p=5 que no entiendo a que se refiere para solucionarlo.

Un saludo

ResponderCitar
Respondido : 04/06/2015 5:56 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes alguna categoria cunas?
Es posible que esas urls hayan sido indexadas cuando aún estabas en etapa de desarrollo

El que te redireccione a una página 404 es correcto, aunque también podrías evaluar quitar la indexación en google, revisa :
https://support.google.com/customsearch/answer/2631051?hl=es

Saludos

ResponderCitar
Respondido : 04/06/2015 7:11 pm