No aparecen categorías en lateral izquierdo tras actualizar a prestashop 1.7.3.1  

Página 1 / 2
 
ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

Buenas tardes. He actualizado prestashop a la última versión estable (la 1.7.3.1) y tras la actualización, las categorías no me aparecen en la página principal (en la parte izquierda de la página como me aparecían antes) ya que la imagen ocupa toda la página. (Se puede ver en las capturas que adjunto).
También, al acceder al menú superior a la parte de productos, se listan el la parte izquierda las categorías (de forma correcta), sin embargo, en la parte central de la página también tendrían que listarse y me aparece toda en blanco hasta que no hay un artículo, que entonces sí que me lo muestra. Es decir, en este punto, me gustaría que en la parte del centro se mostraran igual las categorías, no sólo aquellas donde tengan productos dentro.

¿Cómo puedo arreglarlo? Espero haberme explicado medianamente bien :dry:
Y muchas gracias de antemano.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 20/04/2018 6:17 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Veo varias diferencias la parte de la cabecera por ejemplo el logo me sale a la derecha.
Si tienes habilitada la cache de tu sitio prueba limpiar cache o deshabilitar, prueba recompilar archivos de smarty en la misma pantalla de Preferencias > Rendimiento.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/04/2018 7:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

Gracias por contestar.

Efectivamente, el logo se encuentra a la derecha y debería estar en el otro lado de la página, y el carrito (que actualmente está en el centro, debería de ir hacia el lado derecho).
¿Cómo soluciono esto?

¿Y cómo puedo añadir las categorías en la página principal?

Muchas gracias.
Un saludo.

ResponderCitar
Respondido : 20/04/2018 7:29 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El theme clasic no tiene ninguna posición para que las categorías aparezcan en el inicio, lo puedes ver en la demo : http://demo.prestashop.com/es/?view=front

Con respecto a la desconfiguración, prueba lo que te había comentado, otra opción sería reemplazar los archivos del theme, lo puedes descargar desde : https://github.com/PrestaShop/PrestaShop/tree/develop/themes/classic

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/04/2018 8:14 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

He probado todo lo que me ha dicho, incluso lo de reemplazar los archivos pero sigue igual. Lo que si que me he fijado, es que en el carrito (en el proceso de pedido) aparece todo ordenado de forma correcta.

¿A qué se puede deber eso?

ResponderCitar
Respondido : 20/04/2018 8:36 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El carrito tiene otra configuración por defecto ya que oculta módulos

Revisa desde Diseño > Posiciones , si tienes otro PrestaShop compara cada una de las posiciones con los módulos que hay en cada uno ya que al parecer algo se debe haber desconfigurado.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/04/2018 11:22 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

Buenos días.

¿Pero cómo sé cuál es la configuración por defecto del carrito? No tengo otro prestashop con el que lo pueda comparar. Desde que lo actualicé ya me apareció así y, estéticamente queda horrible. Por eso me gustaría colocarlo como estaba antes de la actualización, el carrito a la derecha del todo, al igual que el inicio de sesión; y el logo a la izquieda de la página junto con la información que aparece más arriba (la de llámenos).

Muchas gracias.

ResponderCitar
Respondido : 21/04/2018 1:48 pm
ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

En la captura adjunto el hook en el que se encuentra el carrito de la compra. El inicio de sesión se encuentra en el mismo hook; mientras que la parte de "llámenos" (módulo de información de contacto) está en el hook displayNav1.
¿Me podrían confirmar si en vuestro Prestashop está de la misma forma o que cambios tengo que hacer?

ResponderCitar
Respondido : 21/04/2018 1:51 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

La configuración de displayNav1 que tienes parece correcta: coincide con un PrestaShop 1.7 de prueba que tengo con el tema Classic.

Tendrías que verificar que la configuración de la posición displayNav2 es como la siguiente:

La mejor opción, si dispones de espacio suficiente en tu cuenta, sería que te instalaras en otro directorio un PrestaShop de prueba y así lo utilices para comparar las posiciones de los módulos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/04/2018 3:24 pm
ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

Buenos días de nuevo.
El hook displayNav2 está exactamente igual que el que me adjuntó en la captura. Intentaré instalar entonces un nuevo Prestashop de prueba, puesto que no sé de dónde puede proceder el error.

Muchas gracias y un saludo.

ResponderCitar
Respondido : 23/04/2018 11:02 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

Querís destacar, que me acabo de dar cuenta de que cuando accedo al carrito para hacer el pedido, ahí si que aparecen todos los módulos colocados. Adjunto capturas de la diferencia que se ve. La primera es cuando se accede al carrito. Y la segunda es lo que se ve en todas las demás páginas.
¿Eso se puede deber a algún código mal en el css?

ResponderCitar
Respondido : 23/04/2018 11:07 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.

las categorías no me aparecen en la página principal
Por defecto el bloque de las categorías solo se muestra en las paginas de categorías, si intentas mostrarlo en el Home de la pagina aparecería al final como un bloque mas ya que por defecto la home no tiene asignada esa columna.

Para añadir una columna a la Izquierda en la Home tienes que acceder a Módulos -> Diseño -> temas y Logo
.- Pulsa en " Seleccionar Diseño "

.- Selecciona " Index " y despliega la opción " Aspecto " dejando seleccionado " Tow Columns, small left columns "

Es posible que después de esto tengas que realizar algunos ajustes en el tema del diseño ya que los productos al mostrarse en filas de cuatro esta no cabrán en la misma linea.

¿ Que problema es el que tienes en el carro ? ya que veo que si se muestra ¿ El problema es de diseño ?

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 23/04/2018 11:52 am

wpdoctor-revisa-la-salud-de-tu-wordpress

ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

Buenos días.

El problema no está en el carrito (ahí es donde los módulos aparecen colocados en las posiciones correctas). El problema está en la colocación de los módulos (carrito, inicio de sesión, idioma) en todas las demás páginas (excepto en la del carrito).
Las categorías ya las he incluído a la página de inicio. Muchas gracias.
Quería también que me aparecieran donde indico en la captura adjunta. Puesto que antes de la actualización de prestashop, aparecían ahí (3 por cada línea) y según se iba accediendo a cada una de ellas, se iban mostrando su primera subcategoría o artículos.

Muchas gracias y un saludo.

ResponderCitar
Respondido : 23/04/2018 12:02 pm
ENRIQUE JAVIER
 ENRIQUE JAVIER
Usuario experto

Lo de añadir las categorías como adjuntaba en la captura ya está solucionado.
Solamente me quedaría poder colocar los módulos que se encuentran descolocados.

ResponderCitar
Respondido : 23/04/2018 12:29 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.

Prueba a desenganchar el modulo de busqueda.

Si desenganchando el módulo de busca se soluciona, perfecto, si vieras que no se soluciona, edita el archivo custom.css que encontrarás en la ruta themes -> classic -> assets -> css -> custom.css y añade lo siguiente:

.col-lg-1, .col-lg-2, .col-lg-3, .col-lg-4, .col-lg-5, .col-lg-6, .col-lg-7, .col-lg-8, .col-lg-9, .col-lg-10, .col-lg-11, .col-lg-12, .col-md-1, .col-md-2, .col-md-3, .col-md-4, .col-md-5, .col-md-6, .col-md-7, .col-md-8, .col-md-9, .col-md-10, .col-md-11, .col-md-12, .col-sm-1, .col-sm-2, .col-sm-3, .col-sm-4, .col-sm-5, .col-sm-6, .col-sm-7, .col-sm-8, .col-sm-9, .col-sm-10, .col-sm-11, .col-sm-12, .col-xl-1, .col-xl-2, .col-xl-3, .col-xl-4, .col-xl-5, .col-xl-6, .col-xl-7, .col-xl-8, .col-xl-9, .col-xl-10, .col-xl-11, .col-xl-12, .col-xs-1, .col-xs-2, .col-xs-3, .col-xs-4, .col-xs-5, .col-xs-6, .col-xs-7, .col-xs-8, .col-xs-9, .col-xs-10, .col-xs-11, .col-xs-12 {

min-height: auto;
}

Puedes utilizar el administrador de archivos de cuenta de cPanel para editar el archivo:
-> https://www.webempresa.com/blog/administrador-de-archivos-de-cpanel-como-buscar-archivos.html

¿ antes de la actualizacion habias realizado alguna modificación en el diseño ? ¿ Te acuerdas que archivo/s son los que modificastes ?

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 23/04/2018 6:12 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro