Porblema con la visualización de imagenes por parte de los clientes  

 
Diego
 Diego
Usuario activo

Mis clientes no pueden visualizar las fotos después de registrarse

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 25/02/2016 12:27 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Necesitaríamos que nos adjuntes algún usuario registrado para poder revisarlo.

Puedes adjuntarnos alguna captura para poder revisar donde esta el problema?

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/02/2016 2:04 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Diego
 Diego
Usuario activo

Si claro, cree un usuario de prueba para que puedan revisar, sería: dgmuri@gmail.com con el password: Muristar01

El archivo adjunto es una muestra donde se observa que en lugar de las fotos aparece un signo de pregunta

ResponderCitar
Respondido : 25/02/2016 4:42 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifico que por alguna razon cambia la ruta de la imagen de esta forma: Contenido solo visible a usuarios registrados

Introduce este código pbdPuSXIwj, haz realizado algun cambio de optimización?

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/02/2016 6:01 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Diego
 Diego
Usuario activo

No he realizado ningún cambio de optimización, lo que hice hace unos minutos fue una regeneración de miniaturas, pero igual el problema persiste

ResponderCitar
Respondido : 25/02/2016 6:27 am
Julen
 Julen
Miembro Admin

Hola,

En primer lugar, indícanos desde que fecha te sucede el problema que estas teniendo.

Existen varias causas, pero vamos a detallarlas para que puedas identificar cuál es tu problema realmente.

La primera causa puede ser que se haya modificado algo del .htaccess , para solucionarlo deber ir a preferencias, SEO&Urls , bajas un poco y pulsas directamente en guardar. Esta acción regenera el .htaccess.

La segunda causa puede ser que hayas regenerado las miniaturas pero que no haya terminado, dando time out. Para solucionarlo, ve a preferencias imágenes y regenera nuevamente las miniaturas pero desmarcando la opción que pone borrar imágenes anteriores, es posible que debas repetir este proceso algunas veces, dependiendo de la cantidad de productos.

La tercera es que después de regenerar siguen sin verse, pese a que ha dado como correcta la regeneración de imágenes. Para solucionarlo debes ir a preferencias, imágenes y verificar el nombre de los tipos de imágenes, en la plantilla por defecto de prestashop 1.6 son las siguientes:

cart_default

small_default

medium_default

home_default

large_default

thickbox_default

category_default

scene_default

m_scene_default

Si tienes otra plantilla diferente, debes consultar con el creador los tipos de imágenes que requiere.

La cuarta, es que hayas marcado la opción de poner imágenes en el almacenamiento nuevo o que no las hayas movido y tengas el almacenamiento por defecto.

Para solucionarlo debes tener claro como está, ve a preferencias, imágenes y regenera las miniaturas.

Debe darte un error de que no se encuentra la imagen en la ruta por ejemplo img/p/1/2/1/imagen.jpg

Esto suele ocurrir después de actualizar y quiere decir que tienes establecido el nuevo almacenamiento.

La solución: Edita el archivo controllers/admin/AdminImagesController.php

busca:

•. // No need to display the old image system if the install has been made later than 2013-03-26

•. $this->display_move = (!Configuration::get('PS_LEGACY_IMAGES') && defined('_PS_CREATION_DATE_') && strtotime(_PS_CREATION_DATE_) > strtotime('2013-03-26')) ? false : true $this->

display_move = false;

y cambia lo último por $this->display_move = true;

Después ve dentro de Preferencias -> Imágenes

Ya aparece la opción de poner el almacenamiento por defecto como lo tenías en la anterior versión.

Marca usar almacenamiento por defecto.

Ahora debes usar una copia de seguridad de la carpeta img antes de actualizar y la reemplazas por la que tienes en la actualización.

Después de recuperar la carpeta img debes ir a preferencias, imágenes y pulsa en mover imágenes al nuevo tipo de almacenamiento.

Y por último desmarca usar almacenamiento por defecto y regenera miniaturas.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/02/2016 9:15 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Diego
 Diego
Usuario activo

Hola, el problema me sucede desde el primer producto que he creado, las imágenes se muestran a los invitados de mi pagina, pero a los usuarios registrados no les permite ver las imágenes.

Voy a intentar solucionar el problema con las opciones que me indicaron, caso contrario, les hare saber para que me guíen en otras alternativas.

ResponderCitar
Respondido : 25/02/2016 4:32 pm
Diego
 Diego
Usuario activo

Gracias por toda la ayuda; sin embargo, el problema se me estaba presentando por él módulo de marca de agua, ya solucioné la situación.

En caso de que a otro cliente se le presente una situación similar, pueden darle también la referencia de que revisen este módulo, ya que también a través de este se puede presentar inconvenientes en la carga de imágenes.

ResponderCitar
Respondido : 25/02/2016 7:56 pm

Cursos Gratuitos WordPress

Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Diego

Gracias por el aporte.

Te recomiendo mejor subir tus imágenes dese el inicio con una marca de agua

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/02/2016 8:58 pm

Por favor Iniciar Sesión o Registro