Problema backoffice Prestashop 1.7.4.4.  

 
Mario
 Mario
Estimable Member

Hola,

Estamos teniendo problemas con el backoffice de Prestashop 1.7.4.4.. El problema es que cuando llevas un espacio corto de tiempo al hacer click en cualquier parte se cierra e intentas acceder de nuevo con el usuario y contraseña y ya nunca te deja acceder. Tenemos o que abrir el modo incógnito o limpiar las cookies y la caché. También ocurre cuando pasa un tiempo en incógnito y tenemos que cerrar todas las ventanas de incógnito y volver a abrir una nueva.

¿Saben como podemos solucionar esto? Muchas gracias.

Un saludo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 09/10/2019 6:42 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es muy raro lo que comentas, has probado con otro navegador? ya que parece ser un problema más bien con las cookies en tu navegador.

Podrías evaluar también actualizar tu PrestaShop ya que podría ser algún tipo de bug, actualmente tienes la versión 1.7.6.1.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/10/2019 8:06 pm

Cursos Gratuitos WordPress

Mario
 Mario
Estimable Member

Hola,

Si, hemos probado en diferentes navegadores, en incógnito, en diferentes equipos con diferentes usuarios.

Esto viene desde versiones previas y actualizar lo hemos intentado pero nos daba error, por eso seguimos en la versión que estamos, no creo que sea un bug de la versión, si no le ocurriría a más gente y por aquí solo he visto un caso similar al nuestro con la versión 1.6. que al final no encontraron solución.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 10/10/2019 11:04 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mario.

actualizar lo hemos intentado pero nos daba error,

Elimina el plugin 1click upgrade
.- Descarga el módulo actualizado y lo instalas:
-> https://addons.prestashop.com/en/data-migration-backup/5496-.html

El módulo de actualización que incorporaba la versión 1.7.4 de prestashop no funcionaba bien al igual que esa versión.

Una vez actualizada la versión, en el acceso selecciona la opción " Mantener sesión activa "

e intentas acceder de nuevo con el usuario y contraseña y ya nunca te deja acceder.

Cuando dices que no te deja entrar por lo que puedo deducir, tendrás un aviso de Cookie caducada.

Eso suele pasar cuando se cierra la sesión y se intenta acceder desde la misma URL que se cerró.

tudominio.xxx/adminxxx/modules.......

Si el problema es de cookies para volver acceder tienes que añadir la URL de acceso al adminsitrador tudominio.xxx/adminxxx

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 10/10/2019 12:05 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Mario
 Mario
Estimable Member

Hola Pepe,

Muchas gracias por la respuesta. Vamos a probar a actualizar como has dicho, desinstalamos el módulo y lo volvemos a instalar aunque ya tengamos esa versión instalada.

Aquí adjunto configuración del módulo. Nos dice que la versión de PHP está obsoleta, ¿cuál deberíamos de utilizar?

¿Recomiendas actualizar con el canal "Principal actualización" o descargando la actualización y eligiendo directorio?

Muchas gracias por adelantado.

Un saludo.

ResponderCitar
Respondido : 10/10/2019 1:24 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mario.

¿cuál deberíamos de utilizar?
utiliza la versión 7.2

Puedes modificar la versión de PHP desde tu cuenta de cPanel:
-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Recomiendas actualizar con el canal "Principal actualización"
En principio Si, si vemos que da problemas ya probariamos manualmente desde archivo pero primero vamos con la forma más fácil.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 10/10/2019 1:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mario
 Mario
Estimable Member

Hola Pepe,

Si dejo la versión 7.2 de PHP me aparece con una advertencia "PrestaShop requirements are not satisfied." ¿Continuo igualmente con la actualización?

En cambio si tengo la versión 7.3. me aparece todo en verde pero me da errores el backoffice.

Edito: No puedo continuar con la instalación si no está todo en verde.

Segunda edición: Si pongo la versión 7.1 no hay ningún problema.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 10/10/2019 7:19 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes algún módulo con este nombre o similar: guzzlehttp?

Al parecer es módulo no esta programado correctamente para trabajar con versiones actuales de PHP, antes de actualizar tu PrestaShop revisa si tienes módulos pendientes de actualizar.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/10/2019 7:56 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mario
 Mario
Estimable Member

Hola,

No tenemos ningún módulo con ese nombre o similar. Los únicos módulos que faltaban por actualizar son Advanced Top Menu, que no tenemos forma de actualizarlo, búsqueda por facetas y lista de enlaces. Lo demás estaba todo actualizado.

Adjunto los archivos del log de la actualización que ha vuelto a dar fallo, probando con PHP 7.1.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 10/10/2019 8:14 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El error que veo en los archivos que adjuntas es a nivel de Base de Datos.

Según veo en los archivos de error hay uno que hace referencia a un tipo de campo bit() que te ha creado posiblemente algún módulo, revisa:
Contenido solo visible a usuarios registrados

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/10/2019 10:51 pm

Cursos Gratuitos WordPress

Mario
 Mario
Estimable Member

Hola Jhon,

Efectivamente ahí estaba el problema, ya hemos podido actualizar en el clon. Muchísimas gracias. Esperemos que con esta actualización el backoffice también funcione correctamente.

Un saludo.

ResponderCitar
Respondido : 11/10/2019 2:52 pm

Por favor Iniciar Sesión o Registro