Avisos
Vaciar todo

Sale el mensaje "Property Carrier->name is empty" al intentar borrar tranportista  

 
Daniel
 Daniel
Usuario experto

Buenos Días

Estoy teniendo un problema recientemente, que antes no me pasaba. Tengo configurado por defecto un transportista, que es el único que usamos como valido, no aceptamos al opción de recogida en tienda física. Pero últimamente solo me acepta esta opción "envío gratis, recogida en tienda" ni si quiera me salen las dos opciones. Por lo tanto me decidí a borrar esa opción dentro del la opción de transportista, al intentarlo me sale el error de "Property Carrier->name is empty".
He leído en el foro que la opción es borrarlo desde la base de datos ¿como puedo hacerlo? ¿se solucionará mi problema con los envíos gratuitos?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 18/08/2017 2:34 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Antes de eliminar el único que tienes, verifica si te sucede lo mismo agregando o editando algún transportista.
Prueba eliminar los que has creado.

Saludos.

ResponderCitar
Respondido : 18/08/2017 6:50 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Daniel
 Daniel
Usuario experto

No es el único que tengo, tengo tres que no puedo borrar, sin nombre y que cada vez que intento editar me crea otro idéntico y uno que he creado yo con el transportista válido. He intentado borrar el único que me vale y lo he vuelto a crear, pero no ha funcionado.

ResponderCitar
Respondido : 19/08/2017 1:47 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Pues si se trataria de un bug: http://forge.prestashop.com/browse/PSCSX-3254 en el enlace se especifica al final sentencia SQL para ejecutarlo en la base de datos. Es de suma importancia que realices una copia de seguridad de la base de datos antes de que se realizar cualquier ajuste.

ResponderCitar
Respondido : 19/08/2017 3:17 am

Cursos Gratuitos WordPress

Daniel
 Daniel
Usuario experto

No acabo de entender lo que tengo que hacer.

ResponderCitar
Respondido : 21/08/2017 1:55 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola daniel.

Ese problema se detectó en versiones anteriores de prestashop y se soluciono en las versiones posteriores.

Veo que utilizas la versión 1.6.1.7, la última versión estable de prestashop es la 1.6.1.16. Previa copia de seguridad actualiza PS a la última versión y revisa si se soluciona.

Un saludo

ResponderCitar
Respondido : 21/08/2017 4:06 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Daniel
 Daniel
Usuario experto

Después de actualizar la versión de Prestashop, el problema persiste.

ResponderCitar
Respondido : 23/08/2017 4:27 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es posible que el problema lo hayas tenido desde versiones anteriores y el bug actualmente ha dañado los registros en la base de datos.

De manera general, ubica tu base de datos y usa PHPMyAdmin para localizar la tabla : ps_carriers
Luego en esta tabla puedes examinar los registros, verifica si tienes un campo deleted , para eliminar según comentan en el foro de prestashop tienes que establecer el registro a 1, verifica si con esto ya no aparece en el backend de tu sitio.

Realiza una copia de la base de datos por seguridad.

Saludos.

ResponderCitar
Respondido : 23/08/2017 7:09 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Daniel
 Daniel
Usuario experto

He borrado los registros de los transportistas pero sigue sin salir ni los costes de envío ni el transportista que tengo por defecto, que ahora solo es uno.

ResponderCitar
Respondido : 24/08/2017 10:21 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Puedes adjuntarnos una captura de los cambios que has aplicado en la base de datos?

Por el momento no visualizo más información en los foros de PrestaShop.

ResponderCitar
Respondido : 25/08/2017 3:02 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Daniel
 Daniel
Usuario experto

He borrado todos los registros vacíos y esto es lo que queda. Hay un montón de transportistas repetidos del mismo que tengo ahora configurado.

ResponderCitar
Respondido : 25/08/2017 9:22 am
Daniel
 Daniel
Usuario experto

Ok, Solucionado. Era un tema de Zonas, por algún motivo Península y España no los reconocía como la misma zona.

ResponderCitar
Respondido : 25/08/2017 11:14 am

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Ok, que bueno que encontraste la solución.

Saludos.

ResponderCitar
Respondido : 25/08/2017 6:18 pm
GRUPO DE INVERSIONES
 GRUPO DE INVERSIONES
Nuevo usuario

Hola, tengo el mismo problema con un transportista que se creo automaticamente de un modulo de mercadolibre. y cada que intento borrarlo se duplica. Por favor explicame paso por paso como eliminar estos transportistas, o si es posible desde el cpanel. El problema es que ese transportista no se deja desactivar tampoco ni desabilitar envio gratis.

ResponderCitar
Respondido : 22/07/2018 8:20 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Por favor abre un nuevo hilo con tu usuario, es decir, no sigas una entrada de otro usuario.
Al realizar la consulat desde una entrada de otro usuario no podemos realizar las pruebas necesarias que necesitamos.

Abre un nuevo hilo con la consulta y nos indicas el dominio afectado.

Un saludo

ResponderCitar
Respondido : 22/07/2018 11:50 am