Artículos con errores 404 pero que sí existen  

 
Pere
 Pere
Nuevo usuario

Hola!

estamos experimentando un error en algunos artículos de nuestro blog que nos tiene un poco desconcertados. Lo que ocurre es que estos artículos aparecen la paginación del blog pero cuando haces click en ellos nos sale un error de que la página que buscamos no existe (un 404 parece).

Lo curioso es que esos artículos sí que existen. Os pongo un ejemplo:

Contenido solo visible a usuarios registrados

Citar
Respondido : 23/05/2018 5:03 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes algún plugin adicional para la búsqueda?, tienes algún plugin de optimización activo?, prueba desactivar este tipo de plugins.

Luego, indícanos a qué categoría corresponde el artículo:
Contenido solo visible a usuarios registrados

Veo que la url se crea bajo "australia", es esta una categoría?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/05/2018 6:08 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pere
 Pere
Nuevo usuario

Hola John,

Siguiendo tus consejos no hemos logrado solucionarlo pero sí aislar el problema, sabemos que sucede porque parece que sucede en los artículos que terminan con una barra lateral "/" en el editor de artículos.

Es decir, en el editor aparecen asÍ:
https://www.growproexperience.com/nueva-zelanda/chilenos-nueva-zelanda-3-dudas-resueltas/

Aunque luego indexan así (sin la barra final)
https://www.growproexperience.com/nueva-zelanda/chilenos-nueva-zelanda-3-dudas-resueltas

¿No debería llevar al mismo lugar? Tampoco tenemos claro por qué en algunos artículos tenemos esa barra lateral y en en otros no.

¿Alguna idea sobre cómo volver a redirecccionar esto?

ResponderCitar
Respondido : 28/05/2018 11:17 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Pere.

Tanto una URl como la otra redirigen a una URL de pagina no encontrada
¿ la entrada " chilenos nueva zelanda 3 dudas resueltas existe ? y la categoria " nueva zelanda ?, prueba por ejemplo a eliminar esa entrada y volver a crearla.

¿ Solo te pasa con artículos de una categoría en concreto ?

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 28/05/2018 1:45 pm

Cursos Gratuitos WordPress

Pere
 Pere
Nuevo usuario

Sí, esa entrada existe. Se puede ver en el administrador de wordpress, está publicada y todo correcto.

Esto nos pasa en todas las categorías, pero sólo en los artículos que están guardados con un "/" al final. El resto de artículos, los que no tienen el "/" al final se ven bien.

Cuando cambiamos la URL de la entrada quitándole el "/" entonces sí que funciona.

ResponderCitar
Respondido : 28/05/2018 3:32 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Pere.

Ok, vamos a probar a eliminar la barra final de todas las entradas.

Editar el archivo htaccess y al principio del archivo añade lo siguiente:

RewriteEngine On
RewriteBase /
RewriteRule ^(.*)/$ /$1 [L,R=301]

Este código redirecciona las URl que terminen con / a la misma URl pero sin la barra.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 28/05/2018 4:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro