Avisos
Vaciar todo

[Resuelto] Atributo de plantilla de las páginas no lo hace correctamente  

 
SILVIA
 SILVIA
Usuario activo

Hola,

Me instalé un tema y me puse a trabajar sobre el y al leer un poco más ví el tema de trabajar sobre temas hijo en lugar de editar el tema padre. Así que hice un tema hijo a partir del padre y me puse a incluir todos los temas que había reformateado en el tema padre. Hasta ahí todo bien.

Ya tenía creadas 2 páginas, la de aviso legal y afiliación. Al pasar al tema hijo y cargar las páginas, el formato no es correcto. He visto que en la edición de las páginas, en el apartado de atributos de página hay un apartado que se llama plantilla y ahí selecciono la plantilla que deben seguir. Pues está bien seleccionada y sin embargo no me lo carga correctamente. Sin embargo, activo el tema padre y ahí si que me lo carga correctamente. No sé que es lo que pasa.

Otra cosa, como puedo ver esa plantilla a la que hago referencia en las páginas?

Muchas gracias.

Respondido : 26/08/2020 5:54 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Silvia,

Como estas creando el tema hijo? puedes eliminarlo (el tema hijo) y hacerlo mediante un complemento, de esta forma se asegura que todo este correcto https://www.webempresa.com/blog/crear-temas-hijo-child-themes-en-wordpress.html te comparto la guía donde esta de igual manera el complemento a utilizar.

Con respecto a ver la plantilla, no comprendo a que te refieres con este punto.

Un saludo 🖐️ 

Respondido : 26/08/2020 6:18 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

SILVIA
 SILVIA
Usuario activo

@argenis

Hola Argeni,

Muchas gracias. Ya había leído ese post y he usado el plugin para general el tema hijo por eso no sé que puede haber pasado y me indicaba cuando analizaba antes de crear era todo correcto.

Respondido : 26/08/2020 7:33 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Silvia,

Puedes indicarnos cual es la URL de tu sitio web? de esta forma podremos verificar lo que nos comentas. También si es posible coméntanos cual es el tema que usas en tu sitio web.

De manera general es posible que el tema que uses no funcione de forma correcta al crear el childtheme con el plugin para crear los temas hijos.

Un Saludo

Respondido : 26/08/2020 7:46 pm

Cursos Gratuitos WordPress

SILVIA
 SILVIA
Usuario activo

@karen

Hola Karen,

Esta es la URL, aún trabajo en la temporal: http://comprau2-cp148.wordpresstemporal.com  

Abajo en el pie de página podéis dar a Afiliación o a Aviso Legal y os saldrán las páginas y veréis que en lugar de salir con el mismo formato que la página de inicio, salen muy feas las cabeceras y los pies de página.

El tema que uso es el JobScout Pro de Rara theme.

Muchas gracias.

Saludos!

Respondido : 26/08/2020 7:53 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Silvia,

Entiendo que el tema que usas es un tema pago -> Contenido solo visible a usuarios registrados , he estado verificando y puede ser que este tema genere algún conflicto al activar el generador de temas hijos.

En este caso prueba contactando con los desarrolladores de la plantilla y coméntales lo que ocurre, es posible que para este tema ellos tengan desarrollado el chiltheme por defecto.

Comprueba esto y nos comentas como ha ido todo

Un Saludo

 

Respondido : 26/08/2020 8:40 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

SILVIA
 SILVIA
Usuario activo

@karen

Hola Karen,

Voy a contactar con los desarrolladores de la plantilla a ver que me dicen pero es que lo que me choca es que tengo 3 páginas creadas: página inicio, afiliación y aviso legal. Las 3 tienen en el atributo plantilla una que se llama "Contact page" y cuando carga la web, la página de inicio la carga bien pero las 2 dos salen super feas.

Lo que tampoco encuentro es esa plantilla "Contact page" por ningún lado, si me podéis ayudar por favor. Igual he borrado o tocado algo q no debía...

Muchas gracias.

Respondido : 27/08/2020 9:48 am
SILVIA
 SILVIA
Usuario activo

@karen

Hola Karen,

Ya me han respondido los desarrolladores y solucionado el problema. Me han pedido que les cree una cuenta temporal de administrador para poder entrar. Me han indicado que han hecho unas modificaciones en el hijo y ya funciona todo.

Entiendo que ahora lo recomendable es que elimine el usuario que les he creado, verdad?

Por cierto, la plantilla "Contact page" que es la que uso para que cogan los atributos de formato las páginas que voy haciendo, no la veo por ningún lado, si me podéis ayudar por favor. Igual he borrado o tocado algo q no debía...

Muchas gracias

Respondido : 27/08/2020 12:38 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Silvia,

Enhorabuena lograste solucionarlo, en este caso ya que no necesitarán ese usuario lo mejor es que lo elimines o desactives cambiando por ejemplo la contraseña de acceso.

Con respecto a la plantilla de contact page, entiendo que esto es una plantilla predeterminada de el tema. Es posible que al realizar algún cambio en el function del childtheme se desactivará algo aunque es muy raro.

Comprueba crear nuevamente la pagina y verifica si en la sección Atributos de pagina -> Plantilla de aparece esta que nos mencionas.

Si aun no logras verla, lo mejor es que escribas nuevamente a soporte ya que esto no se elimina a menos que se altere la funcionalidad del rema

Un Saludo

 

Respondido : 27/08/2020 2:09 pm
SILVIA
 SILVIA
Usuario activo

@karen

Hola Karen,

Muchas gracias por todo. Todo solucionado.

Respondido : 28/08/2020 11:02 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Silvia,

Enhorabuena se ha solucionado todo por completo,

Gracias a ti, siempre estamos encantados en ayudarte 😀 

Escríbenos si tienes cualquier otra consulta

Un Saludo  😊 

Respondido : 28/08/2020 1:32 pm