Avisos
Vaciar todo

Cambio de idioma del sitio por restauración  

Página 1 / 2
 
Juan David
 Juan David
Usuario eminente

Hola,

Tuve un problema con la plantilla de mi página web así que realicé una restauración por medio de SuperBackups, después de haber hecho la restauración muchos elementos que antes estaban en Español cambiaron a Inglés, esto afectó botones, filtros, y el problema más grande es que dentro de mi tienda online, al darle click en algún producto aparece el error 404 porque el cambio de idioma afectó todos los enlaces internos de los productos, es decir, lo que antes en los productos era https://coriles.com/producto/ancheta-old-parr-media/ , ya es https://coriles.com/product/ancheta-old-parr-media/ , el cambio se ve reflejado en la palabra en el enlace producto que actualmente es product.

¿Cómo puedo solucionar este problema de manera óptima? Teniendo en cuenta que al poner el idioma del sitio en español en Settings >> General no me guarda los cambios.

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/07/2018 6:08 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Algo también que podría pasar es que tenga algún plugin de cache o un sistema de cache a nivel de servidor (como magic cache), si tienes alguno de estos sitemas prueba deshabilitar y verifica.

Realiza nuevamente la configuraicón de urls amigables, desde Ajustes > Enlaces permanentes, deja la url por defecto y verifica si te sucede lo mismo, luego cambia nuevamente a urls amigables y verifica.

Entiendo que sólo has recuperado archivos, ya que no has tenido cambios a nivel de BD, es muy extraño que la recuperación te haya causado estos problemas, salvo que los hayas tenido en la misma fecha que restauraste.

Saludos.

ResponderCitar
Respondido : 05/07/2018 7:09 pm

Cursos Gratuitos WordPress

Juan David
 Juan David
Usuario eminente

Hola,

Solucioné el problema de los enlaces, gracias. Este problema del cambio de idioma no lo tenía antes de la restauración.

El plugin de cache que tengo instalado es WP Rocket, lo desactivé y siguió igual (Botones y filtros en Inglés)

Gracias.

ResponderCitar
Respondido : 05/07/2018 8:19 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Cuando realizaste la restauración qué restauraste exactamente? ya que es posible que se hayan perdido archivos del idioma español para tu theme, plugins o para el propio WordPress.

Saludos.

ResponderCitar
Respondido : 05/07/2018 8:49 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan David
 Juan David
Usuario eminente

Hola,

Restauramos todo el sitio por que tuvimos un problema al actualizar la plantilla y luego no se visualizaba el sitio, por eso lo restauramos a como estaba el lunes.

Gracias.

ResponderCitar
Respondido : 05/07/2018 9:04 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Esto que comentas me parece extraño:

Teniendo en cuenta que al poner el idioma del sitio en español en Settings >> General no me guarda los cambios.

Revisa si tienes actualizaciones pendientes de idiomas de WordPress o del propio WordPress, si seleccionas otro idioma te guarda correctamente?, ya que al parecer hay algún tipo de problema con los archivos del idioma español.

Saludos.

ResponderCitar
Respondido : 05/07/2018 10:19 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan David
 Juan David
Usuario eminente

Hola,

En este momento tenemos la versión 4.9.6

Cómo puedo ver si tengo pendiente alguna actualización de idioma pendiente?

Gracias.

ResponderCitar
Respondido : 05/07/2018 10:48 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Desde el menú de: Escritorio > Actualizaciones, puedes actualizar o reinstalar los idiomas, tal como se ve en la siguiente imagen.

Saludos.

ResponderCitar
Respondido : 05/07/2018 11:02 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan David
 Juan David
Usuario eminente

Hola,

Ya he actualizado y los elementos de la página que te he comentado siguen en Inglés.

Gracias.

ResponderCitar
Respondido : 06/07/2018 4:40 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Luego que has realizado la actualización , si ingresas a esa pantalla nuevamente te aparecen otras actualizaciones?

Revisa en Ajustes > Generales, si tienes establecido el idioma español por defecto, tal como se muestra en la imagen adjunta.

Saludos.

ResponderCitar
Respondido : 06/07/2018 8:15 pm

Cursos Gratuitos WordPress

Juan David
 Juan David
Usuario eminente

Hola,

No tengo actualizaciones pendientes y el idioma predeterminado es Español.

Gracias

ResponderCitar
Respondido : 06/07/2018 8:23 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba seleccionar otro idioma, italiano o francés y verifica si tu sitio cambia de idioma, tendría que descargar los archivo, luego cambia a español y verifica si te sucede lo mismo.

Saludos.

ResponderCitar
Respondido : 06/07/2018 10:44 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan David
 Juan David
Usuario eminente

Hola,

Recuerdas que tenía el problema de que en Ajustes > Generales intentaba cambiar el idioma a español y no guardaba los cambios, ahora pasa exactamente lo mismo.

Gracias.

ResponderCitar
Respondido : 07/07/2018 12:30 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Puedes comprobar si dentro del directorio:

wp-content/languages
wp-content/themes/tu_tema/languages

Existen ficheros de traducción para Español?

Comprueba también si en el fichero wp-config.php de tu WordPress se encuentra disponible la siguiente linea:

define('WPLANG', 'es_ES');
ResponderCitar
Respondido : 07/07/2018 3:06 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan David
 Juan David
Usuario eminente

Hola,

Adjunto la imagen de lo que tengo en:
- wp-content/languages

- wp-content/themes/tu_tema/languages
En esta ruta me aparecen los siguientes archivos, el problema es que ese no es el nombre de mi tema.

Y en cuanto a la línea
define('WPLANG', 'es_ES');
No aparece en wp-config.php

Gracias

ResponderCitar
Respondido : 11/07/2018 4:23 pm
Página 1 / 2