Avisos
Vaciar todo

La conexion no es segura tengo SSL instalado  

Página 1 / 2
 
Miguel
 Miguel
Estimable Member

Tengo

Instalado el certificado dese hace ya mas de un año, y ahora he actualizado el tema, y me estan dando los navegadores "La conexion no es segura"

No localizo el problema,y si fuese de alguna imagen o algo que se me escpa, como podria desvincular esa imagen.

Saludos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 15/08/2018 4:02 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Miguel,

Recomendaciones importantes para la web que citas:

Observo que no tienes configurada ruta de imágenes para "Medios" en WordPress.

La ruta correcta es: /home/inforaut/public_html/wp-content/uploads

Cuando instalas WordPress, por defecto la ruta de subida de archivos es wp-content/uploads. Sin embargo es posible que tras un traslado esta ruta, por configuraciones anteriores, no sea la correcta y tengas que modificarla.

Revisa el siguiente artículo por si te es de utilidad:

- Corrige la ruta upload path en WordPress - https://www.webempresa.com/blog/corrige-la-ruta-upload-path-en-wordpress.html

No tener bien configurado este parámetro afecta al desempeño de tu sitio web y prolonga los tiempos de carga.

1. WordPress por defecto busca los archivos de imágenes (que afectan de forma global a toda la web) en la carpeta que indique la variable 'uploads'.
2. Si esta variable está vacía WordPress creará una carpeta en /public_html o en la carpeta donde tengas la web llamada /public_html/wp-content/uploads/2018/08 (por ejemplo) y guardará ahí las imágenes.
3. Al no ser la ruta reflejada en la variable de la base de datos, esto genera un consumo adicional de tiempo de carga, pues muchas de las imágenes las tiene que regenerar sobre la marcha, cuando se pide la carga de la página.
4. Además de consumir espacio adicional en el Hosting, y generar posiblemente entradas de error en el archivo error_log (que puede crecer en tamaño desmesuradamente) los tiempos de carga globales de la página aumentan.
5. Afecta a la vista de la web (imágenes, enlaces internos) en dispositivos móviles.

Revisa el artículo anteriormente citado para que veas la importancia de tener esta ruta bien configurada en la base de datos.

Si no sabes corregir esta ruta en la base de datos (previa copia de seguridad) o si necesitas que lo realicen por ti envía un Ticket a Soporte.

El plugin Asesor de Cookies consume bastantes recursos y estamos desaconsejando su uso en Webempresa, en su lugar te recomiendo consultar este artículo donde te explico como aplicar la Ley de Cookies en tu web sin utilizar plugins:

- Ley de Cookies en WordPress ¡dile adiós a los plugins! - https://www.webempresa.com/blog/ley-de-cookies-en-wordpress-dile-adios-a-los-plugins.html

Sobre el contenido MIXTO de tu web que provoca que el SSL no funcione adecuadamente:

Cuando tu web se carga con el protocolo https puede haber elementos adicionales que carguen con el protocolo no seguro http, como archivos css, js (javascript) o imágenes. Esto provoca, por un lado, que en lugar de salir el icono del candado a la izquierda de la barra de direcciones del navegador se muestre en su lugar una advertencia y, por otro lado, puede provocar que la web no se vea correctamente, debido a que el navegador bloquea los contenidos no seguros.

Para corregir este problema es necesario localizar los elementos no seguros que se están cargando. Puedes utilizar el inspector de elementos que incluyen la mayor parte de los navegadores o utilizar alguna extensión adicional para el navegador como Firebug. Pulsando en la pestaña "Consola" y recargando la página se tendrían que mostrar aquí los elementos no seguros que se están cargando.

Normalmente este contenido no seguro se suele cargar desde algún widget, si se trata de imágenes. Editando el widget podrías corregir la ruta de carga de la imagen, para que en lugar de cargarse con http:// lo haga con https:// o, mejor aun, poniendo simplemente // (por ejemplo, //www.nombreweb.com/images/nombreimagen.jpg).

Otros elementos, como archivos css o js, se suelen cargar desde el propio tema que estés utilizando en tu WordPress, por lo que sería necesario aplicar cambios en el código del tema, localizando los archivos desde donde se hacen estas llamadas, y cambiando las mismas para empiecen por https:// o por //

Otro tema que debes comprobar es el siguiente: en la administración de WordPress vete a Ajustes->Generales. En los campos "Dirección de WordPress (URL)" y "Dirección del sitio (URL)" pon la url de la web con https (puede que esté puesta con http). De esta forma se le indicará a WordPress que la url de la web carga con protocolo https.

Existe un plugin que te puede ayudar en esta tarea de arreglar los problemas con la carga de contenidos no seguros, llamado SSL Insecure Content Fixer, y que se puede descargar desde el enlace https://es.wordpress.org/plugins/ssl-insecure-content-fixer/ o instalar directamente desde la administración de WordPress. Está pensado para detectar la carga de contenido vía http y aplicar el cambio en el enlace de carga a https.

Una vez instalado y activado el plugin deberás ir a Ajustes, SSL Insecure Content. En el parámetro "Fix insecure content" selecciona el nivel de revisión que aplicará el plugin, de menos a más estricto. Puedes ir probando los diversos niveles de arriba a abajo, recargando el frontal después de cada cambio, hasta encontrar el que te corrija el problema, aunque lo recomendable será la opción "Widgets" o, si esta sigue sin solucionar el problema, la opción "Capture". El parámetro "HTTPS detection" se puede dejar con la opción "standard WordPress function".

Saludos

ResponderCitar
Respondido : 15/08/2018 4:34 pm

Cursos Gratuitos WordPress

Miguel
 Miguel
Estimable Member

Hola Luis

Te agradezco muchísimo las recomendaciones, la del plugin de cookies si era mas consciente, pero el tema de las imágenes no, solo sabía que tenía problemas a veces para cargar nuevas imágenes.
Con respecto a ambas recomendaciones ya están aplicadas las soluciones que indicas.

Mi duda es si las imágenes ya subidas que son prácticamente el 100% de la web, también mejoraran en carga o rendimiento, o solo esta mejora la vere reflejada en la subida de nuevas imágenes.

Con respecto al contenido no seguro http, pase un test con whynopadlock y me arrojo el resultado que se puede observar en la captura de pantalla que adjunto.

Después de eso utilice el inspector del navegador y no vi que cargase ninguna imagen con esa url de mantenimiento. Después de ésto instale el plugin SSL Insecure Content Fixer, y he llegado hasta el nivel "captura" y tampoco se ha corregido.

Me sigue apareciendo url no segura.

Gracias

Saludos

ResponderCitar
Respondido : 19/08/2018 4:08 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Esa imagen no deberías tenerla ya que esta haciendo referencia a la url temporal.
Actualmente veo que ya sale correctamente la revisión:
Contenido solo visible a usuarios registrados

Saludos.

ResponderCitar
Respondido : 19/08/2018 4:56 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Miguel
 Miguel
Estimable Member

Perfecto!! si cierto ahora ya si.

Muchas Gracias .

ResponderCitar
Respondido : 19/08/2018 9:19 pm
Miguel
 Miguel
Estimable Member

Perfecto!! si cierto ahora ya si.

Muchas Gracias .

Acabo de darme cuenta, que al desactivar el plugin SSL Insecure Content Fixer vuelve aparecerme el contenido no seguro. Existe alguna forma de arreglarlo sin tener instalado éste plugin de por vida.

ResponderCitar
Respondido : 19/08/2018 9:47 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Miguel,

Si quieres prescindir definitivamente del plugin "SSL Insecure Content Fixer" tendrás que localizar la imagen:

Contenido solo visible a usuarios registrados

Y de esta forma corrijas el problema de contenido mixto (sin HTTPS).

Saludos

ResponderCitar
Respondido : 19/08/2018 10:16 pm
Miguel
 Miguel
Estimable Member

Hola

La cosa es que la imagen proviene de una instalación clon de la que tengo en producción con https pero que va con http: y que en no poco tiempo pretendo borrar.

Saludos

ResponderCitar
Respondido : 19/08/2018 10:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Miguel,

Pues el aviso de "sitio inseguro" te acompañará mientras cargues elementos en tu web que contengan enlaces internos o externos (salientes) con "http" en lugar de "https".

Desde Julio de 2018 Google penaliza el posicionamiento de sitios sin HTTPS (afecta a contenidos mixtos también) y los muestra como sitios "no seguros".

Las webs que no usen SSL posicionarán peor porque Google considera este factor como necesario para posicionar un sitio web.

Saludos

ResponderCitar
Respondido : 20/08/2018 12:12 am
Miguel
 Miguel
Estimable Member

Hola

He conseguido localizar la imagen, aunque no estaba seguia haciendo referencia a ella, pero cargando otra de nuevo he coseguido pasar el test, y sale correcto. Aunque los navegadores me siguen arrojando contenido no seguro.

Gracias!!

Saludos

ResponderCitar
Respondido : 20/08/2018 12:22 am

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Miguel,

La imagen esa era la causa, ahora puedes eliminar si quiere sel plugin de SSL Insecure Content Fixer, ya que no es necesario.

Ahora veo que no tienes contenido mixto.

Comprueba desde otro navegador que no uses habitualmente para descartar que no sea la caché de tu actual navegador.

Saludos

ResponderCitar
Respondido : 20/08/2018 12:56 am
Miguel
 Miguel
Estimable Member

Hola

Si he probado en chrome y firefox y me siguen arrojando pagina no segura.

Saludos

ResponderCitar
Respondido : 20/08/2018 10:42 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

El problema lo tienes en la URL que genera el plugin de Cookie ya que carga un enlace con http:
Prueba a desactivar el plugin y revisa si carga bien el certificado:

Otra cosa que veo es el tema del logo que lo marca como contenido mixto aunqu eveo que carga por https, elimina el logo y lo vuelves a cargar.

Un saludo

ResponderCitar
Respondido : 20/08/2018 11:22 am
Miguel
 Miguel
Estimable Member

Hola

He borrado y cargado las fotos del logo de nuevo, y también he modificado la url del aviso de cookies, pero los navegadores me siguen indicando contenido no seguro.

Saludos

ResponderCitar
Respondido : 20/08/2018 4:04 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel.

Ok, Ya veo que desaparecieron los anteriores avisos, el que veo ahora es el siguiente:

Este aviso es de la siguiente imagen:
Contenido solo visible a usuarios registrados

Parece que es la imagen que tienes incrustada:

Un saludo

ResponderCitar
Respondido : 20/08/2018 5:28 pm
Página 1 / 2