Problema al compartir mis posts en Facebook  

 
Sebastián
 Sebastián
Usuario eminente

Hola chicos

Mi problema es que cuando comparto algunos de los artículos de mi blog en facebook, la foto que aparece es correcta pero el título y la descripción corresponde a otro artículo, siempre al mismo.
El caso es que esto ocurre desde que activé los Rich Pins de Pinterest e introducí en el head el código que en el soporte de Pinterest me indicaron, este:

Me sorprendió que me dijeran que bastaba con incluir los datos de un post fuera el que fuera... y el caso es que no he tenido problema en ninguna otra red social, nada más que en facebook, que se comparten una y otra vez el título y la descripción que puse en esta meta.

Me pregunto si hay algún otro código más general, o alguna otra forma de hacer y solucionar esto??? Por cierto ya he pasado por Debugger Facebook varias veces sin solución.

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 25/07/2017 10:13 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Sebastián.

El problema por lo que veo biene por

Como puedes ver siempre te cargara el mismo articulo.

.- Prueba eliminar el código que añadiste.

Supongo que utilizas yoast para el seo de wordpress.
Para utilizar Rich Pins, necesitas una cuenta de empresa de Pinterest. Si está utilizando una cuenta personal, puedes convertirla a una cuenta empresa.

Para confirmar tu sitio web con Pinterest:
.- accede a Pinterest
.- Accede Editar perfil -> Sitio web
.- Añade el nombre de tu sitio web y haz clic en "Confirmar sitio"
.- Copia el código de verificación que aparece en el cuadro
.- Accede a la administración de WP
.- Accede a SEO -> Social
.- Selecciona la pestaña de Pinterest
.- Añade el código de Pinterest en el cuadro y guardar los cambios
.- Accede a Pinterest y haz clic en "Finalizar"

Comprueba si despues de eso todo vuelve a la normalidad.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 25/07/2017 10:44 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Sebastián
 Sebastián
Usuario eminente

Hola de nuevo,

Efectivamente el problema viente al meter ese código para activar los Rich Pins en Pinterest, pero es que yo ya confirmé mi web en Pinterest añadiendo ese código, pero según me dijeron los de Pinterest si no añado esa meta no tengo los Rich Pins (hasta que no la añadí no los tuve) y si ahora quito esa meta sigo verificado en Pinterest como empresa pero no tengo los Rich Pins. Además solo me ocurre con Facebook.

¿Qué puedo hacer?

ResponderCitar
Respondido : 25/07/2017 7:08 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Has comprobado que el artículo de Facebook mediante el plugin de SEO by Yoast tenga la descripción correcta?.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/07/2017 10:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Sebastián
 Sebastián
Usuario eminente

Sí, lo he comprobado todo y seguía saliendo el título y la descripción de ese mismo post con el que añadí la meta para activar los Rich Pins de Pinterest.
Ahora se ha solucionado, pero claro, he tenido que quitar la meta. Por el momento se me mantienen los Rich Pins, no sé si me los desactivarán por hacerlo.
Ahora el único problema que persiste es con la HOME, se comparte con el título y descripción adecuada del blog pero con una imagen que no tiene nada que ver a pesar de haber escogida la correcta mil veces.

¿Esto como lo soluciono? y por otra parte ¿me desapareceran los Rich Pins al quitar la meta? Si es así, qué hago?

Mil gracias

ResponderCitar
Respondido : 26/07/2017 10:18 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola sebastian.

Por el momento se me mantienen los Rich Pins, no sé si me los desactivarán por hacerlo.
No, mientras tengas el codigo de verificacion añadido en yoast, de eso se encarga el propio plugin.

se comparte con el título y descripción adecuada del blog pero con una imagen que no tiene nada que ver a pesar de haber escogida la correcta mil veces.

En la captura que te indica Jhonny tienes un bloque para añadir la imagen que quieres que aparezca:

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 26/07/2017 3:01 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Sebastián
 Sebastián
Usuario eminente

Justo ahí es dónde la he subido mil veces jejejejej

Gracias.

ResponderCitar
Respondido : 26/07/2017 4:29 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Debería de funcionarte, verifica si dispones de alguna actualización del plugin de SEO by Yoast, caso contrario es posible que otro plugin te pueda estar afectando. Si tienes algún otro plugin que trabaje con redes sociales prueba a desactivarlo.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/07/2017 3:00 am

Cursos Gratuitos WordPress

Sebastián
 Sebastián
Usuario eminente

Pues no sé que puede pasar porque he cambiado la imagen 1000 veces, el plugin está actualizado y no creo que tenga ningún otro que afecte. Estos son los que tengo: Cookie law info, GP premium, Jetpack, TOC, Super cache, Thive Content Builder y Seo Yoast.

No sé...

ResponderCitar
Respondido : 27/07/2017 9:50 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Sebastián.

Mientras tengas añadido el código que comentamos en la primera entrada, siempre te aparecerá esa noticia, como te comente tienes que eliminar el código y realizar la verificación añadiendo el ID en las opciones del plugin de yoast.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 27/07/2017 12:29 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Sebastián.

Mientras tengas añadido el código que comentamos en la primera entrada, siempre te aparecerá esa noticia, como te comente tienes que eliminar el código y realizar la verificación añadiendo el ID en las opciones del plugin de yoast.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 27/07/2017 12:29 pm
Sebastián
 Sebastián
Usuario eminente

Hola Pepe

Si sigues el hilo verás que el código ya lo quité y que todo funciona ya correctamente, es decir, cuando comparto algún post en facebook este va acompañado de imagen, título y descripción correctas. Además, no sé cómo, pero también se me mantienen los Rich Pins de Pinterest (según tu mismo me dijiste se van a mantener mientras tenga la verificación en SEO yoast).

El problema que persiste es cuando comparto la URL del blog que corresponde a la HOME, que por mucho que he indicado en Yoast la imagen correcta, sigue apareciendo una que no tiene nada que ver. Y la verdad es que es un parche que ahora que estoy empezando y compartiendo la url del blog, aparezca una imagen incorrecta (el título y descripción si que están bien).

Ya no sé que más hacer...pero tengo que solucionarlo.

ResponderCitar
Respondido : 27/07/2017 1:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Has verificado si es un problema de caché de Facebook?: https://www.webempresa.com/blog/borrar-la-cache-de-facebook-para-evitar-contratiempos.html

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/07/2017 11:30 pm

Por favor Iniciar Sesión o Registro