Avisos
Vaciar todo

Problema con redireccion indeseada y no localizable  

 
Elias
 Elias
Usuario activo

Buenas tardes a todos

Mi nombre es Elias, y mi nivel es escaso, el justo para haber maquetado un sitio basico y funcional hace un año usando elementor

Ahora que porfin voy a usar la pagina me he encontrado con un error inesperado y que lamentablemente no se como solucionar

 

En la cabecera de mi sitio web, el boton web deberia redirigir a la pagina que yo llame blog (una pagina maquetada a mi gusto en elementor para mostrar las entradas)

https://wewannabefree.com/

 

El problema es que en vez de llevar a blog redirige a la pagina principal, pero como podemos observar en estas 2 imagenes:

a) la redireccion esta indicada correctamente

b)se corresponde con la URL a donde estamos redirigiendo

 

Asi es como deberia verse (el post esta duplicado porque la version de movil es distinta que la de pc)

 

NOTA: en caso de que las imagenes no se vean, estan colgadas y accesibles en la pagina de inicio de mi web

https://wewannabefree.com/

 

Gracias de antemano y quedo a la espera de sus sugerencias y ayuda

Contenido solo visible a usuarios registrados

Citar
Respondido : 16/10/2021 2:26 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Elias, 

Disculpa no logro ver las imágenes que nos comentas para la configuración del menú, puedes enviarlas nuevamente?, envíanos más detalles de lo que necesitas realizar de esta forma podemos ayudarte con lo que requieres configurar

Un Saludo 

ResponderCitar
Respondido : 16/10/2021 3:13 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Elias
 Elias
Usuario activo

Estoy intentando editar el mensaje anterior pero no encuentro como hacerlo

 

en cualquier caso y como ya comente Karen, las imagenes estan en mi pagina de inicio (las subi ahi para compartir los links pero no funcionaron)

NOTA: en caso de que las imagenes no se vean, estan colgadas y accesibles en la pagina de inicio de mi web

https://wewannabefree.com/

 

Dime que mas detalles necesitas porque siento que he sido todo lo especifico que puedo ser tanto en la descripcion como en las imagenes, asi que solo dime si quieres que miere, pruebe o haga algo o te cuente sobre algo y eso hare

ResponderCitar
Respondido : 16/10/2021 3:59 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Elias, 

Puedo ver las imágenes de las configuraciones en tu sitio web, veo que cuando pulso en blog este se va la página, pero según entiendo que tienes la sección de presentación del proyecto añadido, pero esta no se muestra

Screenshot   2021 10 16T115041.313

Si es así, en este caso es probable que la sección se esté ocultado para escritorio y tablet, ya que veo que en móvil si se despliega

Screenshot   2021 10 16T115244.625

Para verifica esto edita la página de tu blog y selecciona la sección donde tienes la presentación del proyecto, una vez estés en sus configuraciones ve al apartado Avanzado -> Adaptabilidad y comprueba estén desactivadas las opciones de ocultar para escritorio y tablet

Screenshot   2021 10 16T115426.186

Si las tienes activas desmárcalas y guarda los cambios, verifica si con ello el contenido se muestra de forma correcta

Un Saludo 

ResponderCitar
Respondido : 16/10/2021 4:55 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Elias
 Elias
Usuario activo

Buenas de nuevo Karen,

tienes razon en lo de que en el movil funciona perfectamente, y es algo que no habia pensado probar,

pero sin embargo estan bien configuradas ambas, acabo de subir 2 imagenes mas en la pantalla principal donde se puede apreciar

https://wewannabefree.com/

Se te ocurre algo mas que pueda estar afectando solo a la version de sobremesa?

ResponderCitar
Respondido : 16/10/2021 5:54 pm
Elias
 Elias
Usuario activo

Igualmente he de hacer notar que no hay forma natural de acceder a /blog/ la unica manera de visualizarlo es entrando directamente a la pagina a traves del administrador, pero como usuario parece que todo se redirige al dominio principal (pero solo en la version de sobremesa como tu descubriste) :S

ResponderCitar
Respondido : 16/10/2021 6:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Elias, 

Disculpa me indicas de una redirección, pero no veo ninguna redirección actual, ten en cuenta que las redirecciones se ejecutan cuando deseas que una URL especifica se dirija a otra, ten envió un video de lo que veo actualmente en tu sitio web -> Contenido solo visible a usuarios registrados

Adicional veo que tienes las opciones de adaptabilidad marcadas, prueba desactivar esta opción y comprueba si con ello se muestra lo que deseas 

adaptabilidad 2

Un Saludo 

ResponderCitar
Respondido : 16/10/2021 8:02 pm
Elias
 Elias
Usuario activo

Buenos dias

No puedo ver el video que me comentas, me dice algo como invalid key o algo asi (como que no estare autorizado)

He eliminado todo lo relacionado con visibilidad, y como ya anticipe, en el sobremesa seguimos teniendo el mismo problema y en el movil ahora visualizamos la entrada en los 2 formatos distintos

Si quieres puedo darte acceso al sitio si crees que puede ayudarte a encontrar el problema

Saludos

ResponderCitar
Respondido : 17/10/2021 5:56 am

Cursos Gratuitos WordPress

Elias
 Elias
Usuario activo

Curioso, si cambio el nombre de blog a blog lo que sea y la redireccion a blog lo que sea, funciona

asi que parece que lo que esta buggeado es la urle mi dominio/blog

Lo unico que se me ocurre es que con anterioridad mi pagina principal era la misma que el blog, y aunque eso ya esta cambiado desde setting, sigue memorizado en algun sitio interno del funcionamiento de la web

alguna forma de solventarlo? aunque abrire un ticket tambien por la via tradicional dado que parece algo mas tecnico

ResponderCitar
Respondido : 17/10/2021 6:00 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Elias, 

En este caso, ya que indicas los slug están causando el conflicto, verifica si tu página de inicio no tiene la misma URL. También verifica si no tienes alguna imagen con este mismo nombre que pueda estar generando el conflicto

Para verificar el slug de la página debes comprobar como está configurada la opción en enlace permanente

Screenshot   2021 10 17T091548.578

Para verificar los enlaces de las imágenes debes ingresar a tu biblioteca de medio, pulsar sobre la imagen y hacer clic en editar más detalles

Screenshot   2021 10 17T091739.096

Dentro de las opciones de edición abajo del todo debe esta la opción de slug, si no te aparece debes activar su visualización en opciones de pantalla

Screenshot   2021 10 17T091907.309
Screenshot   2021 10 17T091920.310
Screenshot   2021 10 17T091938.212

Prueba modificar estos slug si localizas alguno con el nombre de tu página de blog y comprueba si no se genera el error en los enlaces

Un Saludo

ResponderCitar
Respondido : 17/10/2021 2:20 pm

wpdoctor-revisa-la-salud-de-tu-wordpress