Selección de página princial (estática/blog) en Wordpress no funciona  

Página 1 / 2
 
Joan Salvador
 Joan Salvador
Usuario activo

Hola,

la función de escoger la página principal, entre una estática y las últimas entradas (Opciones > Lectura) no me funciona. Le indico que quiero que la Home sea una página estática (la llamada "Inici"). Pero tras guardar los cambios, el Dashboard sigue dejando ambas opciones sin marcar y mantiene como página principal la de las últimas entradas (precisamente la que no quiero). Incluso tras limpiar la caché, como aconseja el propio Dashboard. También lo he probado desde Apariencia > Personalizar, pero con el mismo resultado. No he hecho ningun cambio que pueda explicar este problema. Uso el tema Vantage ¿Cómo se puede arreglar? Gracias!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 12/07/2017 5:18 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Según lo que comentas, el problema lo tienes en el backend, es decir guardas pero no se reflejan las modificaciones hechas, revisa si te sucede lo mismo con otro navegador.

No he visto anteriormente un problema similar, podría tratarse también de algo relacionado con tu theme, podrías probar cambiando de theme y verificar si te permite guardar.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/07/2017 7:36 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Joan Salvador
 Joan Salvador
Usuario activo

Hola,

he probado ambas cosas y sigue sin funcionar. Al guardar los cambios aparece el aviso verde de "Ajustes guardados" pero, en realidad, los cambios no se aplican. Me hace volver a seleccionar y guardar. Incluso habiendo limpiado la caché. Adjunto archivo.

¿Se puede arreglar con algun cambio en el código php?

¡Gracias!

ResponderCitar
Respondido : 12/07/2017 7:54 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es muy extraño lo que comentas, prueba desactivar todos los plugins uno a uno y verificar si alguno de ellos te causa problemas, especialmente plugins de monitoreo o seguridad.

Si tienes actualizaciones pendientes de WordPress, puedes evaluar también actualizar.

Te sugiero realizar estas pruebas en un clon de tu sitio, revisa:
https://www.webempresa.com/blog/clonar-wordpress-en-3-clics-sin-perder-tiempo.html

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/07/2017 10:20 pm

Cursos Gratuitos WordPress

Joan Salvador
 Joan Salvador
Usuario activo

Hola,

tras hacer estas pruebas sigue sin funcionar. También he probado a cambiarlo desde el editor de la página "Inicio" (la que quiero que ejerza de Home), y desde las opciones de enlaces permanentes. No he visto la posibilidad en ningún sitio.

¿Hay algun punto en el código php donde esto está establecido? Aparentemente se ha cambiado solo, pero a lo mejor se puede arreglar desde allí.

Gracias!

ResponderCitar
Respondido : 13/07/2017 5:48 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Desde la opciones de enlaces permanentes?, supongo que quieres decir que lo cambiaste desde :
Ajustes > Lectura, si no es así posiblemente quieres cambiar otra cosa, envía una captura de pantalla de lo que quieres cambiar.

Modificar esto a través del core de WordPress podría ser complejo, lo normal es que funcione desde la configuración.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/07/2017 10:11 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Joan Salvador
 Joan Salvador
Usuario activo

Hola,

Sí que intenté cambiarlo desde Enlaces permanentes. Esto es porque ví que en la URL limpia (dominio.com) aparece la página de blog, lo que no quiero. Y que la página que quiero como Home, que se llama "Inicio" se añade a la URL cuando la llamo desde el Menú: dominio.com/inicio/ Por eso probé suerte a ver si había algo en la página de permalinks. Pero no habría cambiado nada de no haberlo visto muy claro.

Adjunto imagen de la función de Opciones > Lectura. Lo llamativo es que, por defecto, una de las dos opciones en "Página frontal muestra" (o "Tus últimas entradas" o "Una página estática") debería estar seleccionada. Pero no lo está ninguna. Además los campos para especificar las páginas de Home y Blog al poner una estática aparecen con fondo gris y letras atenuadas. Cuando marco que la Home sea una página estática, queda marcada y los campos de al lado de vuelven blancos, como dejándome seleccionar. Pero una vez guardados los cambios, vuelve al punto anterior sin haber implementado ningún cambio.

Gracias.

ResponderCitar
Respondido : 13/07/2017 10:44 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Al parecer estas utilizando una versión antigua PHP, verifica si cambiando a la versión 7 de tu WordPress entra en funcionamiento la web.

Asi mismo me comenta un técnico que tienes este error:

TENCION! Las entradas de las filas site_url y home de la tabla wp_options no coinciden, podrían fallar algunos plugins
-------->site url: https://psicologiaencancer.com
-------->home: http://psicologiaencancer.com

Desde la administración verifica que estas urls coincidan con el https para que no te genere problemas.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/07/2017 4:19 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Joan Salvador
 Joan Salvador
Usuario activo

Hola,

sigue igual. He homogeneizado las líneas siteurl y home a https://psicologiaencancer.com y he actualizado el PHP a versión 7, pero todo sigue igual.

¿Alguna otra posibilidad para probar?

Gracias.

ResponderCitar
Respondido : 14/07/2017 1:36 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Entiendo que has probado cambiar de theme, y aún así, no se refleja la selección que realizas en Ajustes > Lectura, si cambias otros campos de esta página si te funciona?, envía una captura de pantalla.

Esto es una funcionalidad del core de WordPress, qué versión exacta de WordPress tienes?
Verifica si tienes actualizaciones pendientes.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/07/2017 7:52 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Joan Salvador
 Joan Salvador
Usuario activo

Hola,

disculpa por el retraso en la respuesta. Me tomé una semana de vacaciones.
Los cambios en el contenido sí se reflejan en la página; pero cambiando otros parámetros de Opciones > Lectura, no se reflejan. Lo he probado con el número de entradas para mostrar y en mostrar un resumen o el texto completo y, en ambos casos, tras guardar los cambios, estos campos regresan al valor anterior sin implementar el cambio. Incluso limipando la caché como me sugiere. Adjunto captura de pantalla.

La versión de Wordpress es la última disponible (4.8) y todas las extensiones están actualizadas.

Gracias.

ResponderCitar
Respondido : 25/07/2017 3:17 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica a desactivar todos los plugins aunque te lo indicamos anteriormente pero siguiendo el método indicado en la guia: https://www.webempresa.com/blog/desactivar-todos-los-plugins-de-wordpress-sin-tocar-la-base-de-datos.html

Ejecuta Stephan desde tu área de clientes y comprueba si es que no tienes algún registro de errores 500.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/07/2017 12:17 am

Cursos Gratuitos WordPress

Joan Salvador
 Joan Salvador
Usuario activo

Hola,

he hecho esta desactivación via CPanel y Stephan muestra Error 500 en dos plugins: Jetpack y Yoast SEO. Pero con estos plugins desactivados, el problema continúa (los he reactivado tras comprobarlo para que, al menos, ejerzan su función). También da Error 500 en otros archivos:

  • /public_html/wp-includes/pomo/mo.php
  • /public_html/wp-includes/pomo/entry.php
  • /public_html/wp-content/themes/vantage/inc/settings.php

Gracias

ResponderCitar
Respondido : 26/07/2017 3:16 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Sería posible que nos adjuntes los registros para poder verificarlos?, tienes que verificar si las fechas son actuales caso contrario el problema podría ya estar solucionado.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/07/2017 8:49 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Joan Salvador
 Joan Salvador
Usuario activo

Hola,

adjunto un arcxhivo .txt con los registros. Hay dos fechas: 13 de Julio (coincide con la fecha en la que detecté el problema) y 25 de Julio, que no puede ser porque es muy posterior.

Gracias de nuevo!

ResponderCitar
Respondido : 27/07/2017 5:10 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro