Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

Versión php 8  

 
Tomás
 Tomás
Estimable Member

Hola, cuando cambio la versión de php de 7.4 a 8, por recomendación incluso vuestra no paro de ver estos errores en mi errog_logs.

La cuestión es que me he puesto en contacto con el soporte del plugin, pero no recibo ninguna respuesta.

Desactivar este plugin o deshacerme de el sería lo mismo que planterame cambiar de plantilla, que tantos años lleva conmigo y la verdad no me atrae nada dicho cambio. Porque aunque Storefront no es lo mejorcito en lo que se refiere a estética, gracias a este plugin he podido transformarla a algo digerible.

Llevo casi 1 año con este plugin que prácticamente es casi 100% CSS, no del todo pero casi. Es de pago y recibo actualizaciones, 1 por lo menos me llegó este año. El autor creo que es bastante conocido: James Marsland de pootlepress.com, os suena a vosotros?

Pero reitero, le puse en antecedentes este aviso y lo único que recibí es la típica respuesta automática de... gracias por contactar, en breve nos pondremos......

Hace 19 días y a día de hoy no he recibido nada. Sé que a veces los soportes no responden si ven que no guarda relación con su plugin o creen que más bien el problema es ajeno.

Cuando retrocedo de nuevo a la versión 7.4 estos errores desaparecen por completo.

¿Qué opináis?

[30-Nov-2023 20:33:32 UTC] PHP Warning: Trying to access array offset on value of type null in /home2/descalificado/public_html/wp-content/plugins/storefront-pro-premium/includes/class-public-templates.php on line 58
[30-Nov-2023 20:33:32 UTC] PHP Warning: Trying to access array offset on value of type null in /home2/descalificado/public_html/wp-content/plugins/storefront-pro-premium/includes/class-public-templates.php on line 59

Contenido solo visible a usuarios registrados

Citar
Respondido : 30/11/2023 9:49 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Tomás. 

En este caso lo que sucede como comentas es un error de compatibilidad del plugin con unas versiones PHP, para solventarlo tienes que esperar el desarrollador actualice el plugin y añada esta compatibilidad, ten en cuenta que los desarrolladores activos puede tardar algún tiempo en añadir compatibilidades de su plugin con las nuevas versiones de PHP. 

Por ahora nosotros no podemos hacer nada ya que este plugin es de pago y el error que se muestra es en el código en sí del plugin. 

Un Saludo 

ResponderCitar
Respondido : 30/11/2023 9:55 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Tomás
 Tomás
Estimable Member

Entiendo, pero si de momensto lo dejo así con esas advertencias, pasa algo?

 

Gracias de antemano.

ResponderCitar
Respondido : 30/11/2023 10:17 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Tomás, 

De momento no ya que son advertencias, debes verificar si el sitio web carga de forma correcta. Ten en cuenta que dejar la versión PHP 7.4 mientras libran nuevas versiones de los plugins tampoco debe afectar tu sitio web.

Un Saludo 

ResponderCitar
Respondido : 30/11/2023 10:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Tomás
 Tomás
Estimable Member

Es que observo que cuando dejo la versión 8.0 baja el consumo de recursos.

Gracias Karen.

ResponderCitar
Respondido : 30/11/2023 11:00 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Tomás, 

Entiendo, en ese caso puedes dejar esta versión+ y si observas no sucede nada con tu sitio web puedes mantenerla. 

Un Saludo

ResponderCitar
Respondido : 01/12/2023 12:10 am

Cursos Gratuitos WordPress