Avisos
Vaciar todo

Wordpress no carga fotos tras cambio de dominio  

 
comograbar@gmail.com
 comograbar@gmail.com
Usuario activo

Hola,

He buscado a ver si encontraba un caso similar por diferentes foros y no he sabido encontrar nada.

El caso es que acabo de cambiar de dominio temporal a domino definitivo y de repente wordpress no encuentra ninguna imagen (el navegador muestra el cuadrado con interrogante, hoja en blanco...)
Como no eran muchas, las edité una a una. Foto a foto, entrada por entrada. Me di cuenta que al insertar la imagen en la entrada, sólo faltava "http://" en la url de la imágen. Hasta aquí bien.

El problema ha surgido cuando he querido subir una imagen nueva. Al subir la foto, en la primera vista previa que enseña wordpress, ya sale el cuadrado del interrogante.
Creo que WP no sabe dónde guardar el archivo. O lo guarda en el sitio equivocado y al buscarlo no lo encuentra.

Soy un novato en todos estos temas.
Un saludo y gracias de antemano. 😉

Citar
Respondido : 19/10/2013 8:32 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola,

Se agradece que cuando formules una consulta:

- Facilites la URL "exacta" de tu sitio web, donde podamos ver el problema concreto que consultas.
- Los formatos de capturas admitidos son .jpg y .png

Saludos y gracias por tu colaboración.

ResponderCitar
Respondido : 19/10/2013 8:47 pm

Cursos Gratuitos WordPress

comograbar@gmail.com
 comograbar@gmail.com
Usuario activo

Ai sí!! No la he puesto!! Jeje
Pido disculpas.
Aquí esta: www.comograbar.com

ResponderCitar
Respondido : 19/10/2013 9:04 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Martí,

Supongo que realizaste el procedimiento del vídeo que acompaña el artículo:

- https://www.webempresa.com/blog/cambiar-wordpress-de-un-dominio-a-otro.html

¿Que url "exacta" de origen y que url "exacta" de destino indicaste?

Saludos

ResponderCitar
Respondido : 19/10/2013 9:33 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

comograbar@gmail.com
 comograbar@gmail.com
Usuario activo

Sí, seguí los pasos del tutorial.
Origen: http://comograb-cp45.wordpresstemporal.com/
Destino: http://www.comograbar.com

ResponderCitar
Respondido : 19/10/2013 9:54 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Martí,

Lo correcto habría sido:

Origen: http://comograb-cp45.wordpresstemporal.com/
Destino: http://www.comograbar.com

Se explica en el minuto 2.17 del vídeo.

Saludos

ResponderCitar
Respondido : 19/10/2013 10:03 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

comograbar@gmail.com
 comograbar@gmail.com
Usuario activo

He repetido todo el proceso del vídeo y sigo sin poder subir imágenes. Al hacer el primer cambio de url moví todo el contenido de la carpeta /public.html/home/comograb/public.html a la primera carpeta /public.html
¿Puede ser que en lugar de mover se tuvieran que copiar?
No he tocado nada por no tocar lo que no se...

ResponderCitar
Respondido : 25/10/2013 7:09 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Según entiendo no se muestran correctamente tus imágenes en el front-end de tu sitio web , indícanos la url exacta en donde no aparecen las imágenes y aprox donde debería verse (envía una captura de pantalla) , esto nos ayudará a localizar la ruta actual desde donde esta llamandose la imagen

Saludos.

ResponderCitar
Respondido : 25/10/2013 8:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

comograbar@gmail.com
 comograbar@gmail.com
Usuario activo

Al hacer el cambio al dominio definitivo ( http://www.comograbar.com), no mostraba ninguna imagen. Página por página, cambié la fuente de cada una de las fotos (IMG_5). Al cambiar un par de ellas me di cuenta que solo le faltaba "http://" al principio de la url. Lo hice con todas las fuentes y ya se mostraban todas las imágenes correctamente.

He intentado subir una imagen nueva desde "Medios" y no muestra ni la vista previa de la imagen "teclado controlador" (IMG_1).

He puesto la imagen "teclado controlador" en una de las páginas donde ya había una imagen mostrada correctamente:

He copiado la url de "teclado controlador" (IMG_2) y la he pegado en el código de la página.
Al principio del código está la imagen mostrada correctamente. Y después de los enlaces, al final del código, la imagen "teclado controlador" (IMG_3).
Esta última no se muestra correctamente en la pagina (IMG_4).
Dejo la url de dicha pagina: http://www.comograbar.com/contenidos/

En la dirección fuente de la imagen no hay nada (IMG_6)
Al subir la imagen, WP la ha guardado en la carpeta donde las guardaba antes de hacer el cambio de dominio (IMG_7)
Creo que en el proceso de cambio de dominio moví mal los archivos de public.html

Espero que sean las pistas necesarias para detectar el problema. Gracias!

ResponderCitar
Respondido : 26/10/2013 1:07 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Si estas subiendo la imagen nuevamente debería mostrarte la visualización, verifica si la imagen es correcta o cambia de formato de .jpg a .png para verificar si se corrige.

Saludos.

ResponderCitar
Respondido : 26/10/2013 5:44 pm

Cursos Gratuitos WordPress

comograbar@gmail.com
 comograbar@gmail.com
Usuario activo

He probado con los dos formatos de imagen, diferentes medidas y siempre pasa lo mismo... No se que puede ser? Si alguien sabe explicarme porqué hay dos carpetas "public.html" y porqué WP guarda la imagen en la carpeta de (IMG_7) y luego va a buscarla a la carpeta de (IMG_6).
A lo mejor es que todos los archivos tienen que estar en la otra "public.html" ?

ResponderCitar
Respondido : 27/10/2013 9:18 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Si utilizas el administrador de ficheros de tu cPanel:

Administrador de Archivos de cPanel
https://www.webempresa.com/blog/administrador-de-archivos-de-cpanel.html

Verifica si te sucede lo mismo, subelo al directorio correcto y luego llámalo desde tu Wordpress.

Saludos.

ResponderCitar
Respondido : 27/10/2013 3:36 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress