Instalación Joomla interfiere con Moodle  

 
Ignasi S.
 Ignasi S.
Usuario activo

Hola,

Tengo instalado en mi dominio www.aulainf.com un Joomla 1.5 y en una carpeta (oimak) he instalado Moodle 2.2 (www.aulainf.com/oimak)

Tengo un problema y es que al pasar preguntas de una categoría a otra me aparece un error 404.

Adjunto imágenes de los pasos que realizo:

Captura1.jpg: pantalla antes de mover preguntas de una categoría a otra
Captura2.jpg: pantalla que aparece justo cuando aprieto la opción MOU A>>

HE probado de instalar la versión de moodle 2.2.1, la 2.1.4 y la 2.0.7, y en todas las versiones da el error.

Lo curioso es que lo he probado en otras plataformas (con los mismos datos) y funciona perfectamete. No me aparece ningún error.

He enviado diferentes mensajes a soporte@webempresa.com y me han contestado:

el error que aparece en la segunda captura es el error 404 estándar de Joomla. Parece que hay algún problema la instalación de su Joomla que interfiere con su Moodle, pero no se trata en ningún caso de un problema del servidor. Por favor, formule la pregunta a través de nuestro foro para que uno de nuestros técnicos le conteste al respecto.

Podemos resolver su problema, a través del Foro exclusivo para Clientes de Webempresa.

¿Soluciones?

Saludos,

Citar
Respondido : 18/01/2012 8:09 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ignasi Sebastia,

La única posibilidad de que Joomla! interfiera con Moodle es si se utiliza Joomdle y no está configurado correctamente quien es el responsable de gestionar las categorías e ítems.

Si se utiliza Joomdle, no debe configurarse para que administre las categorías e ítems de Moodle, solamente los usuarios, de lo contrario no tiene sentido utilizar este "puente" de administración.

Malas configuraciones de Moodle cuando implementa el plugin de Joomdle dan como resultado que se interfiera sobre todo si se trata de administrar desde Moodle y no desde Joomdle.

Los errores 404 se derivan del uso de las URLs amigables en Joomla! que al utilizar Joomdle para cargar contenidos de Moodle y este último no soportar dichas urls amigables correctamente (por alguna configuración u otras razones) provoca que los ítems de Moodle que se muestran embebidos fallen al cargar.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/01/2012 8:35 pm

Cursos Gratuitos WordPress

Ignasi S.
 Ignasi S.
Usuario activo

Hola gnumax,

Tengo instalado Moodle para realizar pruebas de un proyecto que tengo en mente pero no tiene ninguna relación con Joomla (No tengo instalado Joomdle).

He seguido los mismos pasos que habéis indicado en (salvo que no tengo un dominio adicional para Moodle pero he utilizado una carpeta). De hecho la instalación se realiza correctamente pero no hay forma de mover las preguntas.

Yo me he limitado a seguir las indicaciones de soporte@webempresa.com

Lo curioso es que hago lo mismo en diferentes hostings que tengo acceso y con la misma versión y los mismos datos funciona perfectamente.

¿Qué puede pasar?

¿Queréis acceso a Moodle para poder ver el fallo?

Saludos.

ResponderCitar
Respondido : 18/01/2012 8:46 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ignasi Sebastia,

Si tal como comentas no guarda relación ninguna con Joomla! y no tienen ningún Joomla! instalado en ese mismo Hosting no veo la interferencia.

Comente lo de Joomdle por si guardaba relación ya que a veces malas configuraciones causan problemillas en cuanto a quien administra que (Joomla o Moodle) pero como no es tu caso no hay relación alguna.

No obstante, no damos soporte sobre Moodle en el Foro.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/01/2012 12:40 am

wpdoctor-revisa-la-salud-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Ignasi,

haz una prueba... renombra el fichero .htaccess de tu Joomla a .htaccess_old y vuelve a realizar el proceso de pasar preguntas de una categoría a otra para ver si ahora te sale el error 404 que nos has enviado en la captura de pantalla..

Gracias

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/01/2012 11:21 am
Ignasi S.
 Ignasi S.
Usuario activo

Hola,

Sale el mismo error:
Forbidden

You don't have permission to access /question/edit.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Saludos,

ResponderCitar
Respondido : 19/01/2012 2:01 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David Noguera
 David Noguera
Miembro Admin

Hola Ignasi,

por loq ue tengo entendido, antes te salía un error 404 y ahora te sale un error Forbidden, que es 403.. puedes enviarnos una captura como has hecho antes para que veamos el tipo de error que es?? Si es un error 403 podría ser un problema del Firewall de aplicaciones y tendría solución..

Gracias

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/01/2012 2:04 pm
Ignasi S.
 Ignasi S.
Usuario activo

Hola David,

Correcto: antes me salía error 404 - No s'ha trobat el component y ahora sale un error 403 Forbidden (imagen adjunta).

La única diferencia de antes y ahora ha sido que primero instalé el Moodle en un directorio (www.aulainf.com/oimak) y ahora lo he reinstalado en un subdirectorio (oimak.aulainf.com)

Saludos.

ResponderCitar
Respondido : 19/01/2012 3:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

OK, supondo que se refiere a un subdominio.

OK, al estar instalado en un subdominio se evita que interfiera con Joomla y no te muestra el mensaje de error que te mostraba antes, que es de Joomla.

Ahora el error que te sale seguramente es del Firewall de aplicaciones (Modsecurity), por tanto (ahora sí) has de poner un ticket de soporte hosting para que le añadamos la regla que está provocando el problema a la lista blanca de tu firewall.

Envía un ticket y atenderemos tu consulta lo antes posible.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/01/2012 3:22 pm
David Noguera
 David Noguera
Miembro Admin

Hola Ignasi,

al instalar tu Moodle en un subdominio se ha solucionado el problema que tenías con Joomla, que hacía que se mostraran algunos mensajes de error 404, ya que la URL es diferente ahora... Sin embargo después el problema que tenías era con una regla del firewall de aplicaciones ModSecurity, que estaba generando un falso positivo, hemos añadido algunas reglas a tu lista blanca y ya funciona... sin embargo nos gustaría probar de añadir algunas reglas más, por eso te hemos pedido las credenciales mediante tickets de soporte..

Entendemos que el problema está solucionado, así que cierro el post y si hay algún problema más lo atendemos mediante ticket.

Saludos!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/01/2012 10:24 am

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro