Avisos
Vaciar todo

Problema al insertar codigo de video de YouTube  

 
Mario
 Mario
Usuario experto

Buen día, desde que instale RSS Firewall no puedo insertar el código de YouTube en un modulo html personalizado.

Lo que pasa es lo siguiente, al momento de copiar el código lo hace de manera correcta, ejemplo:

Sin embargo luego de guardar el modulo se agrega automáticamente un "-" en la palabra "iframe", ejemplo:

Fui a la configuración de RSS Firewall, y desactive temporalmente el filtro Javascript, y cuando intento guardar el modulo aparece el siguiente mensaje

Solicito su ayuda, y de antemano, muchas gracias.

Citar
Respondido : 23/02/2014 12:32 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Mario,

Revisa en JCE las siguientes configuraciones:

Si no usas JCE y utilizas TinyMCE es posible que tengas prohibida la etiqueta iframe.

Accede a Gestor de Extensiones, Gestor de Plugins, "Editor - TinyMCE 2.0", eliminar en Elementos prohibidos. También puedes proceder a cambiar en el plugin de "Editor - TinyMCE 2.0" la opción Limpia el código al guardar, nunca o solo en el frontal del sitio web.

ResponderCitar
Respondido : 23/02/2014 1:01 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mario
 Mario
Usuario experto

Uso el JCE y al parecer lo tengo configurado correctamente, pero no acepta el codigo.

ResponderCitar
Respondido : 23/02/2014 1:37 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Mario,

Revisa el siguiente artículo que explica la insersión de video de manera manual:
www.webempresa.com/blog/item/745-insertar-video-manualmente-en-joomla-17.html

haz la prueba también no utilizando ningún editor. Lo deshabilitas desde el Gestor de Usuarios, tu usuario super-administrador y en la Configuración Global.

Otra opción es que en el artículo o módulo donde esté tratando de insertar el vídeo, deshabilites primero el editor [hide/show] o [toggle editor] para que no afecte al código que pegues. Si lo haces luego, una vez hayas insertado el código del vídeo ese artículo o módulo no podrás abrirlo de nuevo (una vez guardes los cambios) con el editor habilitado porque truncarás el código.

Saludos

ResponderCitar
Respondido : 23/02/2014 2:48 am

Cursos Gratuitos WordPress

Mario
 Mario
Usuario experto

La configuración es correcta, e intente con los dos editores, sin embargo sigue agregándose el "-", por lo tanto no permite el iframe. Insisto, yo he insertado varios videos mediante este método, sin embargo desde la instalación del RSS Firewall tengo este problema. 🙁

ResponderCitar
Respondido : 23/02/2014 4:02 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Mario,

Habría que ver entonces si has cambiado alguna configuración o editado reglas de RSFirewall que puedan estar afectando a código iframe que incorporas en artículos.

¿También te sucede con el editor JCE deshabilitado, es decir en modo código?.

Saludos

ResponderCitar
Respondido : 23/02/2014 5:42 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mario
 Mario
Usuario experto

Ya probé con el JCE desactivado y sigue sin guardarse correctamente, y la configuración del Firewall esta como ustedes la recomiendan en uno de sus videos. 🙁

ResponderCitar
Respondido : 23/02/2014 9:37 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Mario,

Otra alternativa si es para vídeos de Youtube y no quieres andar activando/desactivando el editor es utilizar AllVideos o AvReloaded.

- https://www.webempresa.com/blog/insertar-videos-en-articulos-con-allvideos-reloaded.html

Si tienes problemas con la comprobación de Flash y te aparece en la parte inferior, revisa este hilo de discusión:

- https://www.webempresa.com/foro/virtuemart/avreloaded

¿Son artículos de Joomla o de K2, o por el contrario se trata de un módulo Personalizar HTML?.

Saludos

ResponderCitar
Respondido : 23/02/2014 10:27 pm

wpdoctor-revisa-la-salud-de-tu-wordpress