Avisos
Vaciar todo

[Resuelto] problemas con woocommerce  

 
Miguel Angel
 Miguel Angel
Usuario activo

Hola. Tengo una web con DIVI instalado y funcionando correctamente. El problema es que instalo el plugin de woocommerce, funciona correctamente, pero cuando reviso el estado me dice lo siguiente: 

Tu tienda no est√° usando HTTPS. Aprende m√°s sobre HTTPS y los certificados SSL.

L√≥gicamente el dominio tiene el certificado de webempresa. Instalo un pluging para que¬†cargue con SSL. El pluging de woocommerce me dice que todo ok, pero la web no se ve en el navegador¬°¬°¬°¬° Carga el dominio pero no se ve la web. Desactivo pluging SSL y carga, pero woocmerce me da error... ¬ŅAlguna sugerencia?

Gracias y saludos 

Contenido solo visible a usuarios registrados

Respondido : 17/11/2020 7:53 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué plugin para SSL usas?, podrías probar otro similar, por ejemplo:
https://es.wordpress.org/plugins/really-simple-ssl/

Saludos.

Respondido : 17/11/2020 8:15 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Miguel,

Actualmente tienes la web con el complemento activo? por que ingreso a tu web y me muestra el certificado correctamente.

Puedes intentar con este otro complemento de ssl pero es raro que te de problemas el que tienes instalado https://wordpress.org/plugins/wp-force-ssl/ .

Nos comentas como te va, un saludo 🖐️¬†

Respondido : 17/11/2020 8:17 pm
Miguel Angel
 Miguel Angel
Usuario activo

Hola. He probado con el plugin que me comentas, wp force ssl pero no hace nada. El otro pligin que utilizo es Really simple SSL

Si desactivo los dos plugins de SSL funciona todo correcto pero  el estado de woocommerce me sigue dando el mismo error: Tu tienda no está usando HTTPS. Aprende más sobre HTTPS y los certificados SSL.

El problema lo tendré cuando coloque la pasarela de pago, el banco exige que este todo ok en cuanto a la seguridad... 

Gracias y saludos

Respondido : 17/11/2020 9:00 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tal vez tengas algunas urls de tu dominio en http a nivel de base de datos.

Algo que puedes evaluar es hacer una b√ļsqueda y reemplazo de estas urls, puedes usar este plugin para realizar eso:

https://es.wordpress.org/plugins/better-search-replace/

Buscaría la url en http y la cambiarías por la misma url pero con https

Saludos.

Respondido : 17/11/2020 9:13 pm
Miguel Angel
 Miguel Angel
Usuario activo

Hola. Tienes raz√≥n, seg√ļn el plugin que me indicas better search replace la web tiene el dominio don https pero la home http. (Adjunto captura)

cap 2 copia

Veo que el plugin permite cambiar la base de datos, como indicas ¬ŅSi escojo todas las tablas no habr√° problemas? (Adjunto captura)¬†

cap 3 copia

Gracias y saludos

Respondido : 17/11/2020 10:19 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Miguel,

En este caso prueba verificando directamente en el wordpress, en Ajustes > General:

image

En mi caso tengo http y no https pero comprueba que ambos estén en https y modificalo en caso de no tenerlo así, igualmente también puedes hacer el ajuste en la base de datos, simplemente ingresas a la base de datos con la que esta trabajando tu wordpress y en la tabla de wp_options los dos primeros urls son los que te comenta el sistema:

image

Un saludo 🖐️¬†

Respondido : 17/11/2020 10:33 pm
Miguel Angel
 Miguel Angel
Usuario activo

Hola. Si, era tan simple como cambiar en ajustes. Ya esta todo ok. Gracias por todo. Saludos

Respondido : 17/11/2020 10:44 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Miguel,

Encantados de poder ayudarte, si tienes alguna otra consulta recuerda crear un nuevo tema 😀¬†

Un saludo 🖐️¬†

Respondido : 17/11/2020 10:50 pm