Al pedir info de un producto ¡sale otro!  

 
Internautis
 Internautis
Usuario experto

joom 1.5.26 + vm 1.1.9

Me pasa una cosa rarísima: si entráis en la tienda, a la derecha hay un mod donde se anuncia un detector para niños
http://www.eurodetection.com/tienda/details/258/4/iniciacion/vlf2-detector-para-ninos?manufacturer_id=12

Pero al darle en el botón de ¿Tienes dudas sobre este producto? y preguntar, sale otro producto completamente diferente, (siempre el mismo) tanto en el pantallazo de "has consultado tal" como en el email que recibe el usuario y lo que es peor, el que recibe la tienda.

He revisado todo, el sku y todo, y parece estar bien y creo que ni siquiera este producto ha sido clonado del que sale en su lugar.

No tengo idea si sucede con más productos (tendré que probar por la noche, para no agobiar al cliente con 800 mails), pero me urge saber por qué pasa esto y sobre todo cómo lo puedo arreglar ya que es uno de los productos estrella para estas navidades.

Confío en vuestra sabiduría colectiva, un saludo!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 04/12/2012 7:47 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Internautis,

Si cambias la plantilla de Virtuemart el error persiste?

Saludos.

ResponderCitar
Respondido : 04/12/2012 11:15 pm

Cursos Gratuitos WordPress

Internautis
 Internautis
Usuario experto

Sí, acabo de probar con la zeolite (no con la diseñada nuestra) y sale el mismo plato big de minelab que te ha salido a tí, y con la JA_Purity también.

Bueno, vamos averiguando. Tiene que ser algo del módulo y el enlace que le he puesto al producto, porque acabo de ver que si localizo ese mismo producto desde el lateral izquierdo, en la marca Bounty Hunter, no sucede esto tan raro, haz la prueba.

Supongo que con cambiar el enlace en el módulo se arreglará el problema, pero quiero saber por qué pasa, porque una página de producto carga otro.

Gracias Johnny, haz las pruebas que quieras que luego las borro!

ResponderCitar
Respondido : 04/12/2012 11:34 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Internautis,

Yo me refería a la plantilla de Virtuemart no de Joomla adjunto una captura para mejor visualización:

Realiza la prueba y coméntanos si continua el problema.

Saludos.

ResponderCitar
Respondido : 05/12/2012 3:20 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Internautis
 Internautis
Usuario experto

La plantilla que está puesta ahí es la ja_zeolite; si pongo la default, simplemente el cuerpo central de la tienda donde debería salir el producto sale en blanco todo, así que no puedo verificar.

He revisado mucho y parece que sólo sucede con este artículo, y sólo cuando se carga desde el módulo, no cuando se accede desde el menú de las marcas. Veo que en uno y otro sitio los enlaces son ligeramente distintos:

El malo: http://www.eurodetection.com/tienda/details/258/4/iniciacion/vlf2-detector-para-ninos?manufacturer_id=12

El bueno: http://www.eurodetection.com/index.php/tienda/details/258/4/iniciacion/vlf2-detector-para-ninos?manufacturer_id=12

¿Va a ser ese /index.php/ que falta en el "malo"? ¿Eso puede hacer que "salte" a otro producto completamente distinto? Ahora pruebo y os informo.

ResponderCitar
Respondido : 05/12/2012 9:18 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Internautis,

Tienes las url's amigables parcialmente activadas, lo correcto es que no muestren ese index.php en la url.

Procede a activar en la configuración global de Joomla --> parámetros de SEO --> Usar la reescritura URL --> si.

Saludos

ResponderCitar
Respondido : 05/12/2012 9:25 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Internautis
 Internautis
Usuario experto

Pues sí, era eso. ¿Alguna explicación racional?

Esto demuestra mi teoría de que si el ordenador no funciona hay que empezar mirando si está enchufado... Al final ha sido lo más simple, y lo que nunca se mira.

Muchísimas gracias por estar ahí, da la confianza para seguir tocando y probando en la seguridad de que hay alguien al otro lado para corregir nuestros errores!

ResponderCitar
Respondido : 05/12/2012 9:32 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Internautis,

No puedo hacer una análisis retrogrado, se visualiza el problema presente y se busca solución.

Nos alegra que te guste nuestro servicio.

Normalmente solicitamos testimonios para colocar en nuestra página y ayudar a otros posibles clientes a decidirse: https://www.webempresa.com/testimonios.html

Si nos quieres enviar tu testimonio podemos colgarlo en nuestra página con un link hacia la tuya que siempre te ayudará a posicionarse porque nuestra página tiene un Page Rank de Google alto.

En este artículo de nuestro blog se explica como dar de alta un testimonio:

Saludos

ResponderCitar
Respondido : 05/12/2012 9:52 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación