error al crear producto Virtuemart  

 
Enrique
 Enrique
Famed Member

Buenas tardes, cuando me meto en virtuemart, en crear producto o modificar uno existente, me sale un error y no se me muestra vez la interfaz gráfica...
Aquí les dejo una imagen del error...

Saludos, Enrique P.

URL del sitio: http://www.informaticapavon.net/desarrollo/auto

Citar
Respondido : 09/07/2012 12:55 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Parece que el problema lo tienes con el editor de artículos de Joomla que estás utilizando, de forma que se haya seleccionado alguna opción que no existe o esté mal instalado o dañado.

En la administración de Joomla vete a Sitio->Configuración Global. En el campo Editor WYSIWYG predeterminado prueba a seleccionar otro editor y guarda los cambios. Después prueba de nuevo a entrar en la ficha de producto para comprobar si te funciona.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/07/2012 1:37 pm

Cursos Gratuitos WordPress

Enrique
 Enrique
Famed Member

Buenas Pablo, yo tengo como predeterminado JCE, y lo he cambiado por el tymce pero me sigue dando el mismo error..

Saludos, Enrique P.

ResponderCitar
Respondido : 09/07/2012 2:00 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Puede que el problema pueda estar el algún plugin para el editor que hayas podido instalar y que no esté funcionando correctamente, de forma que provoque el error.

Mira el siguiente enlace y prueba la solución que aquí se plantea:

http://whatisgon.wordpress.com/2012/05/04/fixing-call-to-undefined-method-stdclassondisplay-error-in-joomla/

Antes de aplicar cambios en los archivos recuerda hacer una copia de seguridad de lo que vayas a cambiar. También puedes probar antes a desactivar los últimos plugins que hayas podido instalar para ver si el problema se soluciona.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/07/2012 2:13 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Famed Member

Buenas Pablo, he comentado la lineas que me comentas y vuelvo a entrar en la administración de virtuemart y no sale ningún error. Esa línea la tengo que dejar comentada o solo era para probar?

Saludos, Enrique P.

ResponderCitar
Respondido : 10/07/2012 7:40 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Enrique,

Si has realizado los cambios indicados en http://whatisgon.wordpress.com/2012/05/04/fixing-call-to-undefined-method-stdclassondisplay-error-in-joomla/ ¿no te muestra en pantalla el nombre del plugin que produce el error?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 10/07/2012 8:24 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Famed Member

Hola Jordi, no me muestra nada el editor y ya está, pero tengo esa linea comentada. La vuelvo a descomentar?

Saludos, Enrique P.

ResponderCitar
Respondido : 10/07/2012 8:50 am
Enrique
 Enrique
Famed Member

Buenas, me acabo de dar cuenta que también me falla al modificar cualquier artículo, lo he vuelto a descomentar y me da el mismo fallo? pero si lo desactivo no me dice que plugin tengo mal o algo...

Saludos, Enrique P.

ResponderCitar
Respondido : 10/07/2012 9:22 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Enrique, aquí comentan lo que han hecho para solucionar el problema:

http://www.syswoody.com/joomla/fatal-error-call-to-undefined-method-stdclassondisplay-in-usrhomeclubderugbysantanderwwwlibrariesjoomlahtmleditorphp-on-line-268

El problema viene por los editores que tenemos instalado uno de ellos esta dando problemas en mi caso fue el JCE.

Mis solucion final paso por desinstalar el componente ir a configuracion global y poner el editor tyni por defecto, una vez pruebas que todo vuelve a la normalidad, en gestion de articulos procedes a instalar de nuevo el componente. y vuala ya funciona.

Prueba como indican en esta web..

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/07/2012 9:52 am
Enrique
 Enrique
Famed Member

Buenas David, he desinstalado JCE, y antes de volverlo a instalar he probado seleccionando el tyni y me sigue saliendo el mismo error, después he vuelto a instalar el componente JCE y lo he seleccionado y también sigue apareciendo el mismo error...

Saludos, Enrique P.

ResponderCitar
Respondido : 10/07/2012 10:08 am

Cursos Gratuitos WordPress

David Noguera
 David Noguera
Miembro Admin

OK, a ver, haz una prueba, hazte una copia de tu Joomla en un directorio a parte, y descomprime un Joomla 1.5 limpio de la última versión encima, después elimina el directorio installation.

Después accede al Joomla que tienes en el nuevo directorio y revisa si sigue pasando el mismo error...

Así comprobaremos si se trata de un error provocado por algún fichero del core de Joomla que se haya modificado...

Saludos!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/07/2012 10:32 am
Enrique
 Enrique
Famed Member

Hola David, he realizado lo que comentas y ahora no me sale el error...

Saludos, Enrique P.

ResponderCitar
Respondido : 10/07/2012 12:08 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Todo parece indicar en que el problema está en algún plugin de editor de Joomla. Para comprobarlo vete en la administración de tu Joomla a Extensiones->Gestor de plugins. Encima del listado de plugin, en la parte derecha, aplica el filtro por tipo seleccionando la opción editors-xtd y prueba a desactivar los plugins. Después comprueba si el problema se soluciona. De ser así el problema estará en uno de estos plugins. Puedes ir probando en activarlos de uno en uno para tratar de localizar el que de problemas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/07/2012 2:07 pm
Enrique
 Enrique
Famed Member

Buenas Pablo, ya me funciona, he tenido que desactivar todos los plugins del tipo editor-xtd menos este: Editor Button - Modules Anywhere. Entonces el problema no era del editor JCE.

Saludos, Enrique P.

ResponderCitar
Respondido : 16/07/2012 9:35 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro