Modificar url de imagen detalle porqué no la ubica bien  

 
Alceste
 Alceste
Noble Member

Hola, cambiamos la tienda de dominio por lo que hice un clon. Todo funciona bien excepto una cosa. Cuando clicas en una imagen de detalle no la amplía y he visto que es porque no la encuentra, pero está. El porblema es que en el inicio de la ruta no ha cambiado el nombre de dominio.

Las imagenes estan en dominioactual/components/com_virtuemart/shop_image/product/

Pero las busca en: doninioviejo/components/com_virtuemart/shop_image/product/

Mi pregunta es: ¿Tengo que volver a cargar estas imagenes desde cero o puedo arreglarlo de otro modo?

Aquí tenéis un enlace a una imagen con este problema:

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/08/2012 11:32 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alceste,

Es posible que estéis trabajando con un dominio incorrecto en Virtuemart, https://www.webempresa.com/blog/errores-acceso-a-la-administracion-de-virtuemart.html ya que parece que busca cargar en el dominio acudam.com

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 29/08/2012 12:13 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola,
¿Es eso posible si tengo en las dos casillas de la pestaña seguridad el URL correcto? Adjunto imagen
Editando el archivo administrator/components/com_virtuemart/virtuemart.cfg.php sí veo que aparece el dominio viejo. Si pongo el dominio correcto dbería funcionar, ¿no? Creo que lo he corregido, pero la imagen sigue sin ampliarse

ResponderCitar
Respondido : 29/08/2012 12:43 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alceste,

Hay algo que no cuadra. Al visualizar las url's de la pestaña de seguridad de la configuración de Virtuemart, tiene que mostrar las mismas que las del archivo virtuemart.cfg.php, ya que precisamente esa pantalla muestra las url's de ese archivo.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 29/08/2012 2:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola Jordi,
Por eso me extraña. Además, si subo de nuevo la imagen la coge bien. Voy a enviar un ticket a soporte para no publicar datos internos. Saludos

ResponderCitar
Respondido : 29/08/2012 5:09 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Alceste

No creo que sea un tema de problemas al momento de pasar tu sitio a nuestros servidores.

Salvo sea por versión de PHP o algún parámetro en PHP.ini, pero en ambos casos dudo eso.

Por otro lado creo que es más bien un tema de configuración, asegúrate de que tus urls se encuentren correctamente colocadas, revisa el link que te envió Jordi.

También es posible , aunque esto tendrías que confirmarnos, si en tu sitio hay alguna extensión diferente que se integra con virtuemart o has realizado algún cambio de archivos relacionados con imágenes que utilicen urls absolutas, en este caso tendrás que modificar también estas urls.

Si sigues con problemas envíanos una url de producto para verificar lo que comentas , también alguna captura de pantalla de la configuración del vm o de tu producto puede ayudar.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/08/2012 6:35 pm

Cursos Gratuitos WordPress

Alceste
 Alceste
Noble Member

Hola,
Continuo sin hallar el problema, pero miré mel archivo virtuemart.cfg.php en la carpeta equivocada. En la carpeta de este dominio las url del archivo coinciden con las de la pestaña de seguridad de la configuración de Virtuemart :blush:

Tambien he intentado solucionarlo con el siguiente cambio en la parte donde se indican las urls en virtuemart.cfg.php

define( 'URL', $mosConfig_live_site.$app );
define( 'SECUREURL', $mosConfig_live_site.$app);

Con este cambio tampoco se amplia la imagen de detalle.

En vista de esto, me inclino por algun problema con extensiones pero no sé cuales pueden afectar. Las últimas en instalar han sido Awocupon, RokBox (Deshabilitada), AcyMailing, REDj, Tagmeta y VirtueMart category price changer

He deshabilitado todo esto, he desinstalado VirtueMart category price changer y el problema persiste. ¿Podría ser que al hacer el clon no se modificara la ruta de las imagenes de detalle que se suben a VirtueMart y por tanto en el inicio de la ruta conserve el dominio viejo? Porqué si cargo las imagenes de nuevo se muestran bien

ResponderCitar
Respondido : 29/08/2012 7:12 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alceste,

Dudo que se haya modificado por si solo las rutas, el clon ¿Cómo lo realizaste?. Si lo hiciste manualmente es posible que se haya producido perdida de datos por lo que te recomendaría probar la copia y restauración con Akeeba Backup.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/08/2012 4:08 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola, El clon lo hice hace tiempo y todo funciona bien excepto esto. Si no encuentro otra solución, prefiero cargar de nuevo las imagenes de detalle para que las úbique bien y puedan verse las ampliaciones. Lo raro es que la imagen de detalle aparece, pero cuando quieres ampliarla no responde, se abre la ventana de ampliación pero no la localiza. Y si lo miro por la parte del administrador parece tampoco la localiza, pero la imagen está en el directorio de la ruta.

Cuando inspecciona la imagen sin ampliar con Firebug me muestra esto:
Contenido solo visible a usuarios registrados

La solución que he encontrado por ahora es entrar al producto des del administador, clicar en imagenes adicionales y modificar el inicio de la ruta que aparece en "Archivo URL (opcional)" cambiando http://acudamco-cp46.webjoomla.es por http://www.cortinaestor.es

En este enlace hay un ejemplo actual

Saludos

ResponderCitar
Respondido : 30/08/2012 7:32 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alceste,

Ahora se muestra correctamente.

https://forum.virtuemart.net/index.php?topic=75240.0 pero hacen falta conocimientos de SQL.

http://forum.virtuemart.net/index.php?topic=59414.0 es una opción que indican de como realizar con CSVI.

Si ves complicadas estas soluciones, lo mejor es que realices uno por uno si no tienes muchos productos.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 30/08/2012 8:04 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Gracias. Iré modificando las urls. Tengo algunos conocimientos de SQL pero prefiero no jugármela 🙂
Me consuela ver que no he sido el único con este problema porque temía que fuera a causa de algún error mio.
Saludos!

ResponderCitar
Respondido : 30/08/2012 8:16 am

Por favor Iniciar Sesión o Registro