Envio de facturas de forma automática al cliente tras actualización a 2.0.16  

 
Javier
 Javier
Estimable Member

Hola compañeros.

Resulta que tras la actualización a VM 2.0.16 cuando se hace un pedido (alguien compra algo) y aún está pendiente de confirmar, vamos que su estado es "Pendiente" y no se puede verificar el pago realizado. VM manda una especie de primera página de la factura con un formato un poco diferente al que se obtiene al pinchar sobre el logo de factura pdf en el apartado de "Pedidos" de VM. Esta primera página de la factura se envía en forma de archivo pdf adjunto tipo "vminvoice_????????.pdf" con el mail de pedido.

Esto no lo hacía antes, simplemente mandaba el mail con la información del pedido, pero no la primera página de la factura.
Para mí esto no tiene sentido dado que la factura solo ha de emitirse una vez se confirme el pago.

¿Es eso normal? ¿Cómo puedo eliminar ese archivo adjunto, o modificarlo para que sea albarán?

Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 26/12/2012 11:10 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He realizado una prueba de compra con la versión 2.0.16 de Virtuemart y no veo que me envíe la factura con el pedido.

Lo más probable es que el problema se deba a la configuración que tienes en la tienda. Vete a la administración de Virtuemart y entra en el apartado Configuración. Pulsa en la pestaña Compra y verifica en el parámetro Estado por defecto para enviar una factura los estados que tienes. En principio deberías dejar la opción del envío de factura solo para los pedidos confirmados.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/12/2012 11:58 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Javier
 Javier
Estimable Member

Tienes razón Pablo,

Tenía el VM configurado para que hiciera eso, el caso es que antes no funcionaba y ahora cuando he mandado mi primer pedido con la actualización de VM hecha me he sorprendido.
Ya lo he arreglado y he puesto este parámetro correctamente.

Mil gracias y perdona por la consulta chorra.

Saludos.

ResponderCitar
Respondido : 26/12/2012 2:31 pm

Por favor Iniciar Sesión o Registro