Fallo en el módulo de registro de plantilla B&W  

 
Jose Luis
 Jose Luis
Estimable Member

al habilitar el módulo de registro (el del candado superior) en la plantilla B&W mediante mod_gk_register aparece la info de login, pero el botón de REGISTRO no tiene actividad alguna. He visto que otra persona tuvo el mismo problema en el foro, pero al final no hay respuesta a ello.

De todos modos ese módulo, aunque está bien, no es lo visible e intuitivo que cabría esperar, por lo que no sé si finalmente habilitar el registro en otra posición ¿sería posible? he intentado colocarlo en otra posición y la web, si se varía de la posición register, no carga.

Un saludo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 01/09/2013 8:59 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose Luis,

¿Te refieres a este post?

- https://www.webempresa.com/foro/16-Pack-Tienda/74006-Como-poner-este-modulo-de-la-plantilla-Black-y-White-2.html

Adicionalmente revisa este hilo:

- https://www.webempresa.com/foro/16-Pack-Tienda/74317-Modulo-de-registro-en-plantilla-blackWhite.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/09/2013 9:29 pm

Cursos Gratuitos WordPress

Jose Luis
 Jose Luis
Estimable Member

si, me refiero a lo que comenta en el segundo caso en los enlaces que muestras. No tiene actividad alguna el módulo de registro que la plantilla muestra en el candado superior derecho. Si hago como que un nuevo usuario se quiere dar de alta desde ese apartado, el botón REGISTRO no muestra actividad alguna al pulsarlo. Adjunto captura de pantalla del botón que no tiene acción alguna.

He comprobado que en registro de usuarios de JOOMLA está habilitado y el módulo en cuestión está publicado en posición REGISTER.

ResponderCitar
Respondido : 01/09/2013 10:36 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose Luis,

Parece que NO tienes habilitado o definido el reCAPTCHA para el formulario de Registro.

>> ReferenceError: showRecaptcha is not defined

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/09/2013 11:18 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose Luis
 Jose Luis
Estimable Member

pensé en principio que era eso, pero hay un lío de captchas entre el de la plantilla y el nativo de joomla. En el de la plantilla (System - GKreCaptcha) si se activa al principio pedía la key de recapcha...puse el que venía por defecto en el otro (Captcha - ReCaptcha) y si activaba los dos, me sigue sin funcionar el botón...si activo el GK re Captcha me salen dos botones de registro, y el segundo me lleva a otro formulario con el captcha (el capcha no aparece en el formulario superior) si activo sólo el recaptcha no funciona el botón.. si desactivo los dos, obviamente, no funciona tampoco. En las opciones de gestor de usuarios sólo me permite usar como captcha el recaptcha (no aparece el otro) y en la plantilla de B&W no he encontrado ninguna opción que implique modificar el comportamiento.

Gracias de antemano.

ResponderCitar
Respondido : 02/09/2013 10:18 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jose Luis,

Indican que no es necesario el uso del plugin de gk-recaptcha en Joomla! 2.5:
https://www.gavick.com/documentation/joomla-extensions/extensions-for-joomla-1-6/gk-recaptcha/
http://www.gavick.com/forums/security-and-configuration/gk-recaptcha-plugin-12800.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 02/09/2013 10:58 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose Luis
 Jose Luis
Estimable Member

Ok, pero si uso el RECAPTCHA no aparece. En la actualidad tengo el PLUG RECAPTCHA ACTIVADO, en opciones de usuarios seleccionado. He puesto una clave para el dominio, luego me he dado cuenta de que estoy en pruebas y he puesto clave con el dominio de pruebas: en ninguno de los dos casos aparece el captcha en el formulario del candado de arriba. He llegado a la conclusión de que:

- EL CAPTCHA EN EL FORMULARIO DE LA PLANTILLA SÓLO FUNCIONA SI SE ACTIVA GK RECAPTCHA CON RECAPTCHA ACTIVADO, con lo que al registrarse te manda al formulario de registro ordinario de Joomla y encima el Captcha suele dar error.

- LO MEJOR ES DESACTIVAR EL GK RECAPTCHA y LA OPCIÓN DE REGISTRO DEL CANDADO en el módulo GK REGISTER.

Al final el problema era de diseño de la plantilla claramente.

Gracias de todos modos.

ResponderCitar
Respondido : 02/09/2013 12:39 pm

Por favor Iniciar Sesión o Registro