Avisos
Vaciar todo

Modulo de búsqueda de Virtuemart  

 
Alex
 Alex
Estimable Member

Tengo un problema con el buscador de virtuemart.

Cuando hago una búsqueda de los productos y me da el resultado me aparece encima del resultado de la búsqueda otra caja en la que pone "escoger tipo de procuto" o dejarlo en blanco y volver a buscar dándo al botón de "buscar en tienda" Cuando vuelvo a hacer la búsqueda dándole a ese botón me da un error 404

Yo importo la información de los productos con CSV Improved, pero por si acaso he hecho una prueba con los datos de ejemplo y me vuelve a dar el misno resultado.

Tengo activado el SH404Sef pero lo desactiver por si acaso y me da el mismo error.

¿Sabeis a que puede ser debido?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 15/11/2012 7:51 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alex,

He intentado comprobar lo que indicas, pero en tu sitio web Contenido solo visible a usuarios registrados no se visualiza ningún virtuemart instalado.

Saludos

ResponderCitar
Respondido : 15/11/2012 9:32 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alex
 Alex
Estimable Member

Ahora ya está puesto. Esta direccion es donde realizo todas las pruebas. Pero ahora no lo tenia instalado.

Ya verás que cuando realizas una búsqueda y luego le das otra vez a "busca en tienda" tambien da error 404. Están los datos de ejemplo instalados.

ResponderCitar
Respondido : 15/11/2012 10:26 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Parece que se trata de un bug que contiene Virtuemart 2.0. Para arreglarlo tendrás que editar el archivo components/com_virtuemart/views/category/tmpl/default.php. Aquí localiza la línea con el siguiente código:


Justo debajo añade la siguiente línea:


De esta forma, te tendrían que funcionar las búsquedas donde ahora te está fallando.

ResponderCitar
Respondido : 15/11/2012 3:55 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alex
 Alex
Estimable Member

Ok, arreglado.

Lo raro es que nadie se haya dado cuenta de esto, ¿no?

A ver si con la siguiente versión lo solucionan

ResponderCitar
Respondido : 16/11/2012 1:57 pm