Avisos
Vaciar todo

Navegador en imagenes y zoom  

 
LHW
 LHW
Estimable Member

Buenas tardes!
Tengo un problema con las imágenes en las páginas de detalles de los productos de la tienda:

Ocurre lo siguiente:
En cada producto hay metidas distintas imagenes:

La imagen principal se ve grande (perfecto) y si pulsas sobre ella se amplia (perfecto tambien)

Pero las pequeñas se quedan en pequeño

Me gustaria que las imagenes pequeñas se pudiesen ampliar al pulsar sobre ella, como en la segunda captura, o, en su defecto, que haya un navegador de imagenes en la imagen principal para que se viesen en grande.

Me tiene mosqueada lo siguiente: al posar el cursor sobre alguna de las imagenes pequeña, aparece la "mano" sustituyendo al puntero, como si fuese posible abrir la foto http://www.piscilandiapiscinasdesmontables.com/barcas-hinchables-y-kayak/kayak/kayak-doble-hidroforce-ventura-330-x-94-cm-detail mando enlace para que lo veais.

¿Como puedo conseguirlo?
Gracias.
Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 22/09/2015 10:26 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Las imágenes pequeñas deberian verse grandes, el hecho de que te muestre la mano pero no se amplie es por que hay un problema javascript o un conflicto con algún otro plugin, tendrías que probar deshabilitando los plugins que tienes y verificar, podrías tambien cambiar temporalmente de theme y verificar si te sucede lo mimo

Verifica si dentro de los archivos del theme que usas tienes una carpeta woocommerce, podrías probar tambien renombrandola

Saludos

ResponderCitar
Respondido : 22/09/2015 11:19 pm

Cursos Gratuitos WordPress

LHW
 LHW
Estimable Member

Buenas tardes,
Disculpad la tardanza en contestar.

Seguimos con este problema. Después de darle muchas vueltas, he localizado, mas o menos, de donde viene, pero no se como solucionarlo.

Ocurre lo siguiente:
Cuando cargamos un producto e introducimos las imágenes, la primera imagen (la principal, la que Si se abre) se carga con su nombre y extensión.
Por ejemplo: imagen1.jpg
Esta primera imagen no da problemas.

El resto de imagenes del mismo producto (las que tienen el "fallo" de no ampliarse), se cargan con su nombre y extensión, pero al guardar automáticamente le añade al titulo un: _product
Es decir: el titulo de la imagen queda asi: imagen2.jpg_product

En el administrador de archivos media o dentro de las imagenes del productos, si intentas eliminar el "_product" y guardas, se vuelve a añadir automáticamente (no guarda los cambios en este sentido)
Cuando cambias, dentro del administrador de virtuemart, de imagen principal, a "la nueva imagen principal" le desaparece la coletilla _product, pero se le añade a la otra imagen.

Es decir: unicamente se le añade automaticamente _product a las imágenes secundarias, y son las que no se abren.

Las rutas donde se alojan estas imagenes:
/home/piscilan/public_html/images/stories/virtuemart/product/ :: Escribible
/home/piscilan/public_html/images/stories/virtuemart/product/resized/ :: Escribible
Las he revisado, y, en ellas, los archivos no incluyen el dichoso _product (acaban todas en jpg)

Y en ese punto estoy: Perdida en el día de la marmota... porque mi intuición me dice que ahí está el fallo, pero todas las vueltas me llevan al punto de partida. Y no avanzo.

¿Sabeis como puedo solucionarlo?
Gracias
Saludos

ResponderCitar
Respondido : 11/11/2015 6:40 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Pero en código no veo que se contatene _product al final del nombre, además la imagen si existe

Por ejemplo en esta url :
Contenido solo visible a usuarios registrados

Podría ser un problema de algún javascript de tu plantilla o alguna extension que tengas en tu sitio web que te esta cargando javascript y entra en conflicto, tendrías que probar cambiando de plantilla y también ir desactivando extensiones

Saludos.

ResponderCitar
Respondido : 11/11/2015 8:36 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress