Avisos
Vaciar todo

Url amigable en producto  

 
Jose
 Jose
Usuario experto

Hola no consigo que me aparezcan las url amigables en los productos, he buscado soluciones por el foro y no veo como solucionarlo.
En la configuracion Global del seo tengo activado las urls amigables y la reescritura de urls.
En la configuarcion SEO de virtuemart siguiendo las instrucciones del foro, tengo des habilitado usar id de productos y categorias y traducir strings.
Comentaros que he ido probando las combinaciones en configuracion seo de virtuemart y tengo la sensacion de que no cambia nada cuando yo cambio algun parametro.
Tampoco me añade el sufijo seo, a pesar de que lo he probado con "_botellines", ""-botellines",""botellines".
He substituido el archivo router.php que recomendasteis en el foro.
Lo curioso es que solamente fallan en los productos, porque hasta con las categorias parece funcionar bien.
Muchas gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 30/11/2012 2:28 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Jose,

Envíanos una captura de pantalla de la primera pestaña de la Configuración Global de Joomla y otra de la pestaña SEO de apartado Configuración de Virtuemart para que podamos ver cómo lo tienes.

Saludos.

ResponderCitar
Respondido : 30/11/2012 3:04 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose
 Jose
Usuario experto

Os adjunto las dos capturas

ResponderCitar
Respondido : 30/11/2012 3:13 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Jose,

Tu problema se parece un poco al del siguiente usuario: https://www.webempresa.com/foro/16-Pack-Tienda-Joomla/62196-URLs-amigables-25Virtuemart.html , verifica los 3 últimos post.

Saludos.

ResponderCitar
Respondido : 30/11/2012 3:34 am

Cursos Gratuitos WordPress

Jose
 Jose
Usuario experto

Si ciertamente es muy parecido. Lo cierto es que ya visite ese post, yo tambien tengo dos layouts, pero la diferencia es que tengo la ultima actualización de vm.
Tengo la 2..0.14

Gracias

ResponderCitar
Respondido : 30/11/2012 3:39 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Jose,

No me refería tanto a eso sino a lo que menciona en el post Pablo:

En principio parece que todo está bien. El problema podría estar en los elementos de menú que estén cargando partes de Virtuemart, de forma que esto afecte a las urls amigables.

A modo de comprobación, podrías probar a dejar activado un único elemento de menú para Virtuemart, de forma que cargue la página de inicio de la tienda, y comprobar si de esta forma se muestran correctamente las urls amigables.

Saludos.

ResponderCitar
Respondido : 30/11/2012 4:15 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose
 Jose
Usuario experto

Hola, he desactivado todos los elementos del menú que hacían referencia a las diferentes categorias, y solo dejo un elemento que hace referencia a la pagina principal de la tienda(catálogo).
Pero el problema se me agrava, ahora ni siquiera las categorias me devueleven una url amigable,
Por lo que he probado si enlazo a las categorias de forma individual con diferentes elementos del menu, la url que me devuelve para la categoria es correcta aunque no para los artículos.

Cuando dejo el enlace solo a la pagina de inicio de la tienda, me aparecen las categorias, pero al ir a cualquiera de ellas la url ya no es amigable.

Gracias

ResponderCitar
Respondido : 30/11/2012 3:05 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Tendrías que probar a volver a dejar desactivados todos los elementos de menú de Virtuemart desactivados excepto el principal.

Lo más probable es que ahora el problema lo tengas en que, tal como habías comentado, has cambiado el archivo router.php por otro que habíamos indicado en el foro. Casi con toda seguridad esa indicación se hizo para Virtuemart 1.1 y tú estás usando Virtuemart 2.0, por lo que ese cambio no es compatible. Tendrías que volver a dejar el archivo router.php que había originalmente y comprobar si así se muestran las urls amigables.

ResponderCitar
Respondido : 30/11/2012 4:32 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose
 Jose
Usuario experto

Lo cierto es que yo hubiese dicho que ya lo había probado y estaba a punto de contestaros diciendo que ya lo había vuelto a poner el archivo router.php para la versión 2 de virtuemart
Pero antes de escribir he pensado en volver a intentarlo y por fin se ha quedado solucionado.

Supongo que cuando lo intenté debí por error volver a colocar el router.php de la version 1.

Muchas gracias por todo.

Saludos.

ResponderCitar
Respondido : 30/11/2012 6:40 pm