URL que no cambia de idioma en VirtueMart  

 
valentin
 valentin
Honorable Member

Si yo tengo la url en español:

http://www.hardwareshop.es/es/tienda/informatica/procesadores/sobremesa

que es 100% correcto

Y en Portugués tengo:

http://www.hardwareshop.es/pt/tienda/infomatica/processadores/desktop

99.9% correcto. No entiendo por qué en vez de loja, me aparece tienda

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 24/08/2012 11:46 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Valentin,

¿ Tienes marcada la opción de Traducir strings en la configuración de SEO de Virtuemart?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 24/08/2012 12:05 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

valentin
 valentin
Honorable Member

Lo tengo activado, pero sigue igual.

ResponderCitar
Respondido : 24/08/2012 12:25 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Valentin,

Veo que a nivel Joomla la url en Portugués se conforma de forma adecuada, no así cuando se accede a productos de VirtueMart.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/08/2012 2:41 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

valentin
 valentin
Honorable Member

Si, eso lo había visto, pero necesito que ponga lo de Loja. En la versión anterior de la web lo ponia. El problema que tengo es que lo necesito así, porque si no, no me listan en los comparadores de precio de portugal.

ResponderCitar
Respondido : 24/08/2012 4:35 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El tema de "tienda" y "loja" en la url ya te lo había contestado en el siguiente post:

https://www.webempresa.com/foro/30-VirtueMart-20/70026-Url-amigables.html#70079

Veo que ya has cambiado cosas porque al cambiar al portugués sí que se carga lo de hardwareshop.es/pt/loja, pero al entrar en página interiores navegando por categorías se pierde el "loja" y regresa el "tienda". Esto podría estar provocado porque la tienda queda asociada con el id de item de menú de la tienda en español, y de ahí cambia el alias. De ser así, no tengo claro que esto pueda tener solución.

Comprueba que el elemento de menu Tienda para el español esté publicado solo para el idioma español. De ser así, y solo por verificación, prueba a cambiar el alias por "shop" para ver si se aplica para la tienda independientemente del idioma. Entiendo también que el elemento de menú del portugués está asociado con la tienda.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/08/2012 4:36 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

valentin
 valentin
Honorable Member

Vale, lo tengo arreglado. El asunto es que a lo mejor no lo tengo bien configurado. Te adjunto unas capturas para ver si está bien.

ResponderCitar
Respondido : 24/08/2012 5:19 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Valentín,

Teóricamente está bien configurado pero ¿que diferencia hay entre la captura "gestor2.jpg" y "gestor4.jpg"?

Ya que veo lo mismo pero con asignaciones diferentes.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/08/2012 10:22 pm

Cursos Gratuitos WordPress

valentin
 valentin
Honorable Member

Ya está todo ok.

ResponderCitar
Respondido : 27/08/2012 12:26 am

Por favor Iniciar Sesión o Registro