Campos registro  

 
Oscar
 Oscar
Usuario activo

Buenas: He estado buscando algo sobre mi problema pero no encuentro que le haya pasado a alguien. Pues el problema es el siguiente:

- Cuando voy a registrame desde el módulo de registro de VirtueMart, dependiendo del navegador, me salen unos campos y otros no. Me salen los que tienen que salir desde Opera y Mozilla pero no desde el Explorer.

Yo no me había dado cuenta porque uso Opera/Mozilla en ordenadores distintos, pero al hacer la prueba con Explorer salen menos campos .

Adjunto documento con lo que sale en cada navegador. He revisado los campos de usuario desde la administración y creo que está bien.

Muchas Gracias y un saludo

This topic was modified hace 8 meses por Gerard Martínez
Citar
Respondido : 05/10/2010 12:26 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola jorospa

He revisado tu web y efectivamente existe un problema en el IE, pero que tiene que ver con el archivo de estilos.

Es decir en el archivo de tema por defecto
/components/com_virtuemart/themes/default/theme.css

Busca este código:

.formLabel {
	float:left;
	width:30%;
	text-align:right;
	font-weight: bold;
	margin: 2px;
	white-space: nowrap;
	clear: left;
	vertical-align: middle;
	margin-top: 8px;
}

Si te das cuenta tienes dos instrucciones float, eliminando el float:left podras visualizar en IE, y procura formatearlo de otra manera.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/10/2010 7:00 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Oscar
 Oscar
Usuario activo

Sólo veo un float. ¿Debo borrar float left?

.formLabel {
float:left;
width:30%;
text-align:right;
font-weight: bold;
margin: 2px;
white-space: nowrap;
clear: left;
vertical-align: middle;
margin-top: 8px;
}

¿
y dejarlo asi?

.formLabel {
width:30%;
text-align:right;
font-weight: bold;
margin: 2px;
white-space: nowrap;
clear: left;
vertical-align: middle;
margin-top: 8px;
}

De todas las maneras, no he tocado nada. Instalé VirtueMart desde el Pack Empresa de webempresa.

Gracias

ResponderCitar
Respondido : 05/10/2010 7:12 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes razon, confundí el float por el clear :).

Si, en efecto prueba comentando o borrando ese float:left.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/10/2010 7:39 pm

Cursos Gratuitos WordPress

Oscar
 Oscar
Usuario activo

He quitado el primero float:left y me sale desde Mozilla lo siguiente (te adjunto pantallazo). Luego probaré con IE porque no lo puedo entrar en este ordenador con el IE a Internet.

Luego lo probaré, desde el de casa y te digo como va.

Muchas Gracias

This post was modified hace 8 meses por antonio
ResponderCitar
Respondido : 05/10/2010 7:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola jorospa

Eso es un comportamiento esperado, ya que quitaste el float, pero como te comenté ahora se ve en IE pero habra que buscar un formato en el CSS que cumpla en ambos.

Por otro lado estuve revisando en mi extensión descargada de internet el archivo que te comenté y es idéntico al de web empresa; por lo que supongo que el estilo float:left tiene un conflicto con los estilos que usas en tu template.

Prueba en IE y me comentas.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/10/2010 8:01 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Oscar
 Oscar
Usuario activo

jmarreros:

Buenos dias, todo ha ido correctamente como me has indicado, pero tengo una más, cuando saco los productos y tienen más de uno en una categoría sólo me visualiza 1 producto (sólo me pasa con IE). Para no estar más liado con este tema porque creo que cuando no sea una cosa, será otra, ¿Me puedes aconsejar un template para virtuemart que funcione para IE y Mozilla, e intento adaptarlo con los dibujos, colores, etc de mi página?.

Muchas Gracias

ResponderCitar
Respondido : 06/10/2010 10:07 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola jorospa

Para tener una buena plantilla tendras que invertir un poco, puedes revisar el siguiente post de este foro en donde se recomienda entre otras el ja_zeolite.

¿que-plantilla-me-aconseja

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/10/2010 2:51 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro