Error al marcar las casillas de optimización de se  

Página 1 / 2
 
daniel
 daniel
Estimable Member

Hola.
Al marcar las 3 casillas de optimización de seo me da error 404.
Aque puede ser debido.
Un saludo.

Citar
Respondido : 31/12/2010 1:00 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola danny.

Verifica que el archivo htaccess.txt se encuentre renombrado a .htaccess,
esto es en caso de estar corriendo la aplicación en un servidor web apache.

Si estas corriendo en IIS (Servidor web Internet Information Server), esta opción no funcionará.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/12/2010 3:35 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

daniel
 daniel
Estimable Member

Hola.
El archivo htaccess.txt no se encuentra renombrado a htaccess. Que tengo que hacer para renombrarlo? servidor apache.
Hay algún pluyun para que cuando active estas tres casillas me haga las redirecciones 301 a las nuevas direcciones.
Saludos.

ResponderCitar
Respondido : 04/01/2011 1:17 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola,

Tienes que acceder por ftp o través del administrador de archivos que tengas en el panel de control del hosting. En ambas conexiones tienes que tener la opción de renombrar archivos.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 05/01/2011 9:41 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

daniel
 daniel
Estimable Member

ok lo miro.
Hay algún pluyin o algo para que cuando active estas tres casillas me haga las redirecciones 301 a las nuevas direcciones.
Saludos.

ResponderCitar
Respondido : 05/01/2011 11:51 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola danny,

No hay un plugin específico para lo que quieres, hay plugins para redireccionar de una urls a otras y cosas similares pero no para lo que tu comentas.

Lo más sencillo es acceder desde el administrador de archivos de tu cPanel o Plesk y cambiar el nombre del archivo htaccess.txt a .htaccess para que funcione y luego lo editas desde el propio administrador de archivos con el editor de código que este traiga y verificas que tengas 3 líneas similares a estas:

RewriteCond %{HTTP_HOST} ^midominio.es$ [OR]
RewriteCond %{HTTP_HOST} ^www.midominio.es$
RewriteRule ^(.*)$ "http://www.midominio.com$1" [R=301,L]

Preferiblemente que estén situadas al prinicpio del archivo, despues del texto:

#
#  mod_rewrite in use

RewriteEngine On

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/01/2011 11:07 pm

Cursos Gratuitos WordPress

daniel
 daniel
Estimable Member

Hola.He heccho todo lo que me habeis diccho he renombrado el archivo y he copiado las linesas en el archivo que me habeis pasado y ahora se produce otro error.

ERROR 500.
Aque puede ser debido.
Saludos.

ResponderCitar
Respondido : 14/01/2011 2:25 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola danny,

¿Nos puedes mostrar la url del sitio web?.
No respondiste a las consultas de si el hosting es linux o windows.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/01/2011 3:15 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

daniel
 daniel
Estimable Member

Hola.eL Hosting es linux.
http://www.sherrysport.es/

ResponderCitar
Respondido : 14/01/2011 4:03 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola danny

En algunos hosting puedes tener problemas con el .htaccess, por lo cual el propio archivo dentro de sus comentarios te sugiere comentar las comentar la siguiente línea.

## Can be commented out if causes errors, see notes above.
#Options +FollowSymLinks

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/01/2011 5:17 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

daniel
 daniel
Estimable Member

No entiendo lo que me quieres decir con lo de que comente las lineas.Me lo puedes especificar un poco más.
Un saludo.

ResponderCitar
Respondido : 15/01/2011 12:39 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola danny,

Comentar una o varias líneas, significa anteponer al código que se ha de interpretar o ejecutar un símbolo que lo anule o inhabilite, en el caso particular de htaccess se utiliza la almohadilla "#" para comentar estas líneas que no queremos que sean leídas o ejecutadas.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/01/2011 7:13 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

daniel
 daniel
Estimable Member

Hola.
Me sigue saliendo error 500.Ha surgido un problema inesperado que impide que el servidor pueda llevar a cabo la solicitud.
Esto es lo que he puesto en el .htaccess

##
# @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
# Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On
RewriteCond %{HTTP_HOST} ^sherrysport.es$ [OR]
RewriteCond %{HTTP_HOST} ^www.sherrysport.es$
RewriteRule ^(.*)$ "http://www.sherrysport.com$1" [R=301,L]

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#
#Order allow,deny
#Deny from all
#Satisfy all
#
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
# Block out any script that includes a tag in URL
RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /

########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Haber si todo esta correcto.
Otra cosa al renombrar el archivo.En tipo de archivo pone htaccess eso esta bien verdad ya no aparece como documento de texto.
Saludos.

ResponderCitar
Respondido : 19/01/2011 12:42 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola danny,

Cuidado que es un error común renombrar el archivo htaccess.txt a htaccess , y lo correcto es renombrar a .htaccess

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 20/01/2011 9:18 am

Cursos Gratuitos WordPress

daniel
 daniel
Estimable Member

Buenas.Lotengo renombrado a .htaccess que comprobaciones puedo hacer para ver donde esta el fallo.

ResponderCitar
Respondido : 20/01/2011 10:48 am
Página 1 / 2

Por favor Iniciar Sesión o Registro