Mostrar productos aleatorios dependiendo de la categoría en que se encuentre  

 
José Luis Suárez Jiménez
 José Luis Suárez Jiménez
Estimable Member

Hola a todos. Actualmente tengo puesta en la web que se muestren aleatoriamente una serie de productos de la categoría "Ofertas y novedades" en todas las secciones de la web. Adjunto una captura para que veais como tengo configurado el módulo.

He intentado cambiarlo de manera que se muestren productos aleatorios de la categoría donde se encuentre el usuario pero me han surgido dos fallos.

El primero es que me veo sin la posibilidad de poder elegir la categoría donde quiero mostrar el módulo, ya que en el parámetro "asignación del menú" del módulo, no tengo el árbol de las categorías creadas en virtuemart.

Y la segunda es que al escoger una categoría diferente que no sea "Ofertas y novedades" no me muestra el módulo por ningún lado.

Muchas gracias y un saludo.

URL del sitio: http://www.copitecnic.com

Citar
Respondido : 08/03/2012 1:31 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola José Luis,

Te será de utilidad el artículo sobre la extensión MetaMod:

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 08/03/2012 2:42 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

José Luis Suárez Jiménez
 José Luis Suárez Jiménez
Estimable Member

Hola Jordi. La extensión Metamod va de maravilla, es muy flexible dándote la posibilidad de poder configurarlo de muchas maneras. El problema que tengo es que no he podido solucionar el segundo error que comenté en el inicio de este tema.

Resulta que al introducir un ID de categoría diferente al 1 en el módulo que muestra los productos aleatoriamente no me muestra nada. Sólo funciona si pongo el ID=1.

Gracias y un saludo.

ResponderCitar
Respondido : 13/03/2012 1:28 pm
David Noguera
 David Noguera
Miembro Admin

Hola JOseLuis,

podrías activar el modo debug en la configuración global de tu Joomla y después acceder a tu web con el parámetro ID=1, copiar la info de debug que se genera abajo del todo y pegarla en un fichero de texto, y repetir el proceso con un ID de otra categoría??

Después sube esa info en un fichero de texto adjunto para que lo revisemos..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/03/2012 5:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

José Luis Suárez Jiménez
 José Luis Suárez Jiménez
Estimable Member

Hola David. He activado el Debug de Joomla (adjunto captura por si hay algo mal configurado) pero no me aparece nada en la web, tanto si pongo el ID=1 como si pongo otro número de ID.

¿Estoy haciendo algo mal?

ResponderCitar
Respondido : 13/03/2012 11:21 pm
David Noguera
 David Noguera
Miembro Admin

Hola Jose Luis, veo que lo que tienes activado es el plugin de debug, además de esp también tienes que activar el debug en la configuración global de tu Joomla, en la pestaña Sistema, verás que hay una sección donde pone "Parámetros de depuración de errores", marca en Sí las dos opciones que te da allí..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2012 9:21 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

José Luis Suárez Jiménez
 José Luis Suárez Jiménez
Estimable Member

Hola David.
Adjunto en archivo txt los dos resultados del Debug que me muestra joomla. Uno es configurando el módulo con el ID de categoría =1 (en el que si me muestra los artículos aleatoriamente) y otro con el ID=2 (donde no me muestra nada, ni tan siquiera el módulo, tanto si pongo ID=2 como cualquier otro distinto a 1)

Muchas gracias.

Link a post de foro, solo visible a usuarios registrados
ResponderCitar
Respondido : 14/03/2012 5:00 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola José Luis,

Accedo a tu sitio web, y me pulso en Ofertas y Novedades (menú principal del sitio web) y me lleva a http://www.copitecnic.com/component/virtuemart/ofertas-y-novedades?TreeId=1 y no se a que módulo de imágenes aleatorias te refieres, ya que no visualizó ninguno.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 15/03/2012 4:20 pm

Cursos Gratuitos WordPress

José Luis Suárez Jiménez
 José Luis Suárez Jiménez
Estimable Member

Hola Jordi.

Al acceder a http://www.copitecnic.com/ el módulo de la derecha, de ofertas y novedades, muestra artículos aleatoriamente de esa categoría, pero al configurar el módulo y ponerlo para que muestre artículos aleatoriamente de otra categoría distinta no funciona, ni siquiera carga el módulo.

ResponderCitar
Respondido : 15/03/2012 6:24 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola José Luis,

Por lo que entiendo, ahora funciona el módulo porque en el id le pones un 1, y hace una llamada a una categoría y muestra los productos de forma aletoria correctamente.

En el momento que le pones el id=2 no funciona. ¿Entiendo que tienes una categoría de Virtuemart creada que tiene esa id? ¿Y si la tienes creada, en esa categoría hay productos?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 16/03/2012 11:03 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro