No puedo ver mas de 20 articulos  

 
Josean
 Josean
Reputable Member

Buenas tardes.
¿Alguien sabe que cambiar en la configuracion para que me deje ver mas de 20 articulos por pagina?

Ya que entro al front de mi site y en algunas las categorias que tienen muchos articulos, cuando le doy a pagina siguiente, donde estan el resto de articulos, me dice que el enlace esta roto, tambien me pasa lo mismo si intento poner dentro en mostrar +de 20.

La primera pagina de la categoria se ve perfectamente y funciona todo bien, pero en todas las siguientes, me dice enlace roto, a que es devido?

Un saludo y muchisimas gracias

Citar
Respondido : 27/01/2011 6:27 pm
David Noguera
 David Noguera
Miembro Admin

Hola Josean, péganos una URL para que veamos el fallo.

es probable que no te esté funcionando bien las URLs amigables. Comprueba que tienes el fichero .htaccess en la raíz de tu Joomla y no está renombrado como htaccess.txt.

Saludos.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/01/2011 11:45 pm

Cursos Gratuitos WordPress

Josean
 Josean
Reputable Member

Lo acabo de comprobar y esta bien renombrado a /.htaccess
Lo que pasa es que tambien el foro me esta fallando y me están diciendo que puede ser de este archivo tambien.

¿Cómo hago para que funcione correctamente? Aqui estoy un poco perdido...

Un saludo y muchisimas gracias 😉

ResponderCitar
Respondido : 27/01/2011 11:54 pm
Josean
 Josean
Reputable Member

Perdón, un archivo donde puedes ver el fallo, si le das a suguiente.

http://www.aquinohaygeranios.com/tienda-on-line/89-arboles-y-plantas/91-arboles-frutales.html

y otra albergada en el mismo hosting que me da el mismo error:

http://www.golmajo.com/tienda-on-line-comprar/2-setas/12-micelio-o-semilla-de-seta.html

Muchisimas gracias por la ayuda ;)))

ResponderCitar
Respondido : 28/01/2011 1:45 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Josean,

veo que estás usando VirtueMart para hacer un listado de productos y te falla al dar a siguiente, esto es por que VirtueMart no soporta las URLs amigables. Has subido el fichero router.php??

Échale un vistazo a este post donde se explica como dar soporte para URLs amigables para VirtueMart:

https://www.webempresa.com/foro/6-Joomla-15/1783-optimizaci%C3%B3n-para-buscadores.html#1788

Si lo has subido y sigue sin funcionar, prueba con SEF404 que tiene soporte para VM:

http://dev.anything-digital.com/sh404SEF/User-Manual.html

Saludos.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/01/2011 11:08 am
Josean
 Josean
Reputable Member

El fichero route.php si que lo tengo instalado, voy a probar el sef404 a ver que es lo que pasa.

Un saludo y muchisimas gracias ;))

ResponderCitar
Respondido : 29/01/2011 1:56 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Josean
 Josean
Reputable Member

Acabo de comprar se sh404sef, pero me va todavia peor...

Lo he activado y puesto Rewrittin mode en with.htaccess)mod_rewite) pero no me linkea con la tienda online.

Y no se muy bien que es lo que tengo que cambiar para optimizarlo, estoy mirando un tutorial, pero de momento, no consigo hacerlo funcionar, correctamente.

Por cierto, Tengo que eliminar el archivo route.php? Yo creo que si, pero no estoy seguro.

Un saludo y muchas gracias ;))

ResponderCitar
Respondido : 29/01/2011 2:55 am
Josean
 Josean
Reputable Member

Acabo de eliminar el archivo route.php y el componente que tenia instalado para el seo y me sigue sin funcionar, nada..

Llevo semana y media, desarrollando esta web, y estos 2 problemas me impiden continuar..

Creo que algo serio esta pasando en mi servidor...

Un saludo.

ResponderCitar
Respondido : 29/01/2011 3:45 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Josean
 Josean
Reputable Member

Mira tras eliminar esos 2 archivos, he probado y YA me deja ver mas de 20 articulos, muy, muy bien, avanzamos, jejejeejej
pero las urls no son amigables y no consigo hacer funcionar el sh404sef

El problema del foro tampoco esta resuelto y ahora me sale Forbidden access (Flooding) en lugar del redireccionamiento que me salia anteriormente

Si se os ocurre algo, voy probando a ver si entre todos, le podemos encontrar una solución, y poder animarme 🙂

Un abrazo

ResponderCitar
Respondido : 29/01/2011 3:59 am
Josean
 Josean
Reputable Member

Alguine sabe como hacer funcionar el sh404sef, ya que lo he instalado por recomendacion de David, pero cuando lo activo, no me deja ver la tienda online, ni niguna pagina mas que la principal, me sale un mensaje diciendome lo siguiente:

Bad karma : no se encuentra esta pagina !

Usted lo pidió http://www.aquinohaygeranios.com/Tienda-On-Line, pero a pesar de nuestras computadoras buscando muy duro, no pudimos encontrar la. ¿Qué pasó?

* hace clic en un enlace, para llegar aquí, que tiene un error
* hemos eliminado esa página, o se lo dio otro nombre
* o tal vez usted lo haya escrito usted mismo y hubo un pequeño error?

He leido varios manuales y creo que la configuracion la tengo bien y que simplemente al ser la version 2.1.9.787 solamente tengo que activarlo, ya que todas las configuraciones vienen preconfiguradas de serie con una correcta optimizacion.

Un saludo y muchisimas gracias ;))

ResponderCitar
Respondido : 03/02/2011 5:34 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro