Avisos
Vaciar todo

No se ve la tienda si no se está registrado  

 
Daniel
 Daniel
Usuario experto

Hola,

estoy construyendo la página diezlibros.com y ahora choco con un problema que probablemente he creado yo sin saberlo, y lo malo es que tampoco sé como solucionarlo. Si pincho en la pestaña de la tienda, que he llamado "Nuestros temas", en la que hay dos categorías: Novela negra y Novedades, como subpestaña, y otra más dentro de la tienda, sale un mensaje que me da error y me indica que no tengo permiso para acceder al módulo indicado y me pide que inicie sesión como registrado.

¿Cómo puedo eliminar esa denegación, pues quiero que todo el mundo pueda ver la tienda y sus apartados?

Gracias por las posibles respuestas.

Citar
Respondido : 12/08/2011 1:40 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Daniel

Revisa en la configuración de virtuemart que tengas el grupo Público Front-end seleccionado en la opción de Mostar precios a los miembros del grupo.

Saludos.

ResponderCitar
Respondido : 12/08/2011 1:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Daniel
 Daniel
Usuario experto

Hola,

está marcado exactamente como dices, pero la cosa sigue igual: Tengo la pestaña Nuestros temas, de la que cuelgan Novela negra y Novedades. Al pinchar tanto en la pestaña principal como en las subpestañas, me aparece en la columna central de contenido -en la plantilla ja labra, la tengo a la izquierda- Categorías, en la que aparecen las tres categorías -las dos subpestañas y otra más, Novela, cuento y relatos, pero al pinchar indistintamente en cualquiera de ellas, me sale un mensaje que me pide identificarme o registrarme. Además, las otras zonas de la página, donde deberían aparecer el resto de módulos que sí se ven en otras páginas, como la de la pestaña del menú horizontal Noticias, por ejemplo, no se ve nada, sino el color de fondo, que lo tengo en rojo. Pero no identifico el problema.

Gracias por la atención.

ResponderCitar
Respondido : 12/08/2011 6:49 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel,

Pregunta: ¿como tienes configurados los elementos de menú que cargan esas categorías de VirtueMart, públicos, registrados..?

Aporta datos porque de lo contrario es difícil saber que has podido tocar, hay demasiadas cosas que no sabemos de tus configuraciones y cambios realizados para imaginarnos el escenario.

Saludos

ResponderCitar
Respondido : 12/08/2011 7:33 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Daniel
 Daniel
Usuario experto

Hola,

perdonad que no me explique bien, voy a intentar daros toda la información que pueda, a ver si consigo formular bien mis dudas:

sobre lo que me preguntas: todos los elementos del menú que cargan esas categorías están configurados como públicos.

Lo que intento hacer, y no consigo encontrar documentación precisa sobre ello, o llegar hasta ella, es cómo conseguir que en un elemento, que se muestra como una pestaña, del menú principal (denominada "Nuestros temas"), de tipo virtuemart, y con subpestañas de esta, creadas como elementos de tipo VM, también en el menú principal, conduzcan a las categorías de productos de la tienda, y pinchando en cada categoría, a los productos que cada una de las categorías contiene.

He conseguido, y ahora no sé bien cómo, que al pinchar tanto en la pestaña principal, como en las subpestañas, todas elementos del menú principal, aparezcan, en la página principal, bajo el título "Categorías", junto con los dos productos que hasta ahora tengo creados, que aparecen como destacados.

Ocurren dos cosas:

Una, al pinchar en cada una de las subpestañas, en el menú horizontal arriba del frontend, configurado en el menú principal, que llevan el mismo nombre de las categorías que he creado en VM, es igual pinchar en una u otra, todas muestran la página antes citada en la que bajo "Categorías" se ven los nombres de las tres subpestañas, aunque aparecen con la imagen que he asociado a cada categoría del mismo nombre en VM.

Dos, después de pinchar en las subpestañas del menú horizontal, lo que me ha llevado dentro de la página principal, donde entonces se ve el título "Categorías", con los iconos de cada categoría según configuré en VM, al pinchar en uno de estos iconos/categoría, me lleva a otra página donde me pide que me identifique con nombre y contraseña.

Qué quiero lograr: Que al pinchar en las subpestañas del menú horizontal, configurado en la parte joomla, me lleve a las diferentes categorías de los productos configuradas dentro de virtuemart, y a su vez al listado de productos y a cada ficha de cada producto.

¿Qué más datos puedo daros para que podáis ayudarme directamente o dirigirme a siitios de documentación? La página concreta donde se produce lo que describo: http://www.diezlibros.com/nuestros-temas/novela-relatos-y-cuentos.html (También la adjunto como captura).

Gracias, saludos.

ResponderCitar
Respondido : 14/08/2011 2:13 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel,

Qué quiero lograr: Que al pinchar en las subpestañas del menú horizontal, configurado en la parte joomla, me lleve a las diferentes categorías de los productos configuradas dentro de virtuemart, y a su vez al listado de productos y a cada ficha de cada producto.

Tendrás que acceder a la subcategoría deseada, copiar la url relativa (sin el http://www.tudominio.com/) y crear un ítem de menú para dicha subcategoría que sea un "Enlace externo" y pegar dicho enlace (ruta relativa de la subcategoría) para que al hacer clic en el ítem de menú te cargue tal o cual sub-categoría.

Saludos

ResponderCitar
Respondido : 14/08/2011 6:52 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Daniel
 Daniel
Usuario experto

¡Muchas gracias!

Ahora he conseguido solucionar este problema, y ya he conseguido crear un menú con subcategorías de la tienda en el menú horizontal. Mientras lo hacía, probando, he solucionado la otra cuestión que planteé, que cuando pinchaba en una subcategoría, al no estar bien configurada, me daba un mensaje pidiéndome loguearme. Ha desaparecido cuando en la configuración global del sitio, pestaña Sistema, he cambiado Comprobar tipo de MIME de Sí a No.

Ahora tengo otra pregunta/problema, que no sé si la tengo que hacer aquí o abrir otro tema en el foro. Sin embargo, de alguna manera debe estar relacionada: Al pinchar en el menú horizontal de la tienda y en sus subcategorías, al presentar la página principal donde aparecen, desparecen todos los módulos - como ¿Quién está en línea?, productos destacados...- que están al lado, y que en el resto de pestañas, tanto Inicio como las demás, al presentarse en la página principal, siempre aparecen, porque están configurados para que así sea en todos los menús.

Lo dicho: gracias por vuestra paciente ayuda en el foro, y por la enorme información de todo Webempresa.

Saludos.

ResponderCitar
Respondido : 14/08/2011 10:49 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel,

Debes editar uno a uno los módulos que "no ves" en esa vista de categoría que has creado en el nuevo ítem de menú y habilitarlos uno a uno para que "también se muestren" en esa vista cuando se accede a esa subcategoría que tienes en los menús.

Saludos

ResponderCitar
Respondido : 14/08/2011 11:21 pm

Cursos Gratuitos WordPress

Daniel
 Daniel
Usuario experto

Hola,

he hecho lo que me indicaba Gnumax y todos los módulos se muestran en todas las páginas. Sin embargo, se me ha vuelto a presentar el problema de acceso: al pinchar en elemento de tienda en el menú superior horizontal, me aparece la tienda con sus subcategorías en la página principal, y si pincho en cualquiera de ellas me llevará a ver todos los productos de esa subcategorías.

Pero me vuelve a ocurrir que al pinchar en cualquiera de esas subcategorías, que gracias a vuestras indicaciones conseguí habilitar para que pudiera entrar en ellas sin loguearme, ahora vuelve, al pinchar en ellas, a pedirme que me loguee con nombre y contraseña, dando un mensaje de error: "Error: No tiene permiso a acceder el módulo requerido." He borrado alguna de las subcategorías, la he vuelto a crear como ítem del menú principal tipo enlace externo, donde he copiado la url de la categoría sin el nombre de la tienda.com/ y me vuelve a dar ese mensaje de error de que carezco de permisos. Me quedo perplejo, pues no sé qué he hecho mal y donde.

¿Qué otros datos debo buscar?

Gracias, saludos.

ResponderCitar
Respondido : 16/08/2011 3:13 pm
Daniel
 Daniel
Usuario experto

Hola,

he conseguido resolver el problema, por medio de probar y comprobar que tenía habilitada, en la configuración, pestaña Seguridad, de VM, la checkbox que dice: "Permita Administración en el front-end para usuarios de non-backend."

Ya que esto parece de nuevo resuelto, os ruego que cuando tengáis un rato suelto me confirméis lo que he hecho, que es correcto hacerlo y sacar esa conclusión, no vaya a ser que haya sonado la flauta por casualidad.

Gracias, un saludo.

ResponderCitar
Respondido : 18/08/2011 8:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Daniel

La habilitación de esta opción tal como el nombre indica permitirá a los usuarios que tengan permisos de storeadmin, hacer modificaciones a la tienda desde el frontend.

Si utilizas esta opción, revisa que los usuarios públicos no tengan permisos de sotreadmin, sino sólo de shopper, de otra manera podrán administrar la tienda.

Saludos.

ResponderCitar
Respondido : 19/08/2011 1:20 pm
Daniel
 Daniel
Usuario experto

Hola,

así lo haré. Creo que con esto se puede dar por cerrado este tema, aunque por desgracia siempre surgen cosas, y ahí estáis vosotros, aconsejando con bastante paciencia.

Gracias y saludos.

ResponderCitar
Respondido : 24/08/2011 2:44 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress