Problema migrando sitio, plantilla Kraftwerks  

Página 1 / 2
 
Johnny
 Johnny
Usuario experto

Estimados,

El problema parece ser sencillo pero se me ha convertido en un verdadero dolor de cabeza, he creado una pagina en la siguiente direccion utilizando la plantilla Kraftwerks http://www.joomlaecuador.com.ec/partyzone/ ya que el cliente no adquiria el dominio decidi adelantar el trabajo temporalmente en mi cuenta, en esta direccion el sitio esta funcionando correctamente. Ahora que ya se adquirio el dominio quiero hacer la migracion del sitio a http://www.webpartyzone.com pero me salen dos errores el primero es que en la parte inferior desaparece la canasta del carro de compras o al parecer la plantilla se destruye de algun modo y el segundo error es que si ingreso a un producto y quiero agregarlo al carro de compras el link no funciona, cosa que en mi cuenta funciona correctamente.

He migrado el sitio utilizando el componente Akeeba Backup y no funciono, lo hice manualmente y no funciono siempre me queda de esta manera http://www.webpartyzone.com/fiestas-infantiles2/

Ayuda por favor.

Johnny.

Jesus es el camino, la verdad y la vida

Citar
Respondido : 17/08/2010 4:41 am
Lucas
 Lucas
Miembro Admin

Hola,

Me voy a aventurar un poco a ver si acierto 😉

Creo que el problema está en que en la configuración de virtuemart tienes como url del sitio:
http://www.joomlaecuador.com.ec/partyzone/

Si es así cambialo por:
http://www.webpartyzone.com/fiestas-infantiles2/

Si no es eso prueba a crear un subdominio tipo pruebas.webpartyzone.com y haz que apunte a
la carpeta fiestas-infantiles2 para ver si cargando en el directorio principal tu joomla y no en un
subdirectorio te funciona bien, no debería de ser este el problema si en tu hosting original te
funciona pero es algo que yo probaría a descartar porque depende de la configuración del
hosting te podría afectar.

En el caso que ninguna de estas dos opciones te funcionen mira el phpinfo de uno y otro sitio
y busca las diferencias.

Veo que tienes algunos fallos de javascript como:

$("tab-1-lnk") is null
[Break on this error]
index....emid=53 (línea 316)
contents[0] is undefined
[Break on this error] window.addEvent('load', function(){

Pero son fallos que tienes en las dos webs así que no debe ser esto a pesar que también tendrás que mirarlo.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/08/2010 7:07 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny
 Johnny
Usuario experto

Estimado Lucas,

Efectivamente Lucas estaba mal enrutado hice el cambio que me indicaste:

Creo que el problema está en que en la configuración de virtuemart tienes como url del sitio:
www.joomlaecuador.com.ec/partyzone/

Si es así cambialo por:
www.webpartyzone.com/fiestas-infantiles2/

aprovechando sobre el tema, en la misma tienda, no llega el correo de facturacion al cliente y tampoco al dueño de la tienda, solo llega el correo cuando el usuario se registra, sabes que problema puede ser? te agradezco mucho por ayudarme y disculpa la molestia.

Saludos,

Johnny.

Jesus es el camino, la verdad y la vida

ResponderCitar
Respondido : 17/08/2010 10:16 am
Lucas
 Lucas
Miembro Admin

Hola,

Ok a que era la configuración de virtuemart, siempre que se mueve un virtuemart hay que cambiar ese parámetro si no está el parámetro por defecto /.

Si no te llegan los correos presupongo que tampoco te llegan los correos de joomla, verifica que al dar de alta un usuario te llegue el correo con su contraseña, a la dirección de email del usuario que has dado de alta.

Si no te llega revisa en la configuración globla el envío de correos, primero prueba como phpmailer y si no va así prueba configurando el envío de correos con SMTP con datos correctos de identificación, servidor de mail y contraseña, no uses ssl y si no va prueba con ssl, en el caso que así no te vaya pregunta en tu hosting como configurar el envío de correos.

Si el alta de usuarios te funciona veriifica que el Super Admin de Joomla tenga una cuenta de correo válida y que sea donde verificas que te llegan los correos, por último verifica en la configuración de Tienda de Virtuemart que tengas correcta la dirección de email.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/08/2010 6:20 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Johnny
 Johnny
Usuario experto

Estimado Lucas,

Problema solucionado lo del mail, mi equivocacion es que no estaba utilizando un correo corporativo, al realizar el cambio funciono todo normalmente.

La ultima molestia que te quiero preguntar es que el producto del thumb no se me esta mostrando, te adjunto la imagen para que veas el error quizas sea problema de enrutamiento tambien.

saludos.

Johnny.

Jesus es el camino, la verdad y la vida

ResponderCitar
Respondido : 17/08/2010 8:40 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola johnnyheredia,

veo que solucionaste el problema de las rutas en VirtueMart siguiendo las indicaciones de Lucas 🙂

Sobre las miniaturas mira a ver si es algún problema de permisos en la carpeta donde estas se almacenan y por eso no las muestra o porque apunten a la ruta anterior a la copia y por ello no las encuentre.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/08/2010 9:17 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Johnny
 Johnny
Usuario experto

Estimado gnumax,

he puesto la carpeta en 777 pero no funciona, el codigo llama a esta ruta.

Jesus es el camino, la verdad y la vida

ResponderCitar
Respondido : 17/08/2010 9:29 pm
Lucas
 Lucas
Miembro Admin

Hola,

Al acceder a el servidor devuelve un error 500, tendrías que mirar el log del apache y ahí podrás ver el error porque se produce, etc.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/08/2010 9:56 pm

Cursos Gratuitos WordPress

Johnny
 Johnny
Usuario experto

Hola Lucas,

me indica esto

[Tue Aug 17 13:59:43 2010] [error] [client 190.131.93.54] File does not exist: /home/webparty/public_html/500.shtml, referer:  http://www.webpartyzone.com/fiestas-infantiles/index.php?page=shop.product_details&flypage=flypage_new.tpl&product_id=79&category_id=19&option=com_virtuemart&Itemid=53 
[Tue Aug 17 13:59:43 2010] [error] [client 190.131.93.54] SoftException in Application.cpp:601: Directory "/home/webparty/public_html/fiestas-infantiles/components/com_virtuemart/themes" is writeable by group, referer:  http://www.webpartyzone.com/fiestas-infantiles/index.php?page=shop.product_details&flypage=flypage_new.tpl&product_id=79&category_id=19&option=com_virtuemart&Itemid=53 

Jesus es el camino, la verdad y la vida

ResponderCitar
Respondido : 17/08/2010 10:07 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola johnnyheredia,

Lo cierto es que desde el enlace que marcas en el log, accedo a ese producto "Caja / Sorpresa" y me lo añade abajo sin imagen, solo el texto alternativo, por lo que imagino que o no genera la miniatura cuando creaste el producto o tendrás que recrear nuevamente las miniaturas para que carguen.

Al intentar ver esa miniatura me devuelve un 500:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@webpartyzone.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/08/2010 10:31 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny
 Johnny
Usuario experto

Hola gnumax,

Recargare los productos para ver que sucede.

Saludos.

Jesus es el camino, la verdad y la vida

ResponderCitar
Respondido : 17/08/2010 10:51 pm
Lucas
 Lucas
Miembro Admin

Presupongo que tines mal los permisos del directorio infantiles/components/com_virtuemart/themes tienes que averiguar que permisos tienen que tener en tu hosting los directorios para que sean escribibles, supongo que el directorio está a 777 y tendría que estar a 755.

En el caso que te funcione cambia todos los permisos 777 a 755 y 666 a 644.

En todo caso en tu hosting te sabrán indicar que permisos tienes que utilizar, también puedes mirar en el phpinfo de joomla, si tienes SUPHP instalado tendrás que trabajar con 755 o 644 que es lo recomendable, los hostings que trabajan con 777 y 666 no son recomendados para joomla, bueno en realidad no deberían ser recomendables para nada porque son muy inseguros.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/08/2010 10:52 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Johnny
 Johnny
Usuario experto

Saludos Lucas,

Todos los directorios estan con permisos 755 y los cambie a 644 y viceversa pero no dio resultado, y tambien hice lo que me sugirio gnumax, nuevamente subiendo los thumb pero de igual manera no los muestra.

🙁

Jesus es el camino, la verdad y la vida

ResponderCitar
Respondido : 17/08/2010 11:34 pm
Lucas
 Lucas
Miembro Admin

Hola,

Averigua en tu hosting cuales son los permisos correctos ya que el error que comentabas que te aparecía era de permisos, que panel de control tienes?

Péganos el phpinfo para verlo.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/08/2010 11:43 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Johnny
 Johnny
Usuario experto

Hola Lucas,

Gracias por responder, utilizo el cpanel 11, cpanel accelerated 2, segun vi en uno de sus videotutoriales es el mismo, soy reseller de hostgator.

te pego el phpinfo

 http://www.webpartyzone.com/fiestas-infantiles/phpinfo.php 

Espero sirva de algo

Saludos.

Jesus es el camino, la verdad y la vida

ResponderCitar
Respondido : 18/08/2010 11:58 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro