Avisos
Vaciar todo

Problema Certificado SSL se desconecta  

Página 1 / 2
 
Eloy
 Eloy
Usuario activo

Buenas.

Escribo porque por algún motivo la configuración de prestashop para certificados SSL se desactiva sola. Podemos activarla y funciona sin problemas (toda la navegación es segura con https), pero sin saber porque se desactiva pasado un tiempo (puede ser días).

Detecté que si entraba al backend desde la pagina http (sin https, ya que podía por estar mi ip habilitada para mantenimiento), el SSL se desconectaba. Tengo que decir que la tienda siempre esta en modo normal (sin mantenimiento) cuando este fallo se produce. Traté de quitar mi ip de mantenimiento pero pasaba lo mismo.

Le estuve echando un vistazo a vuestro pequeño tutorial, lo hice pero nada.

No se si podéis ayudarme, gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 24/05/2017 9:51 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es muy raro lo que cometnas que se desactiva la configuración https.
Verifica si tienes los parámetros de optimización activos , desde : Parámetros Avanzados > Rendimiento, prueba deshabilitando la cache y verifica si te sucede lo mismo.

Saludos.

ResponderCitar
Respondido : 24/05/2017 11:25 pm

Cursos Gratuitos WordPress

Eloy
 Eloy
Usuario activo

Buenas.
He probado de todas las maneras, con caché y sin caché. Es más, tenía la caché desactivada.
Sigue pasando y no entiendo el motivo.

No se si podéis ayudarme en algo. Gracias.

ResponderCitar
Respondido : 02/06/2017 7:07 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Has notado por ejemplo que si limpias la cache de tu sitio web todo vuelve a la normalidad?

Tienes activado el Magic Cache en tu web?

ResponderCitar
Respondido : 03/06/2017 1:15 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Eloy
 Eloy
Usuario activo

El magic cache los deshabilitamos pensando que era el motivo, pero seguía dando el problema. Ahora mismo esta desactivada, aunque tengo el modulo instalado pero inactivo.
Respecto a lo que comentas de borrar la caché, mi pregunta es como debería hacerlo: ¿borro todos los archivos y carpetas que aparecen en la carpeta public_html/cache o los archivos que contienen las carpetas contenidas en public_html/cache?

Gracias

ResponderCitar
Respondido : 05/06/2017 6:58 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Revisa el siguiente artículo que explica cómo desactivar correctamente Magic Cache
https://guias.webempresa.com/preguntas-frecuentes/desactivar-magic-cache-varnish-desde-la-administracion-web/

Luego con respecto a la cache de PrestaShop, si la tienes desactivada no debería tener efecto sin embargo si que puedes borrar el contenido de la carpeta cache.

Saludos.

ResponderCitar
Respondido : 06/06/2017 1:04 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Eloy
 Eloy
Usuario activo

Gracias por la respuesta.

Te adjunto una captura con un mensaje de error al tratar de guardar la configuración (será porque esta deshabilitado), ya que en teoría me la habilitaron y deshabilitaron tus compañeros de administración del hosting. Ahora se supone que esta desactivada (antes lo estaba también), por ese motivo, cuando le doy a guardar algo en las opciones del módulo me sale el mensaje rojo de arriba. El módulo lo tenía desactivado, pero lo he vuelto a activar según indica el manual que me has pasado, pero internamente, la caché en el hosting esta deshabilitado, ya que se lo dije a tus compañeros, porque creía que era el causante de este problema. Aunque ahora ya no se que puede ser la causa.

He borrado también todo lo que aparecía en la caché.

ResponderCitar
Respondido : 06/06/2017 6:39 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si has seguido los pasos para desactivar Magic Cache entonces no deberías tener problemas, el error que te aparece posiblemente porque ya no tienes archivos de cache y no lo encuentra.

He verificado que actualmente tu sitio se muestra con http, has cambiado las configuraciones o se ha cambiado de un momento a otro, tal como comentas.

Tienes alguna configuración especial en tu archivo .htaccess adicional a lo que te crea PrestaShop?

Saludos.

ResponderCitar
Respondido : 06/06/2017 8:26 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Eloy
 Eloy
Usuario activo

Efectivamente, el sitio web se ha cambiado por si solo a http.

En el archivo .htaccess añadí lo siguiente tal como indica vuestro manual de SSL:

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$  https://gepetoshop.com/$1  [R=301,L,NE]

Ya no sé si está totalmente correcto. Adjunto el .htaccess

ResponderCitar
Respondido : 08/06/2017 10:28 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En PrestaShop no sería necesario que añadas código en el archivo .htaccess para forzar el uso del SSL.

En su lugar tienes que ir en la administración de la web a Preferencias->Configuración. Primero habrá que pulsar en el enlace Please click here to check if your shop supports HTTPS que se muestra en Habilitar SSL. Una vez realizada la comprobación veremos que podemos activar el parámetro Habilitar SSL.

Con este parámetro activado y el parámetro Enable SSL on all pages desactivado se forzará el uso del SSL en las partes privadas de la tienda: proceso de compra, área de cliente, etc. En el resto de páginas, como en el listado de productos o la ficha de producto la página se cargará con http. De hecho si se pone la url con https se redirige a la versió http.

Si activamos el parámetro Enable SSL on all pages se forzará el uso de SSL en todas las páginas, de forma que si ponemos una url de la web con http se redirigirá a la versión con https.

ResponderCitar
Respondido : 08/06/2017 11:24 am

Cursos Gratuitos WordPress

Eloy
 Eloy
Usuario activo

Gracias Pablo por tu respuesta. Así mismo como tu comentas lo teníamos y lo tenemos puesto también, pero sucedía que se desactivaba el SSL sin motivo aparente. Al comentar este hecho, desde atención al cliente nos pasaron una URL de este foro donde explicaba el procedimiento para activar SSL Prestashop (lo que tu has comentado que ya lo teníamos activado), indicando que si no funcionaba lo que tu comentas lo forzaramos mediante .htaccess, tal como se hizo pero tampoco ha dado resultado. Nos sigue pasando lo mismo: lo activamos, funciona correctamente y sin saber el por qué, pasado un tiempo se desactiva.

Mi pregunta era si el código para forzarlo mediante .htaccess estaba correcto. Por que ya no se que otras opciones pueden ser. Tenemos activas tareas cron, pero no creo que sean las causantes ya que después de activadas el SSL sigue funcionando.

Código insertado en .htaccess (la duda es si el dominio esta puesto correctamente):

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ gepetoshop.com/$1 [R=301,L,NE]

ResponderCitar
Respondido : 12/06/2017 11:25 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola eloy.

El certificado no tienen porque desactivarse, si que es verdad que se tienen que renovar cada cierto tiempo pero es una tarea automática que realizamos nosotros.

Como te indico pablo, en prestashop no hace falta que añadas ningún código ya que lo activas desde la administración de prestashop Preferencias -> Configuración Habilitar SSL

El código que se tendría que añadir en el archivo htaccess sería este:

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https:// gepetoshop.com/$1 [R,L]

Si añades el código ten en cuenta que para que funcione tiene que estar el primero en el archivo htaccess ( Linea 1 )

Otra cosa que podrias probar es eliminar el certificado desde tu Área de clientes y volver a crearlo todo de nuevo.

Un saludo

ResponderCitar
Respondido : 12/06/2017 12:08 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Eloy
 Eloy
Usuario activo

Gracias Pepe.

Probaré con el código modificado y si no funciona lo elimino y creo de nuevo.

Muchas gracias.

ResponderCitar
Respondido : 12/06/2017 12:21 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Eloy.

Ok, dejo el hilo en espera de tus indicaciones 😉

un saludo

ResponderCitar
Respondido : 12/06/2017 12:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Eloy
 Eloy
Usuario activo

Buenas otra vez. Os comento:

Quité del htaccess el código de forzar el redireccionamiento y detecté que cada hora al ejecutar una tarea cron que tengo configurada para la importación de productos con el módulo totalimport pro se desconfiguraba la configuración de conexión segura (SSL) de prestashop. Mirando el log de errores vi que aparecía un error de cache para Varnish, aunque este modulo lo tenía desactivado. Desinstale el modulo de Varnish y en principio parecía que todo funcionaba bien, el caso es que a finales de semana me volvió a pasar. Estoy viendo a ver si detecto el origen.

Ya os comentaré algo.

ResponderCitar
Respondido : 19/06/2017 2:12 pm
Página 1 / 2