Avisos
Vaciar todo

Problema indexado Prestashop  

 
Jose
 Jose
Usuario experto

Buenas,

Desde que migramos de servidor nuestra tienda de prestashop al de webempresa estamos teniendo problemas con el index. Al meternos en buscar y regenerar indice completo, pone operación exitosa, nos aparece 1380/1380 artículos indexados, pero después en la búsqueda no arroja ningún resultado. Para corregir esto solo nos funciona regenerar el indice completo desde un programa que se llama store manager de Prestashop. necesitamos arreglar el indexado interno, a ver si alguno puede ayudarnos. gracias,

un saludo

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 20/10/2016 10:19 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si el siguiente enlace te es de utilidad:
https://www.webempresa.com/foro/44-M%C3%B3dulos-PrestaShop/136936-B%C3%BAsqueda-de-la-tienda-no-funciona.html

ResponderCitar
Respondido : 21/10/2016 6:17 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose
 Jose
Usuario experto

Como he comentado no es que no sepamos indexar, llevamos mucho tiempo trabajando con prestashop. He explicado nuestro problema detalladamente en el primer post, a ver si alguien nos puede ayudar, gracias.

Un saludo

ResponderCitar
Respondido : 21/10/2016 5:55 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Veo que estas usando un módulo de búsqueda que tiene funcionalidad Ajax, van apareciendo los resultados conforme vas tipeando, cuando buscas algún producto nuevo no te aparece en este módulo?

Podrías probar con el módulo standard y verificar si te sucede lo mismo.

Saludos

ResponderCitar
Respondido : 21/10/2016 7:40 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose
 Jose
Usuario experto

Buenas,

Gracias por la respuesta, como he explicado en el primer post todo funcionaba correctamente hasta que migramos. En la actualidad también funciona correctamente si indexamos desde un programa externo como es el store manager, pero si indexamos desde el backoffice, en la sección buscar, nos aparecen todos los artículo como indexados pero al buscar no muestra ningún resultado.

ResponderCitar
Respondido : 22/10/2016 2:34 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jose.

Revisando un poco veo los siguientes errores:

[Sat Oct 22 14:11:19 2016] [error] [client 87.217.79.167] PHP Warning: mcrypt_encrypt(): The IV parameter must be as long as the blocksize in /home/zaverses/public_html/classes/Rijndael.php on line 51, referer: https://zavers.es/Backoffice/index.php?

Estos errores suelen ser causados por permisos por lo que deduzco que el problema del indexación pueda venir también por el tema de permisos.

Realiza un revisión con el Asistente Virtual Stephan

Sthepan revisa los permisos de los ficheros y directorios de tu cuenta y los corrige en el caso que encuentre alguno con permisos incorrectos, de forma automática.

Comprueba los resultados y nos comentas.

Un saludo

ResponderCitar
Respondido : 22/10/2016 3:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose
 Jose
Usuario experto

Buenas Pepe,

Gracias por la respuesta, evidentemente antes de abrir un hilo hemos pasado el asistente varias veces, y revisado los permisos, por lo que ese no es el problema. Gracias

ResponderCitar
Respondido : 22/10/2016 3:57 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Dudo que sea algo en tu cuenta de hosting, podrías sin embargo probar instalar un nuevo Pack Prestashop en una carpeta de tu cuenta y probar el indexado.

Comentas que los problemas ocurrieron cuando trasladaste tu sitio, podrías asumo que tienes una copia de tu sitio antes del traslado, podrías evaluar igualmente restaurarla en una carpeta y verificar si te sucede lo mismo.

Podrias probar también isntalarte un módulo que te haga una limpieza y verificación de la base de datos, por ejemplo : https://www.prestashop.com/forums/topic/275483-module-database-clean-up-optimization-of-store-db-speed-up-your-store/

Saludos.

ResponderCitar
Respondido : 22/10/2016 5:18 pm

Cursos Gratuitos WordPress

Jose
 Jose
Usuario experto

Gracias por el aporte Jhon,

Hemos instalado el modulo de limpieza de la base de datos y el error persiste. En una instalación limpia de prestashop en el mismo hosting, no se nos presenta el error, por eso creemos desde un principio que algo que se corrompió en la migración, sabemos que creando la tienda de nuevo se solucionaría pero no podemos permitirnos eso. Gracias,

Un saludo

ResponderCitar
Respondido : 22/10/2016 6:19 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola José.

Ok, puedes indicarnos que modulo es el que estas utilizando para la búsqueda ¿ es el propio de prestashop o es un modulo independiente ?

Disculpa por tantas preguntas pero vamos a ojo y necesitamos algunos datos para ver que esta provocando lo que nos comentas.

Un saludo

ResponderCitar
Respondido : 23/10/2016 11:50 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose
 Jose
Usuario experto

Hola Pepe,

Gracias por tu interés, es el por defecto, he comprado un modulo nuevo y parece que ha arreglado el problema del indexado, por algún motivo el modulo por defecto está corrupto

ResponderCitar
Respondido : 01/11/2016 3:16 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jose.

Ok, gracias por la información 😉 , lo tendremos en cuenta e intentaremos revisarlo.

Cerramos el tema.

Un saludo y gracias de nuevo por el aviso

ResponderCitar
Respondido : 01/11/2016 12:09 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress