Sólo me aparecen los transportistas gratuitos en la página de venta final  

 
Sergio
 Sergio
Usuario experto

   Hola a todos:

            Estamos migrando nuestra página de Prestashop 1.6 a 1.7.6. Todo va bien de momento, pero estamos haciendo pruebas de compras y nos encontramos con que en la pantalla final de las ventas, sólo nos aparecen los transportistas que tengamos dados de alta cómo gratuitos. Si cualquiera de los que tenemos sin ser gratuitos los pasamos a gratis, automáticamente nos aparecen, por lo que hemos descartado que tengamos mal dadas de alta las zonas o algo similar. Sin embargo, por más vueltas que le estamos dando, no acabamos de dar con la tecla.

 

      ¿Alguien sabe donde está el fallo? No creemos que tenga que ver, pero estamos con el tema Transformers (que es una pasada, la verdad). Imaginamos que se trata de algo en el Backoffice del 1.7.6 y no del theme, pero por si acaso.

 

            ¿Alguna idea? Gracias de antemano.

Citar
Respondido : 17/04/2020 6:00 pm
Karen Rios
 Karen Rios
Usuario Moderator

Hola Sergio,

¿Puedes indicarnos para que dominio es tu consulta? veo que tienes varios dominios en tu cuenta.

También puedes enviarnos una captura de las configuraciones de tus transportistas, en lineas generales puedes verificar si tienes las zonas configuradas de forma adecuada y activas para los transportistas.

Saludos

ResponderCitar
Respondido : 17/04/2020 7:20 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Sergio
 Sergio
Usuario experto

@karenrios

    Hola:

          Gracias por responder y por el interés. El dominio es Ferreteroonline.es, aunque al tener dados de alta los productos y las formulas de pago, lo tenemos en modo mantenimiento (para que de momento nadie pueda acceder ni comprar, claro). Si nos facilitáis una IP, os podemos añadir al acceso en mantenimiento. No sé cómo podríamos hacerlo.

         Os adjuntamos unos pantallazos de los transportistas, pero seguimos pensando que no se trata de las zonas, por que incluso los transportistas que no nos aparecen, si los ponemos como "transporte gratuito", automáticamente aparecen en la pantalla final (si fuera una cuestión de zonas, lógicamente entendemos que seguirían sin aparecer).

         Pensamos en un primer momento que podían ser uno de los dos módulos que tenemos, uno el onepage checkout y el otro el "costo de envío avanzado" de motionseed, pero incluso desactivando ambos (es decir, dejando la pantalla de pago por defecto del theme) y sin actuar el de costo de envío avanzado, sigue ocurriendo exactamente lo mismo ....

       A ver si a vosotros se os ocurre el por qué .....

 

                  Un cordial saludo y gracias de nuevo por el interés.

Transportistas • Ferretero Online Seguridad para tu vivienda y negocio Mozilla Firefox 17 04 2020 23 51 19
Transportistas • Ferretero Online Seguridad para tu vivienda y negocio Mozilla Firefox 17 04 2020 23 52 10
Transportistas • Ferretero Online Seguridad para tu vivienda y negocio Mozilla Firefox 17 04 2020 23 52 23
Transportistas • Ferretero Online Seguridad para tu vivienda y negocio Mozilla Firefox 17 04 2020 23 52 40
Transportistas • Ferretero Online Seguridad para tu vivienda y negocio Mozilla Firefox 17 04 2020 23 52 57
Transportistas • Ferretero Online Seguridad para tu vivienda y negocio Mozilla Firefox 17 04 2020 23 54 22
Transportistas • Ferretero Online Seguridad para tu vivienda y negocio Mozilla Firefox 17 04 2020 23 50 41

 

          

ResponderCitar
Respondido : 17/04/2020 11:05 pm
Sergio
 Sergio
Usuario experto

      Hola de nuevo:

                         Acabamos de dar con la solución. Espero que a alguien más le venga bien por si le surje el mismo problema. El tema está en que los transportes los había creado automáticamente el módulo del transportista (en este caso ASM, pero podría ser perfectamente Correos, Correos Express, etc.). Aunque nosotros posteriormente modificamos manualmente estos transportistas, parece ser que eso da problemas.

         La solución pasa por borrar los transportistas creados por el módulo y crearlos de cero. Con eso, empieza a funcionar todo correctamente. Luego, nosotros utilizamos el módulo que indicamos antes para gestionar las normas de envíos gratuitos, etc. Es decir, no configuramos ninguno de los de transportistas como gratuitos en las fichas de transportistas y creamos normas mucho más completas a través del módulo "Costo de envío avanzado". Pero vamos, que el problema de que aparezcan en la ficha final independientemente de que sean gratuitos o no se soluciona borrando los creados por módulos y creándolos manualmente desde cero.

           Gracias por vuestro interés y tiempo y espero que le valga a alguien que tenga el mismo problema.

 

                    Un cordial saludo y por favor, dad por solucionado el hilo. Gracias.

ResponderCitar
Respondido : 18/04/2020 9:22 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@admincerrajeronline-com

Hola Sergio,

Agradecemos infinitamente que compartieras la solución con nosotros, de verdad se aprecia. 

Seguro nos será de una enorme ayuda, seguimos en contacto 🙂

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 18/04/2020 5:13 pm

Por favor Iniciar Sesión o Registro