Avisos
Vaciar todo

Problemas de visualización en desplegable y administrador  

Página 1 / 2
 
Miguel Eugenio
 Miguel Eugenio
Usuario activo

Buenos días,

por alguna razón, de la noche a la mañana no se visualiza correctamente un desplegable que tenemos en www.verquehacer.com para que el visitante pueda seleccionar la ciudad donde quiere ubicarse y ver sus eventos. Además de otros cambios visuales a nivel de administración (opciones de un plugin que cambian de estilo o distribución pero siguen funcionando).

Como tenía un backup del día anterior lo bajé a local para estudiarlo y revisarlo, pero para mi sorpresa se veía bien, así que lo volví a subir al hosting y lo restauré, pero se sigue viendo mal.

Así que el mismo backup en local funciona bien, y en hosting funciona mal.

La web estaba en WP 5.8.3 y PHP 7.4, en local hemos recuperado el backup ya sobre 5.9.3, y en el hosting recuperamos como estaba y viendo que seguia igual actualizamos a 5.9.3, sin arreglarse el problema.

¿Os suena por qué puede estar pasando esto?

Muchas gracias y un saludo,

Miguel.

Contenido solo visible a usuarios registrados

Citar
Respondido : 19/04/2022 9:40 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel Eugenio.

Supongo que te refieres a esto:

screenshot www.verquehacer.com 2022.04.19 10 44 22

Puedes probar añadir lo siguiente en Apariencia -> Personalizar -> CSS Adicional.

li.cities_names a {
color: #fefefe;
}

 

Un saludo

ResponderCitar
Respondido : 19/04/2022 9:48 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Miguel Eugenio
 Miguel Eugenio
Usuario activo

Buenos días, @pepesoler

 

gracias por tu pronta respuesta. No parece un problema de color o estilo, al pinchar se debe ver como tenemos en un subdominio de prueba para trastear con mejoras y cambios.

Al pinchar en el desplagable la caja se debe mostrar en blanco, con todas las ciudades (en esta versión solo 1 para probar) y no interferir en el resto de la plantilla.

Sin embargo, ahora mismo se "arrastra" hacia abajo todo lo que ocupa el desplegable y "arrastrando" también toda esa localización para ocupar lo que ocupa el desplegable.

Adjunto pantallazo, pero si quires te puedo dar el link para verlo "visualmente".

Muchas gracias,

Miguel.-

 

image
ResponderCitar
Respondido : 19/04/2022 9:58 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel Eugenio.

Pues si nos pasas el link donde podamos ver como se tendría que ver seria de ayuda.

 

Un saludo

ResponderCitar
Respondido : 19/04/2022 10:07 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Miguel Eugenio
 Miguel Eugenio
Usuario activo

Hola Pepe,

 

https://demo.verquehacer.com/

 

Una cosa más que puede serte de utilidad: prueba a visitar tanto la web "oficial" como la "demo" con el móvil, verás que la localización (a la derecha junto a la lupa para buscar) sale con el símbolo habitual en móvil para la versión "demo" pero no lo hace en la versión "oficial". Espero estar explicándolo bien.

Versión "buena":

image

Versión "oficial":

image

Muchas gracias y un saludo,

Miguel.

ResponderCitar
Respondido : 19/04/2022 10:14 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola  Miguel Eugenio.

Veo que utilizas el plugin WP-Optimize 

.- Elimina la cache del plugin y una vez eliminado desactiva el plugin, con eso comprobáremos si el problema es del plugin de Cache.

 

La localización lo realizar con el plugin " Tevolution - LocationManager " ?

Veo que no utilizas la misma version del plugin en el clon que en la web en producción.

Podrías utilizar la misma version del plugin que tienes en el clon y ver si con una versión se soluciona, puedes utilizar el plugin wp rollback para volver a version anterior

-> https://es.wordpress.org/plugins/wp-rollback/

 

Un saludo

ResponderCitar
Respondido : 19/04/2022 11:20 am

Miguel Eugenio
 Miguel Eugenio
Usuario activo

Hola Pepe,

he borrado la caché del plugin, desactivándolo también, sin resultado positivo.

Efectivamente para la localización usamos el plugin Tevolution - LocationManager pero, en principio, tenemos la última verisón en ambos entornos: 2.2.2

image

¿Ves algo diferente entre los 2 entornos?

Eso me lleva a otra reflexión: el viernes pasado, por elevado acceso a la web que colapsó en varios momentos, instalamos HeartBeat para disminuir las peticiones admin_ajax,
y por optra parte Yoast Test Helper para resetear las tablas indexadas y le dimo al botón de Yoast 'Empieza el procesamiento y acelera tu sitio ahora' para mejorar el SEO de la página. Esta última parte falló por tiempo.

¿Puede tener relación con el problema que estamos teniendo?

Muchas gracias y un saludo,

Miguel.

ResponderCitar
Respondido : 19/04/2022 11:39 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel Angel.

¿Ves algo diferente entre los 2 entornos?

Si, en la version del clon los plugins estan sin actualizar por eso te indique bajaras la version del plugin.

¿Puede tener relación con el problema que estamos teniendo?

En principio no tendrían que tener relación, prueba a bajar la version del plugin.

 

Un saludo

ResponderCitar
Respondido : 19/04/2022 12:38 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Miguel Eugenio
 Miguel Eugenio
Usuario activo

Hola Pepe,

el plugin WP Rollback solo funciona con temas y plugins que se encuentren disponibles en el Directorio oficial de WordPress y este es de pago y por lo tanto externo. Revisaremos nuestros ficheros y si no tenemos una copia consultaremos con el vendedor.

¿Se te ocurre alguna alternativa?

Podríamos volver a una situación anterior (varios dias atrás antes de este problema). ¿Como ves esta posibilidad?

Muchas gracias y un saludo.

Miguel.

ResponderCitar
Respondido : 19/04/2022 1:08 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Miguel, 

El plugin de WP Rollback te permite retroceder los plugins -> https://es.wordpress.org/plugins/wp-rollback/

Una vez los instalas el plugin en las opciones de los plugins en tu WordPress aparece la opción para retroceder  a la versión que deseas

image

Verifica esto y nos comentas como ha ido todo

Un Saludo

 

ResponderCitar
Respondido : 19/04/2022 1:20 pm

Cursos Gratuitos WordPress

Miguel Eugenio
 Miguel Eugenio
Usuario activo

Hola Karen,

muchas gracias por tu respuesta, una vez instalado y activado, no me ofrece la posibilidad de Retroceder. Te pogo pantallazo del propio plugin activado y unos cuantos alrededor:

image

Saludos,

Miguel.-

ResponderCitar
Respondido : 19/04/2022 1:26 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel.

Si, solo funciona con los plugins gratuitos, los plugins de pago no puede realizar el rollback ya que tiene que descargar la version anterior del plugin y al ser de pago no puede.

Una cosa que podrías probar es a descargar la carpeta del plugin que tienes en el clon y sustituirla por la que tienes en la web principal.

Podrías ponerte tambien en contacto con el soporte del plugin o la plantilla paar que te indiquen si tienen alguna solución, supongo que tendrá mas usuarios con el mismo problema.

 

Un saludo

ResponderCitar
Respondido : 19/04/2022 2:51 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Miguel Eugenio
 Miguel Eugenio
Usuario activo

Gracias Pepe,

no ha funcionado susitituir los ficheros actuales por los que están en la versión que sí funciona. Estoy valorando el recuperar un backup de la semana pasada cuando la web funcionaba bien (descargando lo añadido para reinsertarlo después).

Como decía en el primer mensaje del hilo, no solo pasa con este plugin, hemos visto que hay diferencias en el backend, por eso esto valorando esa marcha atrás.

En cualquier caso, muchas gracias por la ayuda.

Miguel.

ResponderCitar
Respondido : 19/04/2022 3:41 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel.

Puedes Restaura una copia desde las opciones de Superbackup, tienes una guía en esta entrada:

-> https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/#Restaurar-web

 

Un saludo

ResponderCitar
Respondido : 19/04/2022 3:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Miguel Eugenio
 Miguel Eugenio
Usuario activo

Buenos días,

retomo el hilo para comentar que hemos restaurado la web con el backup generado el viernes pasado, 3 días antes de ver el error del asunto, y se sigue viendo mal lo comentado al inicio: no se carga bien un desplegable y cambia la visualización de una parte de la administración de la web.

Me he dado cuenta al ver la consola del navegador (en verdad de varios navegadores web por si era un problema del mío habitual) que hay un error del servidor al cargar un fichero.

image

He pensado que si algo funcionaba el viernes (bueno y sábado y domingo) y hemos recuperado esa situación y sigue sin verse, ¿podría ser un problema de permisos?

¿Podríais, por favor, comprobar si puede ser esto?

Un saludo y muchas gracias.

Miguel.

ResponderCitar
Respondido : 21/04/2022 11:25 am
Página 1 / 2