Avisos
Vaciar todo

Tema hijo ASTRA - posible CACHÉ? lo desactivo pero el estilo sigue igual  

 
Ana
 Ana
Usuario activo

¡Hola!

Tengo mi sitio con el tema ASTRA y antes de personalizarlo creé un tema hijo con el propio generador que dispone Astra. Lo activé y estuve probando qué pasaba si lo desactivaba una vez personalizado el tema hijo (siempre desde el menú apariencia > personalizar, nada de css adicional, ni modificando la hoja de estilo). Al comprobar que una vez desactivado seguía manteniendo el estilo del tema hijo, me extrañó y opté por eliminarlo directamente desde el escritorio de wordpress. Pero algo raro debió pasar porque el sitio seguía viéndose con el estilo del tema hijo (ya no existente) y además si intentaba personalizar el tema padre no podía y me salía el siguiente mensaje:

"Ha habido un error crítico en esta web. Por favor, comprueba la bandeja de entrada del correo electrónico del administrador de tu sitio para obtener instrucciones.
Aprende más sobre la depuración en WordPress."

Tras enviar un ticket a vuestros compañeros de soporte técnico me indican que todo apunta a que al crear el theme hijo se ha creado algún tipo de incompatibilidad con la configuración del plugin Astra Pro que tengo instalado o de WordPress y por eso falla.

Elimino el plugin Astra Pro y el tema padre, y los vuelvo a instalar y activar. En esta ocasión ya no me sale el mensaje de error y me deja personalizar el tema, pero no entiendo por qué sigue apareciendo con el estilo del tema hijo. De hecho si personalizo de nuevo desde el menú, y vuelvo a eliminar el tema y a instalarlo, mantiene los últimos parámetros de estilo, en lugar de aparecer por defecto como cuando te instalas la plantilla por primera vez.

Sospecho que tiene que haber alguna caché interna o algo parecido porque otra cosa no se me ocurre. De todas formas, he borrado la caché del navegador varias veces, he probado a instalar un plugin para borrar la caché de la web, pero tampoco funciona (supongo que porque se han hecho esos cambios antes de instalarlo???).

No sé a qué se debe, pero necesito vuestra ayuda porque ya no sé qué hacer, ni encuentro información por ninguna parte.

Un saludo y gracias por adelantado.

PD: perdonad el tostón 😉

 

 

Contenido solo visible a usuarios registrados

Citar
Respondido : 22/02/2021 7:07 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Ana,

Veo que tienes Wp optimize, prueba desactivarlo y verificas nuevamente si tienes el mismo problema.

Un saludo 🖐️ 

ResponderCitar
Respondido : 22/02/2021 7:21 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ana
 Ana
Usuario activo

¡Hola!

Lo instalé precisamente porque seguía sucediéndome y pensé que igual me ayudaría a eliminar una "supuesta caché".

Lo acabo de eliminar, de todas formas, pero no te puedo decir qué sucede porque no puedo editar nada ni acceder al escritorio porque me sale un mensaje de "No disponible temporalmente por un mantenimiento programado. Vuelve a comprobarlo en unos minutos."

Tampoco entiendo por qué sale ahora ese mensaje la verdad y si es verdad que con solo esperar se soluciona.

ResponderCitar
Respondido : 22/02/2021 7:40 pm
Ana
 Ana
Usuario activo

Ya he logrado poder entrar en el escritorio de wordpress y como me temía sigue sucediendo.

Lo que acabo de comprobar es que no es cosa de el tema ASTRA en cuestión, ya que si personalizo desde el menú (sin añadir css adicional) el tema padre de Twenty Nineteen, lo elimino desde temas y lo vuelvo a instalar y activar, sigue con el estilo que le di, no como viene por defecto.

La verdad que es algo que acabo de darme cuenta ahora a raiz de lo del tema hijo, pero igual es que es así, nunca me fijé. De todos modos, me parece muy raro, porque y si quiero el tema tal como viene por defecto, ¿qué hago?

ResponderCitar
Respondido : 22/02/2021 8:17 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba en un nuevo sitio web y verifica si te sucede lo mismo, puedes instalar un nuevo sitio web en una carpeta de tu cuenta de hosting.

Prueba creando un tema hijo de algun tema por defecto, por ejemplo twenty twenty one, puedes usar algún plugin para crear el tema hijo, verifica haciendo cambios.

Cuando funcione bien puedes probar instalar el theme Astra

Saludos.

ResponderCitar
Respondido : 22/02/2021 8:41 pm
Ana
 Ana
Usuario activo

@jmarreros

Entiendo entonces por lo que dices que nada tiene que ver con ninguna caché que se pueda limpiar o algo parecido, ¿no?

Probaré en otro sitio como dices. De todos modos, a ver si hay algún compañero/a del foro, al que le haya pasado alguna vez lo mismo y puede compartir su experencia. Ya por curiosidad.

Un saludo y gracias.

ResponderCitar
Respondido : 22/02/2021 9:31 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola,

Es algo extraño lo que te ha sucedido, prueba con lo que mi compañero Jhon te ha indicado y nos comentas qué resultados has obtenido. 

Si el problema se repite, por favor, adjunta capturas de pantalla donde visualicemos los cambios que has realizado (los cambios de estilo, etc) y que ya no deberían aparecer en tu web y sin embargo, aparecen.

Saludos 🙂

ResponderCitar
Respondido : 22/02/2021 10:49 pm
Ana
 Ana
Usuario activo

@bulmaro-webempresa

@jmarreros

Buenos días,

He probado en un nuevo sitio y sigue sucediendo lo mismo. En este caso, no he creado ni siquiera el tema hijo, sino tal como os conté en un mensaje anterior he personalizado directamente el tema "padre" Twenty Nineteen en el personalizador. Como se trata solo de una prueba, he cambiado solo el color de fondo. Después, he eliminadoel tema desde temas y me he asegurado que tampoco está en el servidor. A continuación lo vuelvo a instalar y activar, y sigue con el estilo que le di antes de eliminarlo, no en verde claro como viene por defecto.

Yo es que no me lo explico, pero sigo insistiendo que a mi me da que eso tiene que ser porque se queda en la caché de algún sitio, no?. Aunque como ya dije, he borrado la caché del navegador, incluso he probado abrir wordpress con otro navegador y también me pasa lo mismo.

Os adjunto capturas, aunque no creo que sirvan de mucho. ¿Podéis probar vosotros por favor y decidme si os pasa?

 

Captura las modificaciones siguen al eliminar y volver a instalar el tema 1
Captura las modificaciones siguen al eliminar y volver a instalar el tema 2
ResponderCitar
Respondido : 23/02/2021 11:18 am

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Ana.

si personalizo de nuevo desde el menú, y vuelvo a eliminar el tema y a instalarlo, mantiene los últimos parámetros de estilo, en lugar de aparecer por defecto como cuando te instalas la plantilla por primera vez.

Aunque elimines la plantilla esta deja restos en la Base de datos y lo mas seguro que si vuelves a instalar la plantilla de nuevo la configuración que tenias antes vuelva aparecer.

 

Una vez eliminado puedes utilizar el siguiente plugin que optimiza la BBDD:

-> https://wordpress.org/plugins/wp-optimize/

 

Un saludo

ResponderCitar
Respondido : 23/02/2021 11:55 am
Ana
 Ana
Usuario activo

@pepesoler

 

Gracias Pepe, finalmente después de 4 mensajes por mi parte, se ve que mis sospechas ignoradas por completo tenían que ver con el problema planteado. Tanto el inicial del tema hijo como el posterior que descubrí probando por mi cuenta.

Agradezco enormemente la labor que realizais y vuestro asesoramiento, pero en este caso las posibles soluciones que me habéis estado dando (empezando por la primera) no parecían corresponderse a la explicación detallada que os daba. En ningún momento, por ejemplo, me habeis dicho ni que tuviera ni que no tuviera nada que ver lo de la "supuesta caché" con el problema. Y no será porque no he insistido (incluso en el propio asunto del tema ya lo mencionaba).

Lo mejor es que la solución que me das tú, @pepesoler, con el plugin WP optimize, es la que yo ya planteaba al inicio en mi primer mensaje pero que no me había funcionado y que precisamente después @argenis me dijo que probara desactivarlo y verificara si seguía teniendo el mismo problema (cuando el problema ya existía antes del plugin, pero bueno, le hice caso). Ahora, lo volveré a instalar y probaré con las diferentes opciones que da, a ver si consigo dar con la tecla.

En fin, os digo esto, porque a la hora de plantearos algún problema o duda de CMS, al no tener un teléfono al que llamar o al menos un chat como antaño, pues la única vía que tenemos es por aquí y encima no apta para todos los planes. Es por eso que hay que dedicar bastante tiempo para plantear y explicar bien el tema por escrito para que conozcáis con todo detalle lo que nos pasa y así nos podáis ayudar mejor. Entonces, que después de ese tiempo invertido, notes que no hay un feedback real, pues cansa, cansa y molesta, sinceramente. Al menos a mi.

En cualquier caso, gracias por intentar ayudarme.

ResponderCitar
Respondido : 23/02/2021 8:40 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Sobre esto que comentabas anteriormente

He probado en un nuevo sitio y sigue sucediendo lo mismo. En este caso, no he creado ni siquiera el tema hijo, sino tal como os conté en un mensaje anterior he personalizado directamente el tema "padre" Twenty Nineteen en el personalizador. Como se trata solo de una prueba, he cambiado solo el color de fondo. Después, he eliminadoel tema desde temas y me he asegurado que tampoco está en el servidor. A continuación lo vuelvo a instalar y activar, y sigue con el estilo que le di antes de eliminarlo, no en verde claro como viene por defecto.

Lo que posiblemente suceda es que el theme cuando lo desinstalas no esta eliminando estas configuraciones, estas configuraciones que haces en el personalizador no se guarand en archivos sino a nivel de Base de datos, es por eso que las vuelves a ver cuando instalas de nuevo el tema.

Por otro lado, si que he detectado que hay un problema en la generación de los temas hijo del theme Astra, en este caso te sugiero que si vas a usar un tema hijo no uses el generador del tema sino usa un plugin y verifica si agregando algo de código en el style.css del tema hijo se reflejan los cambios. Revisa: https://www.webempresa.com/blog/crear-temas-hijo-child-themes-en-wordpress.html

Es posible que en futuras versiones del theme Astra solucionen estos problemas.

Saludos.

Esta publicación ha sido modificada el hace 8 meses por Jhon
ResponderCitar
Respondido : 23/02/2021 9:24 pm
Ana
 Ana
Usuario activo

@jmarreros

Gracias Jhon,

Sí, lo que me comentas ya me lo dijo tu compañero @pepesoler en el mensaje anterior. De hecho borré el tema, y volví a instalar el plugin WP Optimize para optimizar la base de datos. Ejecuté todo en lo que había algo, incluido eliminé las (y los datos transitorios). Pues aún así, cuando he vuelto a instalar el tema sigue con la misma personalización. Esto ya es de locos, pero bueno. Si se os ocurre alguna alternativa os lo agradecería muchísimo.

Por cierto, ¿habéis probado ustedes por curiosidad a hacer lo mismo que yo, a ver si os funciona?

 

ResponderCitar
Respondido : 24/02/2021 12:27 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@anajaranagmail-com

Hola Ana,

Yo considero que lo mas viable es que exportes los contenidos que desees conservar como son: posts, paginas, custom posts types, etc. con la herramienta de Wordpress (Herramientas -> Exportar), luego instales un Wordpress en un subdominio de tu cuenta y empieces de 0, vale no le veo caso a que continues estresándote por está situación que puedes remediar haciendo lo que te indico. 

El siguiente artículo puede serte de utilidad -> https://www.webempresa.com/blog/instalar-wordpress-subdominio-hosting.html

ResponderCitar
Respondido : 24/02/2021 1:36 am