Actualizar de 1.6 a 1.7  

 
isabel
 isabel
Reputable Member

Buenos dias.

He intentado actualizar la tienda de 1.6 a 1.7 y da un error y no se actualiza.

Adjunto pantallazos para que vean el error.

Quedo a la espera de vuestras noticias.

Un saludo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 22/08/2018 3:50 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Isabel.

No te aconsejo que actualices de 1.6 a 1.7, uno de los motivos es por tema de compatibilidades, antes de actualizar tienes que ver que todas las extensiones que tienes instaladas tenga su versión para 1.7 y que tu plantilla sea compatible para 1.7 o tenga actualizaciones para esa versión.

Antes de empezar a actualizar lo consultaría con los desarrolladores de tu plantilla y que te aconsejen de como proceder a la actualización.

Sobre los avisos que muestras en las capturas:

El primero te indica si quieres restaura un Backup, de normal cuando prestashop realiza una actualización puedes indicarle que realice una copia de seguridad, si la actualización por cualquier motivo no funciono, tienes la posibilidad de restaurar una copia y ese es el aviso que te esta mostrando con el nombre de la copia a restaurar.

El segundo aviso te indica que no encuentra un directorio/carpeta y te indica la ruta donde tendría que estar, revisa si en esa ruta se encuentra la carpeta que te indica.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 22/08/2018 4:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

isabel
 isabel
Reputable Member

Hola Pepe.

La plantilla que utilizo es una de las que vosotros ofreceis gratis en concreto HIMALIA.

El querer actualizar es porque he leido en uno de vuestros articulos que el resto de versiones quedaran obsoletas para octubre 2018.

En cuanto a directorio/carpeta que me indica no tengo la ruta...que tengo que hacer?

ResponderCitar
Respondido : 22/08/2018 4:35 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Isabel.

No podrás actualizar la plantilla, no es compatible con la nueva versión 1.7, en principio no vas a tener problemas para trabajar con esa versión.

Hemos eliminado los instaladores de packs de todos nuestros servidores, por lo que ya no es posible instalar las plantillas que hemos estado ofreciendo hasta ahora con nuestros planes de hosting.

Los packs han sido un componente adicional que hemos incorporado durante años en nuestros servicios de alojamiento; pero en la actualidad la oferta de plantillas que existe en el mercado para los diferentes CMS (tanto de forma gratuita como de pago) es muy amplia y por este motivo, hemos considerado oportuno adaptar nuestras aplicaciones a una instalación básica con las actualizaciones de seguridad más modernas ya incluidas y comprobadas, lo cual abre el abanico de posibilidades que tienes para personalizar tu web. Además, nuestras plantillas de Prestashop estaban adaptadas para la versión 1.6, y este cambio nos permite ofrecerte una instalación actualizada a la versión 1.7.

Los packs Webempresa que tengas instalados seguirán funcionando correctamente, por supuesto, pero has de tener en cuenta que no sacaremos nuevas actualizaciones ni nuevas versiones.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 22/08/2018 5:02 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

isabel
 isabel
Reputable Member

En conclusión:

El tema de la plantilla me da igual, pasar a una basica de 1.7, pero que tengo que hacer para pasar a 1.7?

ResponderCitar
Respondido : 22/08/2018 5:10 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola isabel.

Podrías empezar por instalar un pack basico de PS 1.7, esto lo puedes realizar facilmente desde tu cuenta de cPanel -> Aplicaciones -> Instalar prestashop.

Para no tener la web que tienes ahora activa sin servicio o caída, puedes instlar la nueva en una carpeta independiente y trabajar en esa web hasta tenerla como tu quieres, una vez terminada se mueve a la raíz de tu dominio.

.- Selecciona tu dominio para la instalación.
.- En la opción ruta pones " nueva " ( esta sera la carpeta donde se instalara al nueva web )

Una vez instalada podrás acceder desde dominio.xxx/nueva

Para exportar los productos de PS puedes utilizar una consulta:
.- accede a la administración de prestashop 1.6
.- accede parámetros avanzados -> Gestor SQL
.- Añade una nueva consulta:

SELECT pat.id_product
	, prd.ean13
	, prdlang.name
    , prd.reference
    , GROUP_CONCAT(DISTINCT(concat(atgl.name, ":", atg.group_type, ":", atg.POSITION)) SEPARATOR ", ")
    , GROUP_CONCAT(DISTINCT(concat(pal.name, ":", atg.POSITION)) SEPARATOR ", ")
    , pat.supplier_reference
    , pat.reference
 FROM ps_product_attribute pat
INNER JOIN ps_product prd ON (prd.id_product = pat.id_product)
INNER JOIN ps_product_lang prdlang ON (prd.id_product = prdlang.id_product and prdlang.id_shop = 1)
 LEFT JOIN ps_product_attribute_combination pac ON (pat.id_product_attribute = pac.id_product_attribute)
 LEFT JOIN ps_attribute att ON (pac.id_attribute = att.id_attribute)
 LEFT JOIN ps_attribute_group atg ON ( atg.id_attribute_group = att.id_attribute_group)
 LEFT JOIN ps_attribute_group_lang atgl ON ( atgl.id_attribute_group = atg.id_attribute_group)
 LEFT JOIN ps_attribute_lang pal ON (pac.id_attribute = pal.id_attribute AND pal.id_lang = atgl.id_lang)
WHERE atgl.id_lang = 1
GROUP BY pat.id_product_attribute
ORDER BY pat.id_product, pac.id_attribute

Creara un archivo CSV que podrás importar a la nueva instalación:
-> http://doc.prestashop.com/pages/viewpage.action?pageId=54264587

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 22/08/2018 5:43 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro