Botones Guardar Producto y Editor no funcionan tras actualizar a PS 1.6.1  

 
Walter
 Walter
Usuario activo

Después de actualizar a PS 1.6.1 los botones para guardar productos en el BO no funcionan - los iconos de los botones se quedan dando vueltas y los botones no se activan

Tampoco funciona el editor de textos en la edición de productos - simplemente no aparece

Ambos problemas solamente aparecen en productos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 10/08/2015 12:38 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Walter,

Me comenta un técnico de soporte los parámetros habilitados en la instalación de PrestaShop 1.6.1.0 que tienes instalada en /public_html:

PARAMETROS SMARTY PRESTASHOP
* Compilación de SMARTY: Habilitada
* Caché de SMARTY: Habilitada
* Consola depuración SMARTY: Deshabilitada
PARAMETROS CCC PRESTASHOP
* Cache para CSS: Habilitada
* Cache para Javascript: Deshabilitada
* Reducción de código HTML: Habilitada
* Comprimir Javascript: Deshabilitada
* Caché de navegador .htaccess: Habilitada

Te recomiendo que verifiques las configuraciones adecuadas a estos parámetros:

- Algunas optimizaciones recomendadas en PrestaShop para mejorar el rendimiento de tu Tienda - https://www.webempresa.com/blog/item/1778-algunas-optimizaciones-recomendadas-en-prestashop-para-mejorar-el-rendimiento-de-tu-tienda.html

Tras aplicarlas coméntanos si persiste el problema por favor.

Importante: Haz una copia de seguridad antes de hacer cambios.

- Copias de Seguridad desde el Panel de Hosting cPanel: https://www.webempresa.com/blog/copias-de-seguridad-desde-el-panel-de-hosting-cpanel.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/08/2015 3:57 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Walter
 Walter
Usuario activo

en dos ocasiones he intentado configurar los parámetros como aconsejáis y siempre he tenido muchos problemas, sobre todo con JavaScript ,que como comprobarás, son los únicos parámetros deshabilitadas.

tengo otras dos webs con vosotros que prácticamente son un clon de ésta y funcionan bien después de la actualización a PS 1.6.1 - tampoco tienen la caché y compresión de JavaScript habilitadas.

He reinstalado prestashop y la mayoría de los módulos no nativos pero esto no me soluciona el problema.

ResponderCitar
Respondido : 10/08/2015 12:54 pm
Walter
 Walter
Usuario activo

he desactivado varios módulos que no utilizaba y el problema de los botones esta solucionado.

falta solucionar lo del editor de texto que me tiene loco - no sé que más hacer - necesito vuestra ayuda

gracias

ResponderCitar
Respondido : 10/08/2015 2:40 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No debería ser tema de la configuración del rendimiento, ya que esto afecta al frontal de la web y tu problema en la administración.

Haciendo pruebas con PrestaShop 1.6.1.0 veo que también me sale la rueda girando cuando edito un producto, pero esta se quita pasados unos segundos (unos 6, aproximadamente).

Si en tu caso permanecen sin quitarse es posible que tengas cacheado en tu navegador el código javascript de la versión anterior de PrestaShop, y esto sea lo que te esté originando el problema. Cuando estés editando un producto, prueba a pulsar F5 o Control+F5 para refrescar archivos CSS y javascript, y comprueba si así se soluciona el tema.

De no ser así, también podrías probar con otro navegador para ver si te ocurre lo mismo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/08/2015 2:48 pm
Walter
 Walter
Usuario activo

ya había probado limpiar la caché del navegador y de prestashop por si acaso

ResponderCitar
Respondido : 10/08/2015 5:36 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Sólo te aparece en la pantalla de productos este problema?, puedes verificar con firebug si te reporta algún tipo de error javascript,

Firebug es una extensión de Firefox, puedes usar la consola y luego errores cuando cargas esta página, para aprender sobre firebug revisa :
https://www.webempresa.com/blog/usando-firebug-para-modificar-la-apariencia-de-una-plantilla-joomla.html

Lo otro es que verifiques si tienes actualizaciones de módulos pendientes, desde Modulos => Modulos, verifica si tienes actualizaciones pendientes

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/08/2015 6:21 pm
Walter
 Walter
Usuario activo

Buenas,

Exacto solo me sale este problema al modificar los productos. He verificado con firebug si hay algun error pero no hay ningún error. Solo me sale una advertencia: "Este sitio hace uso de un certificado SHA-1; se recomienda que use certificados con algoritmos de firma que usen funciones hash más fuertes que SHA-1"

No tengo pendiente ninguna actualización pendiente de módulos.

No se que hacer ya para resolver el problema.

ResponderCitar
Respondido : 27/08/2015 1:00 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Ese mensaje de SHA-1 que comentas no debería de tener nada que ver con el problema que comentas. Prueba a editar un producto utilizando un navegador distinto al que estás usando, para verificar si el error está en un problema de compatibilidad entre esta versión de PrestaShop y tu navegador.

Si sigue fallando, indícanos si has instalado módulos adicionales en tu PrestaShop. Algunos añaden opciones adicionales en la edición de los productos, y si estos no son compatibles con PrestaShop 1.6.1.0 podrían generar problemas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/08/2015 4:36 pm

Por favor Iniciar Sesión o Registro