Avisos
Vaciar todo

Error 500 en módulos y servicios en actualización a versión 1.7.4.2  

 
Rosa
 Rosa
Usuario experto

Hola.
He actualizado en el clon de mi tienda online prestashop de la versión 1.6.1.7 a la versión 1.7.4.2.
La plantilla default bootstrap no es compatible así que no sé si podría venir el problema de ahí. La cuestión es que al ir a módulos y servicios me sale error 500. Os paso pantallazo.
Me he metido a consultar el tema por internet para informarme y he activado el modo depuración para ver más específicamente. Os paso pantallazos.
Cómo podría corregir esto?
Muchas gracias de antemano.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 25/08/2018 4:44 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es como si te faltaran archivos, el proceso de actualización se completó correctamente?

Qué versión de PHP tienes activa?, podrías probar con PHP 7.2, revisa:
https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Saludos.

ResponderCitar
Respondido : 25/08/2018 6:16 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Rosa
 Rosa
Usuario experto

Hola John.
Creo que la actualización daba errores aunque no recuerdo dónde mirarlos. Para el clon tenía PHP 7.1 y lo he cambiado ahora para probar a 7.2.8. No había 7.2 solo. Sigue dándome error para acceder a módulos y servicios. Crees que es mejor que la vuelva a descargar?
Un saludo

ResponderCitar
Respondido : 25/08/2018 6:39 pm
Rosa
 Rosa
Usuario experto

Perdona.
He entrado en Sthepan y me da un montón de errores. Te mando pantallazos.

ResponderCitar
Respondido : 25/08/2018 6:48 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Rosa,

Antes de haber "intentado" actualizar a PrestaShop 1.7.4.2 deberías haber actualizado tu versión 1.6.1.7 a la estable 1.6.1.20 para reducir el número de posibles errores que luego la actualización a la 1.7.4.2 te ha generado.

No puedes saltar alegremente de la rama 1.6 a la 1.7 sin pensar que no se van a producir cientos de errores en el proceso si no estabas en la versión estable de la 1.6 que no es precisamente la 1.6.1.7

Actualmente no es muy estable el upgrade de la 1.6 a la 1.7 ya que hay factores importantes como el Tema en uso y si este soporta la 1.7 y a partir de ahí podríamos hablar de módulos incompatibles, etc.

Personalmente creo que te has precipitado en actualizar a la 1.7, todavía no está maduro el módulo "1-click upgrade 4.0.1" para hacer estas cosas. Yo esperaría a finales de septiembre para hacerlo.

Saludos

ResponderCitar
Respondido : 25/08/2018 8:52 pm
Rosa
 Rosa
Usuario experto

Hola Luís.
Agradezco tu consejo. Como ha sido en el clon, seguiré trabajando entonces con la versión 1.6.1.7.
Actualizaré entonces poco a poco como me comentas.
Muchas gracias por vuestra información y consejos.

ResponderCitar
Respondido : 25/08/2018 10:01 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Rosa,

Como te decía, y tras muchísimas pruebas de upgrade de la 1.6 a la 1.7 (diferentes instalaciones con temas y módulos diferentes para probar por donde falla) he llegado a la conclusión (que ya tenía meses atrás clara) de que el módulo "1-click upgrade" para pasar a la 1.7. estable "esta verde aún".

Mi recomendación es que usando el "canal secundario" del actualizador, actualices a la 1.6.1.20 estable.

Cuando actualizar de la 1.6 a la 1.7 sea sencillo y seguro no te preocupes que publicaré un hermoso artículo en el Blog explicando el proceso. 😉

Saludos

ResponderCitar
Respondido : 25/08/2018 10:14 pm