Avisos
Vaciar todo

Problemas con actualizacion 1.6.1.0  

 
Luis Daniel
 Luis Daniel
Reputable Member

Hola Amigos
Acabo de actualizar Prestashop a 1.6.1.0 y tengo algunos problemillas en los cuales espero me puedan ayudar. Los pongo juntos porque presumo que son del mismo bando
a) Los componentes del menu superior "mi menu" y el cambio de moneda no estan activos
b) aparece sólo el título del bloque facebook (ubicado abajo de la página de inicio)
He intentado lo siguiente: reconfigurar, resetear y desinstalar y volver a instalar los módulos.
Limpié los caches
Spephan hizo su trabajo
Todo parece estar bien pero en Leo position widget sale un Warning de Fatal error, adjunto toma de pantalla, también desconozco si eso tiene algo que ver con los errores que mencioné
Espero haberme explicado con claridad y sus consejos
Gracias
Luis

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 14/08/2015 4:01 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Es posible que sea un problema de la plantilla, realizaste copia de seguridad?

ResponderCitar
Respondido : 14/08/2015 4:47 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Daniel
 Luis Daniel
Reputable Member

Hola johnny
Si, hice una copia de seguridad (total y parciales), pero volver a lo anterior me dejaría con los problemas de seguridad que ustedes comunicaron. La idea de ser posible sería superar este problema con esta actualización si fuese posible. confío en ustedes y se que me dirán lo que es mejor.
Saludos
Luis

ResponderCitar
Respondido : 14/08/2015 2:04 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Tal como te comenta Johnny, el problema que tienes tras la actualización a la versión 1.6.1.0 sea de compatibilidad con la plantilla.

Entiendo que estaban usando la versión 1.6.0.14. De ser así, podrías aplicar el parche de seguridad de esa versión de forma manual.

Para ello, y una vez que hayas vuelto a la versión 1.6.0.14, descarga el siguiente archivo zip:

https://gist.github.com/Shudrum/27fc534de69c96617280/raw/5a71ab4b31ef79f3edb1d159e08847c172b19950/patched_files_1.6.0.14.zip

Sube el archivo en la raíz de tu web y descomprímelo. Esto arreglará los problemas de seguridad.

Recuerda hacer antes una copia de seguridad completa de tu web.

ResponderCitar
Respondido : 14/08/2015 4:03 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Daniel
 Luis Daniel
Reputable Member

Hola Pablo
Entiendo que me olvido de la versión 1.6.1.0, reinstalo la 1.6.0.1 que tenía y luego aplico el parche?

Todo parece andar bien menos eso, hay un módulo "mi menú" que es compatible con 1.6.1.0, puede también resultar incompatible con el theme.
Otra pregunta, mi theme esta fuera de compatibilidad para nuevos Upgrades, porque en ese caso debiera pensar en cambiarlo.
Espero tus / vuestros consejos, gracias

Saludos
Luis

ResponderCitar
Respondido : 14/08/2015 4:12 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Revisando tu página veo que se está produciendo un error de javascript, concretamente de Jquery, que muy probablemente sea lo que causa el problema con los desplegables de la parte superior.

No puedo garantizar que esto esté provocado por la actualización a la versión 1.6.1.0 de PrestaShop, ya que también podría deberse a conflicto entre módulos. Prueba a desactivar el módulo "Mi menú" para ver si así funciona el selector de monedas.

Sobre la compatibilidad de tu tema con las nuevas versiones de PrestaShop, esto es algo que tampoco te puedo garantizar. Todo depende de los cambios que se introduzcan en las nuevas versiones de PrestaShop, y que la plantilla se adapte a estos cambios.

ResponderCitar
Respondido : 14/08/2015 4:30 pm

Cursos Gratuitos WordPress

Luis Daniel
 Luis Daniel
Reputable Member

Pablo
Desactive el módulo y sigue igual, no se si importa pero al lado tiene el módulo del blog que si funciona.
Lo raro es que a pesar de estar desactivado, quedo en le header ( a la vista en el front office)
No me gusta rendirme fácil pero creo que deberé regresar al 1.6.0.1, a propósito el parche de seguridad tambén lo cubre?
Gracias
Luis

ResponderCitar
Respondido : 14/08/2015 4:41 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Podrías hacer dos últimas pruebas antes de pasar a la versión anterior, colocar este módulo de cambio de monedas en otra posición, lo otro es verificar si tu theme tiene actualizaciones ya que es posible que sea debido a esto.

Si aplicas el parche de seguridad entonces las actualizaciones de seguridad serán aplicadas a tu sitio

Saludos.

ResponderCitar
Respondido : 14/08/2015 6:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Daniel
 Luis Daniel
Reputable Member

Hola Jhon
Cambíe el módulo "mi menú por otro que se llama: Bloque Mi cuenta en el pie de página, obviamente va en el píe de página y funciona.
Lo segundo, ¿como hago para saber si el theme tiene actualizaciones, el actual vino en un pack de ustedes?

Gracias
Luis

ResponderCitar
Respondido : 14/08/2015 6:32 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Veo que el error javascript lo genera el menú responsive, hace referencia a un selector que no existe offcanvas
Puedes comprobarlo cuando redimensionas el navegador o cuando lo ves en un movil , no funciona el menú

Revisa si en Modulos => modulos, tienes actualizaciones pendientes de módulos, tendrías que actualizarlas, especialmente si estan relacionados con el menú

Supongo que tienes la versión 1, por que no veo actualizaciones del theme
http://www.leotheme.com/prestashop/themes/269-leo-styleshop.html

Saludos.

ResponderCitar
Respondido : 14/08/2015 8:12 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Daniel
 Luis Daniel
Reputable Member

Hola Jhon
Tengo todos los módulos actualizados.
Revise las actualizaciones del theme y van por la 1,6 el tema podria estar ahí, pero por esa plata prefiero esperar y pasar a un theme que realmente sea un cambio.
Una pregunta más. yo estaba con la versión 1.6.0.1, si restauro todo a esa, ¿el parche de seguridad sirve? o no le hace falta , o debo hacer update a la 1.6.0.4 y luego aplicarlo?
Espero tu respuesta y creo que me arreglaré con eso por el momento, Gracias

Saludos
Luis

ResponderCitar
Respondido : 14/08/2015 8:47 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si aún quieres mantener la versión anterior y luego evaluar actualizar cuando decidas cambiar de Theme entonces puedes aplicar el parche indicado

Una opción más simple sería instalarte las actualizaciones de seguridad con un módulo como el que se muestra en el siguiente enlace

http://addons.prestashop.com/en/natif/20255-securitypatch.html

Según veo lo aplica también para PS 1.6 y esta actualizado

Saludos

ResponderCitar
Respondido : 14/08/2015 10:39 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Daniel
 Luis Daniel
Reputable Member

Gracias Jhon!
Por ahora vuelvo a la anterior versión mientras elijo un tema nuevo, le aplicaré el parche y seguro cuando instale el nuevo theme hare el upgrade a 1.6.1.0.
Por el momento y salvo Ustedes piensen otra cosa, doy por cerrado este hilo, Muchas Gracias

ResponderCitar
Respondido : 14/08/2015 10:59 pm