Avisos
Vaciar todo

Mi web se rompe al actualizar el tema  

Página 3 / 3
 
Farmaciola
 Farmaciola
Estimable Member

Buenos días, haber ya hace semanas que tengo un problema en mi web. En concreto es un comercio online echo con CMS Wordpress 9.3.4 y el plugin Woocommerce 3.3.1. El problema es que al actualizar mi tema la web se rompe,no se carga ni la mitad de contenido y queda partida. Me he puesto en contacto con el autor (Hace 2 semanas que estamos con este tema), y el me dice que en la actualización no hay que haber ningún problema porque es 100% compatible con la versión de Woocommerce. Me comenta que seguramente viene del host... Hace días ya os lo comente en un hilo del foro, me mirasteis el host, me dijisteis que esta todo correcto, he creado un entorno de pruebas para replicarlo y pasa igual, en el hilo desactivando plugins vi que al desactivar el plugin "Wizestore Core", luego la página vuelve a cargar, no carga al 100% faltan unos detalles pero vuelve a cargar. Mi tema es el Wizestroe for Woocommerce y este plugin es del tema, esto ya lo sabe el autor pero el me dice que esta todo correcto.
Como podemos solventar el tema? Ya no se que hacer, lo que quiero es solo poder actualizar el tema, me han pasado ya muchas cosas pero como esta ninguna, todo lo he ido solucionando, pero ahora ya no se que hacer y temo por no poder actualizar el tema, ya que corrigen muchas cosas las actualizaciones, y lo tengo que arreglar porque a la larga si no lo actualizo los plugins no serán compatibles tampoco.
Pido ayuda por favor. Podéis mirarlo todo por favor, que este todo correcto, respecto a mi dominio "elitderm.com".
Muchas gracias.

Citar
Respondido : 12/02/2018 6:47 pm
Farmaciola
 Farmaciola
Estimable Member

ok, porque el problema esta en que puedo activar la licencia en el entorno de pruebas, pero en el entorno de producción no puedo activarla. Es curioso, haber si me dice algo mas. Lo de actualizar el tema ya lo dejo de momento, ahora me interesa poderlo activar con licencia pro si algún día tengo que hacer cambios visuales en el tema.
Gracias.

ResponderCitar
Respondido : 20/02/2018 6:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Ok, entiendo, veremos que te responde entonces.

Saludos.

ResponderCitar
Respondido : 20/02/2018 8:18 pm
Farmaciola
 Farmaciola
Estimable Member

Buenos días, de momento no me dice nada de nada, el soporte que he pagado de momento no me ha ayudado por parte del autor del tema. Hoy vuelvo a entrar a mi sitio de pruebas y tampoco puedo activar el tema, mientras ayer si que me dejaba. E echo una restauración con Superbackup ahora mismo.
Puede que algo del Host me obstruya la activación del tema? Podemos mirar bien mi Host haber como esta?
Que no haya algún cache o algo que impiden la actualización correcta, no es normal que ayer pudiese y hoy no.
Podemos mirar bien mi dominio adicional "Elitderm.com"?
Gracias.

ResponderCitar
Respondido : 21/02/2018 9:45 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Nosotros desde foro no podemos acceder a vuestras cuentas, puedes mandar un ticket desde tu área de clientes explicado lo que te pasa y pidiendo que revisen tu cuenta por si hubiera algún bloqueo que afecta.

Un saludo

ResponderCitar
Respondido : 21/02/2018 12:04 pm
Farmaciola
 Farmaciola
Estimable Member

Haber el autor o uno de sus compañeros a entrado al wp-admin de mi web "elitderm.com" y con solo 2 minutos me ha activado el tema.
Como puede ser? Yo he estado horas probando, escribiendo la licencia y a darle al botón "Activar" para que se me activase, puede ser que mi ip publica hacia Webempresa este bloqueada o algo?
No entiendo porque, también lo probé con varios navegadores diferentes.
Por lo tanto tema activado con licencia, 1 problema menos.
Ahora solo me faltara ver porque se me rompe la web al actualizar el tema.
Pero lo que me preocupa es que ellos entrando en mi wp-admin si les funciona a mi no, de donde puede venir ese problema?
Gracias.

ResponderCitar
Respondido : 21/02/2018 4:36 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si el servidor te hubiera bloqueado no podría ni entrar al administrador.
Tal vez haya sido un problema puntual de cookies o algo específico referido al navegador que has estado usando.

Saludos.

ResponderCitar
Respondido : 21/02/2018 4:45 pm
Farmaciola
 Farmaciola
Estimable Member

Ok, ya no se por donde vienen los errores, me perdí ejej. Use el Internet Explorer y el Google Chrome y nada, ninguno me fue bien.
Ok, tema resuelto lo de activación del tema.
El otro problema que tengo (Al actualizar tema se me rompe la web), este si que no tiene nada que ver con las cookies o exploradores, supongo.
Volveré hablar con ellos para que se lo miren bien y os comento, aquí en Webempresa ya me habéis dicho por parte de Host que está todo bien 😉
Haber para ir bien lo tengo que solucionar, ya que actualizar temas,plguins... Soluciona errores de seguridad y demás, pero si no se puede, lo dejare sin actualizar.
Gracias.

ResponderCitar
Respondido : 21/02/2018 5:13 pm

Cursos Gratuitos WordPress

Farmaciola
 Farmaciola
Estimable Member

Después de 1 mes y algo he descubierto porque se me rompía la web al actualizar el tema. Os explico cuando empece a crear la web y empece a crear los formularios de contacto (plugin contact form)con el recpactha integrado, seguí una guía en el cual me decía que se tenía que poner un código de Google en el archivo "header.php" (archivo de dentro el tema), antes de la linea

, tal como se muestra en la captura de pantalla que adjunto.
Segun tu compañero John no hace falta agregar el código de Google dentro el archivo "header.php" de mi tema, poruqe sin agregarlo carga igual y me parece que es así 😉
Pues yo al poner ese código allí en ese archivo cada vez que se actualiza el tema lógicamente desaparece esa linea, y al no estar la linea de código en el archivo "header.php, la web se me rompía por todos sitios.
Hoy he visto que actualizando el tema y escribiendo la linea de código allí, ya puedo actualizar el tema! También he actualizado a la versión de Woocomerce mas reciente y también perfecto! (Antres no me dejaba). Era la linea de código, pero no lo entiendo es como si Google hubiera registrado esa linea en el host y sin esta en el tema, la web se rompe.
Por lo tanto descartado todos los plugins, plantillas obsoletas que podían quedar sin actualizar,el nucelo del tema, también el autor decía que podría venir de un bloqueo de Host, pues también esta teoría fuera.
Ya está resulto lo único que me gustaría entender es porquie sin esa linea no puedo actualizar el tema.
Haber si sabéis alguna explicación lógica...
Muchas gracias 😉 :laugh:

ResponderCitar
Respondido : 16/03/2018 2:16 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Efectivamente la actualización debería sobreescribirte los archivos directamente, salvo haga algún tipo de comprobación antes, para saber si los archivos son iguales, etc. Tal vez tenga que ver con alguna comprobación de seguridad que hace el theme antes de actualizar.

Que bueno que finalmente encontraste el problema, te sugiero documentar esto en caso te vuelva a ocurrir.

Saludos.

ResponderCitar
Respondido : 16/03/2018 4:36 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Farmaciola
 Farmaciola
Estimable Member

Creo que me pasara siempre al haber puesto el código ese de Google, cada vez que actualice el tema tendré que ir dentro el archivo header.php y poner el dichoso código, ya que sin él la web se me romperá.
Lo que no entiendo es que sin él se me rompa, ese código se registro allí y ahora siempre lo tendré que poner cuando actualice el tema.
Bueno si alguien mas sabe acerca de ese código y porque lo debo poner después de actualizar mi tema, que comente por favor, hablare con el autor del tema haber si deduce alguna explicación lógica.
Muchas gracias por todo!
Saludos!

ResponderCitar
Respondido : 16/03/2018 4:52 pm
Farmaciola
 Farmaciola
Estimable Member

De momento voy actualizando el tema de esa forma, guardo la línea de código de Google en el portapapeles,
actualizo, me voy al archivo header del tema, y le vuelvo a poner la linea de Google, una vez puesta la linea de código, la web vuelve a quedar perfecta.
Si alguien sabe el porque que nos lo explique por favor, no acabo de entender porque dependo de esa linea de código.
Muchas gracias y buenos días 🙂

ResponderCitar
Respondido : 02/05/2018 10:48 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Por favor, serias tan amable de abrir otro hilo con la consulta que nos quieres realizar, este lleva ya mucho tiempo y entre unas cosas y otras llevamos tres paginas con lo que nos resulta complicado seguir el hilo a mas que ya no se de que dominio estamos hablando.

Abre un nuevo hilo con la consulta e indicando a que dominio haces referencia.

Disculpa pero se nos hace complicado poder seguir este hilo 😉

ResponderCitar
Respondido : 02/05/2018 2:06 pm
Farmaciola
 Farmaciola
Estimable Member

Perfecto, así lo haré.
Ya podéis cerrar este tema.
Gracias.

ResponderCitar
Respondido : 02/05/2018 2:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Página 3 / 3