Pregunta sobre actualizaciones y plugins wordpress  

 
Ramón
 Ramón
Reputable Member

Hola

Os hago una pregunta sobre una duda que me surge acerca del tema y tareas de actualizaciones de wordpress.

En worpress, a la hora de instalar un plugin, te informan si este esta probado en la versión que uno tiene instalada, siendo más que recomendable no instalarlo si no es compatible.

Bien, entonces que ocurre con los plugins que uno tiene instalados, cuando actualiza a la ultima versión de wordpress?
Por lo que veo y experimento hasta la fecha, la respuesta es nada, entonces, donde radica el problema a la hora de instalar un plugin cuya versión no es compatible (por no haberse probado) con la ultima versión wordprees, pero si con la predecesora?

Intentare explicarme mejor por si no lo hice correctamente.

Tengo la versión 3.7.1 de wordpress.
Quiero instalar un plugin cuya versión esta probada hasta la 3.6 de wordpress.

¿Que hacer?

Muchas gracias 🙂

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 27/11/2013 7:17 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Ramón

Usualmente suelen ser compatibles y no deberías tener problemas.

Evidentemente si el desarrollador ha verificado el plugin para la nueva versión de wordpress será mucho más confiable.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/11/2013 8:34 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ramón
 Ramón
Reputable Member

Hola Jhon

Muchas gracias por tu respuesta, pero... no termino de comprenderlo.

Si no es bueno instalar un plugin "no compatible con la versión actual del wordpress", porque es recomendable actualizar el wordpress. Al hacerlo, a los plugins instalados no les pasa nada, por eso me pregunto ¿donde esta lo malo de instalar un plugin no probado con la versión actual de wordpress? :dry:

ResponderCitar
Respondido : 27/11/2013 10:01 pm
Ramón
 Ramón
Reputable Member

Pongo un ejemplo del que me acabo de dar cuenta:

En el vídeo del blog https://www.webempresa.com/blog/item/1279-fuentes-google-en-wordpress-con-wp-google-fonts.html se instala el plugin Google Fonts cuya versión es compatible hasta la 3.5.2 en una versión worpress 3.7.1

A esto es a lo que me refiero :whistle:

ResponderCitar
Respondido : 27/11/2013 10:11 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ramón,

Primero y muy importante, WordPress 3.7 incorpora "por defecto" las "actualizaciones del core "automáticas" es decir, las realiza "si o si" si detecta que hay una nueva.

- https://www.webempresa.com/blog/item/1252-deshabilitar-las-actualizaciones-automaticas-en-wordpress-3-7-x.html

Segundo y contraviniendo lo que dice Jhon, no es correcto, un plugin que era "estable" y válido en 3.6 (o inferiores versiones) NO tiene porque ser (por el hecho de ya estar instalado en tu WordPress) compatible con la versión 3.7 o superiores, por lo que "siempre" es importante asegurarse, tras una actualización del "core" que los plugins que ya teníamos en uso siguen siendo compatibles con la nueva versión del "core" y esto solo se puede hacer verificando plugin por plugin en la web del autor.

Cierto es que como "el valor" se le supone, es decir, debería ser una actualización que no afectase a las versiones de los plugins, pero sucede que no siempre los desarrolladores de plugins hacen las cosas correctamente y o bien no tienen en cuenta los nuevos cambios del "core" o sencillamente dejan sus plugins en versiones "vulnerables" que finalmente suponen un riesgo para la instalación que las use.

Copia de Seguridad debería ser lo primero a plantearse siempre y luego usar el senso y analizar cuan vulnerable puede ser tu sitio web un función de los plugins que uses y su procedencia.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/11/2013 11:32 pm
Ramón
 Ramón
Reputable Member

Hola Luis

Antes que nada, disculpa el retraso de mi respuesta.

Veo que en este tema del Blog se instala un plugin cuya versión esta comprobada hasta la 3.4.2 en un wordpress 3.7.1

A lo primero:
Esto es una buena ayuda a mantener una correcta actualización.

A lo segundo:
Es lo que yo, bajo mi modesta opinión, entiendo. Pero ya ves que no siempre es así.
Uno busca un determinado plugin, y cuando lo encuentra puede tener la suerte de que este sea compatible con la versión instalada y entonces no hay problema, pero... cuando el plugin encontrado no es compatible con la versión, te surge el dilema, instalarlo o no instalarlo, esa es la cuestión.
Pero por lo visto en los últimos artículos del blog (como decía al principio) no es tan importante este detalle, así que me quedo con la duda del principio.

A lo tercero:
Sin lugar a dudas, copia de seguridad full-time, pero que ocurre con trabajos realizados entre copia y copia cuando se detecta que tras una actualización el plugin instalado no funciona correctamente o afecta a otras partes?

Mi resumen del asunto es. Aguantarse las ganas de instalar un plugin no compatible con la versión del wordpress y punto, de lo contrario, "confiar" en ese supuesto "VALOR" (como en la mili) y que el desarrollador sea un tipo comprometido con la causa y nos brinde la actualización correspondiente.

Es correcto?

ResponderCitar
Respondido : 01/12/2013 8:32 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ramón,

cuando el plugin encontrado no es compatible con la versión, te surge el dilema, instalarlo o no instalarlo, esa es la cuestión.

NO se exactamente que te pueden decir otros técnicos al respecto de actualizaciones de WordPress, uso de plugins fuera de versión, no actualizados por sus autores (comodidad, falta de tiempo, desinterés) pero lo cierto es que "cada día", repito "cada día" publico las vulnerabilidades relativas a WordPress, themes y plugins de terceros en Twitter y es sorprendente que mientras publico 1 o 2 vulnerabilidades por mes de Joomla, llego a publicar más de 10 o 15 vulnerabilidades para plugins y themes de WordPress por mes.

Supongo que esto es un indicador ¿no?, y por supuesto la responsabilidad última de hacer uso de estos plugins recae sobre ti que es quien debe decidir si vale la pena arriesgar una instalación en producción por una u otro funcionalidad adicional obtenida por medio de un plugin.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/12/2013 8:47 pm
Ramón
 Ramón
Reputable Member

Hola Luis

Mas claro, agua !! El usuario debe de primar la seguridad sobre otras muchas cuestiones.

Gracias y saludos 😉

ResponderCitar
Respondido : 01/12/2013 9:42 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro