Problema con wordpress multisitio basado en subdominios  

 
Juan Jose
 Juan Jose
Nuevo usuario

Hola, he configurado en wordpress un multisitio como se indica en el articulo www.webempresa.com/blog/red-de-sitios-wordpress-multisite.html, con el sistema subdominios, ya que la intención es crear diferentes secciones dentro de la temática de la web.

Todo ha ido correctamente, la pagina principal funciona correctamente, se pueden crear los diferentes subdominios con el administrador de red, te envía los correos y avisos. Aparte he creado en cpanel los diferentes subdominios en la carpeta del dominio utilizado.

El problema lo tengo cuando intento acceder al escritorio de los subdominios me sale el siguiente error:
"Not Found

The requested URL /index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."·

Obviamente esto me indica que no hay archivo index.php, y mi pregunta es si aparte de crear el multisitio, tengo que incluir algunos archivos más en cada subdominio, o esto lo hace todo wordpress al instalar el multisitio.

He leído y releído cada uno de los post anteriormente enviados y el que más tiene en común es este Link a post de foro, solo visible a usuarios registrados por lo que he probado cada una de las soluciones planteadas.

Por favor, alguien me pueda indicar la razón de porque pasa esto o pueda darme alguna solución,

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 23/01/2017 5:17 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Has probado configurar nuevamente pero con carpetas?,
Al parecer no eres el único que tiene ese problema, revisa por ejemplo:
https://wordpress.org/support/topic/problem-creatin-subdomain-i-am-getting-no-index-php-found-404-error/

Según indica en la respuesta debes eliminar los subdominios que has creado en Cpanel.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/01/2017 10:19 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan Jose
 Juan Jose
Nuevo usuario

Muchas gracias Jhon, segun esta informacion hay que crear o configurar subdominios comodín (que realmente no se lo que significa) :blink: :blink: , aunque en la informacion de wordpress tambien explica que puede hacerse de las dos formas, o crear subdominios desde cpanel o esta otra forma.
- https://codex.wordpress.org/Create_A_Network
- https://codex.wordpress.org/Before_You_Create_A_Network

El subdominio comodin _wildcard_ esta creado en la zona DNS de cpanel. Se crea automaticamente al crear un subdominio *.qhadi.es, pero aun borrando los subdominios anteriormente no funciona.

Ya que mi ingles es de nivel 0, osea traductor google :blush: :blush: , por favor puedes explicarme que comenta este enlace y si es correcto https://en.wikipedia.org/wiki/Wildcard_DNS_record

Gracias

ResponderCitar
Respondido : 24/01/2017 3:19 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Prueba crear el WildCard subdomain en el Cpanel de tu cuenta de hosting, revisa las imágenes del siguiente link:

https://www.namecheap.com/support/knowledgebase/article.aspx/9191/29/how-to-create-a-wildcard-subdomain-in-cpanel#paper_lantern

Asegúrate de apuntar el subdominio a la misma localización en donde tienes tu WordPress.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/01/2017 5:59 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan Jose
 Juan Jose
Nuevo usuario

Creo que la principal razon del fallo de todo esto es:
"WordPress debe ejecutar desde la raíz de la Carpeta Web (es decir public_html ) para los subdominios funcionen correctamente. No van a trabajar desde dentro de un subdirectorio."

Como soluciono esto si mi dominio principal de Webempresa no es el que quiero utilizar para el wordpress multisitio??

ResponderCitar
Respondido : 24/01/2017 6:04 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

HOla

Debería poderse realizar con dominios adicionales, has probado con la wildcard que te envié, si creas el subdominio de tu dominio adicional apuntando a la carpeta de tu dominio te sucede lo mismo?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/01/2017 7:02 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan Jose
 Juan Jose
Nuevo usuario

Si, entre una cosa y otra, ahora funciona!!!. Parece ser que como soy un "tuercebotas" :S :S incluía siempre _wildcard_, y al quitarlo, gracias al articulo que me has enviado, lo he probado así, y funciona.

Muchas gracias

ResponderCitar
Respondido : 24/01/2017 8:07 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Que bueno que lo solucionaste

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/01/2017 10:24 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro