Avisos
Vaciar todo

Artículo enlazado desde menu  

 
Miguel Sempere
 Miguel Sempere
Usuario activo

Saludos.
He creado un menú superior, que debe dar acceso a otras partes de la web. Por ejemplo, "Contacto" debería abrir la web de contacto con la información acerca de como contactar con la empresa.

Para ello he creado un apartado del menú que se llama prueba y he configurado que al pulsarlo enlace a un artículo ya creado.
En el menú, he puesto que sea tipo enlace a un artículo, y que su enlace sea index.php?option=com_content&view=article&id=63 . Pues bien, luego al pulsar sobre ese botón, el enlace que hace es hacia http://tuclinicadelpie.es/index.php/prueba y por tanto no me abre el artículo que había creado.

¿A que se debe?
Muchas gracias.

URL del sitio: http://www.tuclinicadelpie.es

Citar
Respondido : 22/04/2012 10:51 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Miguel Sempere,

Facilitanos una captura de como tienes los parámetros SEO de tu Configuración Global.

Saludos

ResponderCitar
Respondido : 23/04/2012 12:53 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Miguel Sempere
 Miguel Sempere
Usuario activo

Saludos, gracias por la velocidad en responder.

La respuesta me hizo pensar que uno de los problemas era que tenía activada la opción "URLs amigables para motores de búsqueda". Ahora si que enlaza con el artículo correcto, pero a pesar de que esto funcione y que el artículo exista, no aparece nada del artículo, sino la misma web inicial pero con la URL cambiada.

Gracias y un saludo.

ResponderCitar
Respondido : 23/04/2012 8:18 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Miguel,

La demo de esta plantilla gratuita, tampoco ayuda mucho http://www.globbersthemes.com/demo/hyuster/ ya que no existe navegación por el sitio web, todos los menús son enlaces externos.

Hay diferencias con la tuya, que si muestra debajo de los textos a tres columnas, más texto que corresponderá a los artículos.

Envíanos captura de pantalla de la administración de la plantilla (administración --> extensiones --> gestor de plantillas --> editar la plantilla en cuestión) para que podamos ver los parámetros.

Saludos

ResponderCitar
Respondido : 23/04/2012 8:51 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Miguel Sempere
 Miguel Sempere
Usuario activo

Hola Miguel,

La demo de esta plantilla gratuita, tampoco ayuda mucho http://www.globbersthemes.com/demo/hyuster/ ya que no existe navegación por el sitio web, todos los menús son enlaces externos.

Hay diferencias con la tuya, que si muestra debajo de los textos a tres columnas, más texto que corresponderá a los artículos.

Envíanos captura de pantalla de la administración de la plantilla (administración --> extensiones --> gestor de plantillas --> editar la plantilla en cuestión) para que podamos ver los parámetros.

Saludos

Saludos.
Si te refieres al código, le pego el index.php:










	
	
	id) initEditor(); ?>
	<meta http-equiv="Content-Type" content="text/html; " />

<link rel="stylesheet" href="baseurl ?>/templates/hyuster/css/tdefaut.css" type="text/css" media="all" />
<link rel="stylesheet" href="baseurl ?>/templates/hyuster/css/joomlastyle.css" type="text/css" media="all" />
<link rel="stylesheet" href="baseurl ?>/templates/hyuster/css/box.css" type="text/css" media="all" />
<script type="text/javascript" src="templates/template ?>/js/mootools.js">
<script type="text/javascript" src="templates/template ?>/js/scroll.js">
<script type="text/javascript" src="templates/template ?>/js/script.js">
<script type="text/javascript" src="templates/template ?>/js/cufon-yui.js">
<script type="text/javascript" src="templates/template ?>/js/cufon-replace.js">
<script type="text/javascript" src="templates/template ?>/js/Bebas_400.font.js">
<link rel="icon" type="image/gif" href="baseurl; ?>/templates/template; ?>/favicon.gif" />
<script type="text/javascript" src="templates/template ?>/js/jquery.js">
<script type="text/javascript" src="templates/template ?>/js/slideshow.js">

        window.addEvent('domready', function() {
        SqueezeBox.initialize({});
        $$('a.modal').each(function(el) {
            el.addEvent('click', function(e) {
                new Event(e).stop();
                 SqueezeBox.fromElement(el);
            });
         });
      });
    

 

params->get("caption", "Donde el corazón se inclina, el pie camina...");
$license	= "globbersthemes.com";
?>

    countModules( 'right' );
     if ( $mod_right ) { $width = '';
    } else { $width = '-full';}
     ?>



<img src="templates/template ?>/images/slide1.jpg" alt="image1" /> <img src="templates/template ?>/images/slide2.jpg" alt="image2" /> <img src="templates/template ?>/images/slide3.jpg" alt="image3" /> <img src="templates/template ?>/images/slide4.jpg" alt="image1" />

var $j = jQuery.noConflict(); $j(document).ready(function(){ $j("#slideshow").slideshow({ pauseSeconds:5, height:273, fadeSpeed:0.5, width:744, caption: false }); }); countModules('user1') || $this->countModules('user2') || $this->countModules('user3')) { ?>
countModules('right')) { ?>
ResponderCitar
Respondido : 23/04/2012 8:58 am
David Noguera
 David Noguera
Miembro Admin

Hola Miguel, no veo que se incluya la etiqueta del tipo

<jdoc:include type="component"

Podrías cambiar la plantilla por la estándar de Joomla y probar si así te funciona bien y después volver a cambiar a la plantilla que tienes ahora??

Saludos

ResponderCitar
Respondido : 23/04/2012 10:20 am

Cursos Gratuitos WordPress

Miguel Sempere
 Miguel Sempere
Usuario activo

Hola Miguel, no veo que se incluya la etiqueta del tipo

<jdoc:include type="component"

Podrías cambiar la plantilla por la estándar de Joomla y probar si así te funciona bien y después volver a cambiar a la plantilla que tienes ahora??

Saludos

Saludos.
Gracias. He cambiado a otra plantilla que instalé, ya que las que vienen por defecto las tengo desinstaladas y si que me aparece el artículo debajo de las columnas.
En cuanto a <jdoc:include type="component" , ¿te refieres a que puede que me falte dicha linea en el código y por ello no salgan los artículos?

ResponderCitar
Respondido : 23/04/2012 10:33 am
Miguel Tuyaré
 Miguel Tuyaré
Honorable Member

Hola Miguel:

Si, a lo que se refiere David es a que falta esa línea de código la cual es crucial para ver contenidos.

Tal vez has hecho alguna modificación en el index.php y la has eliminado, revisa eso.

ResponderCitar
Respondido : 23/04/2012 1:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación