Avisos
Vaciar todo

Boton no me muestra el contenido del articulo  

Página 2 / 2
 
Jose Miguel
 Jose Miguel
Estimable Member

Hola señores:

Pues ahora me ocurre algo muy extraño, creo un boton, le añado un articulo y me tira esto..


"Not Found

The requested URL /mijoomla/tours-ivao/tours-ivao.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

He mirado los errores que me tira el log de errores del Cpanel y pone esto..

Tue Oct 05 14:46:19 2010] [error] [client 85.137.148.230] File does not exist: /home/midominio/public_html/404.shtml, referer: http://www.midominio/mijoomla/

como es que no existe? o que es lo que no existe?

Un salu2

Citar
Respondido : 05/10/2010 4:03 pm
Leonel Cantón
 Leonel Cantón
Estimable Member

En la parte del SEO de la configuración de joomla tienes los 3 parámetros activados?

Voy a intentar replicar la situación en un servidor de webempresa para buscarle una solución

Saludos,

Leonel

ResponderCitar
Respondido : 13/10/2010 5:54 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose Miguel
 Jose Miguel
Estimable Member

Si lo activo, no se muestra los articulos, sin embargo desactivado si salen.

Creo que todo viene originado por el archivo .hacces, que gnumax me añadió uno en mi joomla ya que segun él, no habia, sino estaba el haccess.txt, por ahi bienen los tiros.

Un salu2

ResponderCitar
Respondido : 13/10/2010 5:56 pm
Leonel Cantón
 Leonel Cantón
Estimable Member

Ya probastes así

Estoy teniendo problemas para accesar a mi sitio de pruebas, pero en cuanto tenga re-establecida la conexión hago las pruebas y te comento.

Saludos,

Leonel

ResponderCitar
Respondido : 13/10/2010 6:28 pm

Jose Miguel
 Jose Miguel
Estimable Member

Asi lo tengo, de otra forma no me funciona.

ResponderCitar
Respondido : 13/10/2010 7:10 pm
Jose Miguel
 Jose Miguel
Estimable Member

Hola, este es el contenido del "htaccess"

##
# @version $Id: htaccess.txt 2368 2006-02-14 17:40:02Z stingrey $
# @package Joomla
# @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
# Only use one of the two SEF sections that follow. Lines that can be uncommented
# (and thus used) have only one #. Lines with two #'s should not be uncommented
# In the section that you don't use, all lines should start with #
#
# For Standard SEF, use the standard SEF section. You can comment out
# all of the RewriteCond lines and reduce your server's load if you
# don't have directories in your root named 'component' or 'content'
#
# If you are using a 3rd Party SEF or the Core SEF solution
# uncomment all of the lines in the '3rd Party or Core SEF' section
#
#####################################################

##### SOLVING PROBLEMS WITH COMPONENT URL's that don't work #####
# SPECIAL NOTE FOR SMF USERS WHEN SMF IS INTEGRATED AND BRIDGED
# OR ANY SITUATION WHERE A COMPONENT's URL's AREN't WORKING
#
# In both the 'Standard SEF', and '3rd Party or Core SEF' sections the line:
# RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
# May need to be uncommented. If you are running your Joomla! from
# a subdirectory the name of the subdirectory will need to be inserted into this
# line. For example, if your Joomla! is in a subdirectory called '/test/',
# change this:
# RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
# to this:
# RewriteCond %{REQUEST_URI} ^(/test/component/option,com) [NC,OR] ##optional - see notes##
#
#####################################################

## Can be commented out if causes errors, see notes above.
Options FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /

########## Begin Standard SEF Section
## ALL (RewriteCond) lines in this section are only required if you actually
## have directories named 'content' or 'component' on your server
## If you do not have directories with these names, comment them out.
#
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
#RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$ [NC]
#RewriteRule ^(content/|component/) index.php
#
########## End Standard SEF Section

########## Begin 3rd Party or Core SEF Section
#
#RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
#
########## End 3rd Party or Core SEF Section

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR] # Block out any script that includes a tag in URL RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR] # Block out any script trying to modify a _REQUEST variable via URL RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-
Z]{0,2}) # Send all blocked request to homepage with 403 Forbidden error! RewriteRule ^(.*)$ index.php [F,L] # ########## End - Rewrite rules to block out some common exploits ########## Bloqueo de IPs # Deny from 189.106.146.170 #

Un salu2

Nota.- Tengo otro joomla que el archivo htaccess contiene solo esto: (he ocultado con x los datos reales, por eso de la privacidad temporal)

RewriteEngine on

RewriteCond %{HTTP_HOST} ^xxx.xx$ [OR]
RewriteCond %{HTTP_HOST} ^xxx.xx$
RewriteRule ^/?$ "http://www.xxx..xx" [R=301,L]

RewriteCond %{HTTP_REFERER} !^ http://xxx.xx/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^ http://xxx.xx$ [NC]
RewriteCond %{HTTP_REFERER} !^ http://www.xxx.xx/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^ http://www.xxx.xx$ [NC]
RewriteRule .*.(jpg|jpeg|gif|png|bmp|swf)$ - [F,NC]

RewriteCond %{HTTP_HOST} ^xxx.xx$ [OR]
RewriteCond %{HTTP_HOST} ^www.xxx.xx$
RewriteRule ^/?$ "http://www.xxx.xx/xxxx/" [R=301,L]

ResponderCitar
Respondido : 13/10/2010 7:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Leonel Cantón
 Leonel Cantón
Estimable Member

Hola, los 2 archivos son muy similares, toma en cuenta que cualquier linea que empiece con # es un comentario, y si en el primer caso eliminas todos los comentarios, te queda algo muy similar.

Estoy comparando tus htaccess con uno que tengo (en otro server) y cuando pueda lo comparo con el que tengo de pruebas en el webempresa.

Saludos,

Leonel

ResponderCitar
Respondido : 13/10/2010 8:44 pm
Jose Miguel
 Jose Miguel
Estimable Member

Gracias amigo, esperaré.

Un salu2

ResponderCitar
Respondido : 13/10/2010 8:51 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Kenedi,

El archivo "oficial" que utilizamos en los servidores de Webempresa es el que te adjunto al final. Solo funciona correctamente en nuestros servidores y no te garantizo que no tengas un error si lo utilizas en otros.

No olvides una vez subido renombrarlo a .htaccess en tu /public_html. Lo ideal es que lo hagas desde el administrador de archivos de cPanel.

Saludos

Esta publicación ha sido modificada el hace 4 años por antonio
ResponderCitar
Respondido : 13/10/2010 9:48 pm
Jose Miguel
 Jose Miguel
Estimable Member

Hola gnumax, me alegro verte por aqui.

Yo, sistema joomla, solo lo tengo en webempresa, en otras tengo html,etc., osea, que solo lo usare en webempresa.

Voy a probar, gracias gnumax, se lo que cuesta dar respuesta a tantos asuntos distintos, mi enhorabuena a todo el equipo.

Un Salu2

ResponderCitar
Respondido : 13/10/2010 9:56 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose Miguel
 Jose Miguel
Estimable Member

Bueno, pues al parecer no puedo activar las url amigables porque no se me muestran los articulos debidamente, siempre muestra "creo" el último editado y por mas que pulses, siempre muestra lo mismo, ahora bien, si desactivo las url amigables me va todo a la perfección. Así que ya no se que probar.

.... :huh:

Un salu2

ResponderCitar
Respondido : 13/10/2010 11:30 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Kenedi,

En principio con el mod_rewriter funcionando en tu servidor y htaccess debidamente renombrado y activado no deberías tener el problema que comentas. Si el servidor te devuelve errores HTTP 505 , eso es porque no tiene disponible el mod_rewrite de Apache pero en tu caso no es así.

¿Tienes alguna otra extensión SEF activada?

Saludos

ResponderCitar
Respondido : 14/10/2010 2:35 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose Miguel
 Jose Miguel
Estimable Member

Hola Gnumax:

Esto es muy extraño, desde webempresa me han cambiado el famoso htaccess y para mas inrri, borré el joomla y lo instalé de nuevo sin nada, por defecto, solo le he metido la plantilla que fue creada con artister, ya no tiene nada instalado, y si activo las url amigables, NO me da el error " tipo 404 ni nada por el estilo" sino, que no salen los articulos al pulsar los botones de los menus, pero si desactivo las url amigables, si se me muestran. Qué relación existen entre las url amigables y la información que muestra al pulsar un boton? que hay que los vincula? porque el error viene por ahí, voy a indagar por google a ver que encuentro, pero ya te digo, extensiones tipo SEF (que no se qué es) no he instalado nada, repito, esto todo por defecto, instalado el pack joomla del hosting, y solo tiene la plantilla creada por artister.

Qué raro... :dry: :blink: :S :huh: :ohmy: 🙁

ResponderCitar
Respondido : 14/10/2010 11:33 am
Jose Miguel
 Jose Miguel
Estimable Member

Yuuuuupiiiiiiii !! :woohoo: , por fin dieron con el problema!! :laugh: gracias WEBEMPRESA !!.

Publicare un post "PROBLEMA URL AMIGABLES" con la solución.

Un salu2

ResponderCitar
Respondido : 14/10/2010 12:19 pm

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Kenedi,

Me alegro que con la ayuda de los técnicos de Webempresa hayas podido solucionar el problema que espero compartas con nosotros por si algún usuario más se encuentra en las mismas.

Saludos

ResponderCitar
Respondido : 14/10/2010 10:48 pm
Jose Miguel
 Jose Miguel
Estimable Member

Hola Gnumax, ya lo hice publicando un post con mi problema y la solución, pero para que veas, un simple dato en un campo en concreto ha sido todo el quebradero de cabeza, y claro!! ustedes dais por hecho que eso, lo tenemos controlado!! y lo descartais como posible problema, por eso ha durado tanto la cosa, y yo!!, que me iba a imaginar que eso me pudiera dar problemas, ahora si que lo se, y ha sido gracias a todo el equipo de webempresa, un millón de gracias.

Salu2

ResponderCitar
Respondido : 14/10/2010 11:34 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 2 / 2