Meta description y Keywords vacíos  

 
Aitor
 Aitor
Usuario activo

Hola

Tenemos un problema y no sabemos como solucionarlo: a pesar de haber introducido los metas de la descripción y palabras clave en sitio/configuracion global, el código aparece vacío:


Adjunto un pantallazo del gestor de Joomla.

He probado a copiar y pegar el HEAD del index.php de otro Joomla que realizamos y donde los meta sí aparecen ( http://www.panlakua.com/) con la misma plantilla (beez) pero los meta siguen aparecer, así que no parece que el problema esté en ese archivo.

¿Sabeis que puede haber pasado? ¿Qué archivo gestiona los meta tags?

Muchas gracias,
Eloy

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 17/09/2012 5:29 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Aitor

Estos valores se guardan en la base de datos y no en un archivo específico

Estas usando alguna extensión adicional de urls amigables o SEO?, estas usando Joomfish?

Si estas usando por ejemplo Joofish puedes definir estos valores a nivel de Joomish, en la configuración de tu idioma.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/09/2012 11:13 pm

Cursos Gratuitos WordPress

Aitor
 Aitor
Usuario activo

Efectivamente estamos utilizando Joomfish pero añadiendo los meta en la configuración de cada idioma siguen sin aparecer en el código.


Adjunto pantallazo.

ResponderCitar
Respondido : 18/09/2012 9:19 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Aitor,

¿ Si utilizas otra plantilla en el frontal del sitio web, se muestran entonces los metadatos ?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 18/09/2012 9:24 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Aitor
 Aitor
Usuario activo

Hola,

Acabo de probar con la platilla JA_Purity y tampoco se muestran los metadatos

ResponderCitar
Respondido : 18/09/2012 9:53 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Aitor,

¿ Puedes enviar una captura de pantalla de como tienes los metadatos en la configuración global de Joomla! ?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 18/09/2012 2:59 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Aitor
 Aitor
Usuario activo

Hola Jordi,

Sí, ese pantallazo lo adjunté en el primer mensaje de este post, como puedes ver ya rellené los campos.

Investigando he encontrado esto por ahi:
http://www.joomfish.net/forum/viewtopic.php?f=8&t=1448

"I found the solution

administrator/components/com_joomfish/tables/JFLanguage.php

// allow bind of aggregated objects
- $this->jLanguageTable->bind($newValues);
+ // Kochin: The original code only works correctly when $newValues is an array,
+ // but $newValues may be a TableJFLanguage object.
+ if (is_a($newValues, 'TableJFLanguage')) {
+ $this->jLanguageTable->bind($newValues->jLanguageTable);
+ } else {
+ $this->jLanguageTable->bind($newValues);
+ }
// If the core language object includes special meta information we ensure those are stored in our parameter objcet
$langParameter = new JParameter($this->params);
$langParameter->set('MetaDesc', $this->jLanguageTable->get('metadesc'));

and all work"

Aunque lo he probado en local y tampoco funciona, gual no lo he hecho bien porque no sé mucho de PHP, eso sí ya he quitado los "+" y lo he dejado sin errores de sintaxis.

¿Por qué no aparecerán los metadatos? en fin, vaya misterio...

ResponderCitar
Respondido : 18/09/2012 3:41 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Aitor

Envía el archivo que has modificado administrator/components/com_joomfish/tables/JFLanguage.php

Para ver si hay algún problema de sintaxis con respecto a lo que indican en el foro.

Puedes enviar tu archivo comprimido como adjunto.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/09/2012 6:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Aitor
 Aitor
Usuario activo

Hola,

Lo cierto es que el cambio lo había hecho en locahost,

de todos modos me he bajado el archivo del servidor y os lo adjunto en este mensaje.

Gracias

ResponderCitar
Respondido : 19/09/2012 7:34 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola,

Antes de proceder a revisar códigos, hay que asegurarse que es un tema de Joomfish, si desactivas el plugin System - Jfrouter (administración --> extensiones --> gestor de plugins).

Y entonces revisar si se muestran los metadatos.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 19/09/2012 7:46 am

Cursos Gratuitos WordPress

Aitor
 Aitor
Usuario activo

Hola,

He probado a desactivarlo y no he podido ver la web ya que me aparece un error de servidor, en google chrome me aparece esto:
"
Error del servidor
El sitio web ha detectado un error al recuperar la http://90grados.info/ http://90grados.info/. Es posible que esta esté inactiva debido a tareas de mantenimiento o que se haya configurado de forma incorrecta.
A continuación se detallan algunas sugerencias:
Vuelve a cargar esta página web más tarde.
Error de HTTP 500 (Internal Server Error): Se ha detectado una condición inesperada cuando el servidor intentaba atender la solicitud.
"

Si vuelvo a activar el plugin el sitio web vuelve a funcionar como antes, sin los meta, claro.

Veo que ese plugin tiene colocado en el orden el valor -101, supongo que no tendrá nada que ver con el problema que tenemos.

ResponderCitar
Respondido : 19/09/2012 8:26 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Aitor,

He modificado el fichero que has enviado siguiendo las instrucciones del enlace http://www.joomfish.net/forum/viewtopic.php?f=8&t=1448

Prueba a ver si funciona.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 19/09/2012 9:56 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Aitor
 Aitor
Usuario activo

Por fin!!! ya funciona, entiendo que entonces era un error del propio joomfish, no?

Muchas gracias

ResponderCitar
Respondido : 19/09/2012 10:42 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Aitor

Si, al parecer es un problema de Joomfish.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/09/2012 9:28 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro