Modificar url de pá...
Avisos
Vaciar todo

Modificar url de página  

Página 2 / 2
 
Aitor
 Aitor
Reputable Member

Hola,
Quisiera que esta página http://www.encuentrosconelbaile.com/index.php?option=com_content&view=article&id=139&Itemid=157 tuviera una URL más corta.

He visto que desde el panel de control podría crear un subdominio, pero en concreto la quisiera llamar a la página www.encuentrosconelbaile.com/tropicalhouse
¿Cómo podría hacerlo?
Saludos.

Citar
Respondido : 03/01/2012 9:11 am
Aitor
 Aitor
Reputable Member

Gracias Gnumax,
Ya lo he sustituido, pero sigue dando error al cargar la página: www.encuentrosconelbaile.com/tropicalhouse ...
Lo vuelvo a adjuntar
Saludos
Contenido solo visible a usuarios registrados

ResponderCitar
Respondido : 07/01/2012 10:06 am

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Aitor,

Lógico que no te funcione, los códigos de "redirecciones 301" deben estar siempre al prinicipio del archivo htaccess.

Si tienes en la web 2 dominios, por ejemplo, midominio.es y midominio.com y quieres que cuando se cargue uno de ellos se redirija al otro, para que no se indexe la web con los dos dominios, hay que hacer lo siguiente:

- En el cPanel vamos a Dominios->Redirecciones.
- Creamos una nueva redirección con los siguientes datos:
-* Tipo: Permanente (301)
-* http://(www.)?: En el primer campo seleccionamos del desplegable el dominio que queremos redirigir, por ejemplo midominio.es. El segundo campo lo dejamos vacío.
-* redirecciona a?: Introducimos el dominio al que se va a redirigir el anterior, con el http:// incluido, por ejemplo, http://www.midominio.com
-* redirección www: Seleccionamos la opción "Redirigir con o sin www.".
-* Wild Card Redireccionamiento: dejamos marcada la casilla.
- Finalmente pulsamos el botón Crear.
- Vamos al editor de archivo y editamos el archivo .htaccess de la web.
- Al final del archivo deberemos encontrar algo como lo siguiente:

        RewriteCond %{HTTP_HOST} ^midominio.es$ [OR]
        RewriteCond %{HTTP_HOST} ^www.midominio.es$
        RewriteRule ^(.*)$ "http://www.midominio.com$1" [R=301,L] 

Si el archivo .htaccess contiene más código deberemos cortar este texto y colocarlo arriba del todo. Además habrá que agregar el símbolo / en la tercera línea antes del $1. Es decir, tiene que quedar de la siguiente manera:

        RewriteCond %{HTTP_HOST} ^midominio.es$ [OR]
        RewriteCond %{HTTP_HOST} ^www.midominio.es$
        RewriteRule ^(.*)$ "http://www.midominio.com/$1" [R=301,L] 

Con esto, cualquier parte de la web que se cargue con el primer dominio se redirigirá al segundo.

Esta regla anterior no ha funcionado en el caso de una web que está en nuestros servidores, y se tenía que redirigir a una web externa. El código que ha funcionado es:

        RewriteCond %{HTTP_HOST} ^midominio.es$ [OR]
        RewriteCond %{HTTP_HOST} ^www.midominio.es$
        RewriteRule ^(.*)$ "http://www.midominio.com/" [R=301,L] 

Que ante cualquier url del dominio .es lleva correctamente al resultado de http://www.midominio.com (inicio del sitio web, no a otras url's)

Saludos

ResponderCitar
Respondido : 07/01/2012 6:38 pm
Aitor
 Aitor
Reputable Member

Hola,
Una duda,
En el ftp, en public_html tengo 2 archivos, uno .htaccess y otro htaccess ¿es normal? o sólo debo tener 1?
Saludos

ResponderCitar
Respondido : 07/01/2012 7:34 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Aitor,

El único archivo que interpretará el servidor será .htaccess que además de ser oculto (.) por eso lleva el punto al inicio (los archivos en linux se ocultan llevando un punto al principio). el resto de archivos que tengas no tendrán aplicación, pero siempre es bueno tener solamente el archivo activo.

Saludos

ResponderCitar
Respondido : 07/01/2012 7:53 pm
Aitor
 Aitor
Reputable Member

No sé, algo raro está pasando.
www.encuentrosconelbaile.com/tropicalhouse no funciona cuando lo intento hacer desde .htaccess.

también me da error al intentar crear desde el panel de control un subdominio para intentar llamarlo tropicalhouse.encuentrosconelbaile.com y redirigirlo (otros me están funcionando)

No se como hacerlo, pero lo que si quiero es tener una dirección que sea facil, que sustituya a esta:
http://encuentrosconelbaile.com/index.php?option=com_content&view=article&id=139&Itemid=157
porque es difícil que se la aprenda la gente... :unsure:
Saludos y gracias por vuestro apoyo y paciencia.

ResponderCitar
Respondido : 07/01/2012 8:11 pm

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Aitor,

Que http://www.encuentrosconelbaile.com/tropicalhouse/ no te funcione tiene su lógica, el navegador te devuelve un "Forbidden" (Prohibido) porque no puedes listar directorios que es lo que interpreta esa url y al no haber un index.html en dicha carpeta no tiene nada que mostrar y devuelve un error.

¿Como tienes creadas las redirecciones en tu cPanel? (si adjuntas una captura ponla entre etiquetas [hide]).

Saludos

ResponderCitar
Respondido : 07/01/2012 8:33 pm
Aitor
 Aitor
Reputable Member

Ahi va gnumax,
Contenido solo visible a usuarios registrados
Saludos

ResponderCitar
Respondido : 07/01/2012 8:47 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Aitor

Veo que el subdominio: tropicalhouse.encuentrosconelbaile.com si funciona correctamente y te redirecciona a la url deseada.

Evidentemente realizar este procedimiento de utilizar subdominios para cada apartado de tu web no es lo más recomendable ya que por ejemplo si editas o agregas una opción de menú necesitarás agregar o modificar la redirección, lo que te dificulta la administración del sitio.

Saludos.

ResponderCitar
Respondido : 08/01/2012 12:20 pm
Aitor
 Aitor
Reputable Member

Hola
John, y ¿qué opción me recomiendas?

El tema es que las páginas pueden tener su url larga, pero si yo hago un folleto, o una tarjeta, pueda poner algo fácil... solamente es por eso. Que la gente vea una url corta, aunque luego la introduzca y se redirija a la url larga que da por defecto el joomla.

También he descartado lo de las url amigables porque me daba problemas con el aDSmanager.
En mi antiguo joomla 1.0 tenía algunos archivos, que eran por ejemplo tropicalhouse.php, en los que el contenido era este:

Contenido solo visible a usuarios registrados

(pero ahora con el joomla 1.5 no me funciona y yo me pierdo con esto...)
Saludos.

ResponderCitar
Respondido : 08/01/2012 5:27 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 2 / 2