Configuración PHP M...
Avisos
Vaciar todo

Configuración PHP Mail en Configuración Global del Sitio para recibir correos de Alta de Usuarios en Joomla! 1.7  

Página 2 / 3
 
Jorge
 Jorge
Estimable Member

Hola buenas tardes,

Me podríais indicar por favor como deberían quedar los siguientes parámetros para configurar el PHP Mail en la configuración global del sitio?
El tema está en que los usuarios se registran correctamente, les llega bien el email para activar la cuenta por medio del enlace y entran y salen perfectamente, pero a la cuenta de administración del sitio no llega la notificación del registro de los distintos usuarios.
La configuración está por defecto una vez instalado Joomla y es la siguiente:

Configuración global / Servidor

Configuración de la base de datos

Tipo --> MySQLi
Hospedaje --> localhost
Usuario --> nombre de usuario bd
Base de datos --> nombre de bd
Prefijo --> jalvn_

Configuración del correo electrónico

Gestor de correo --> PHP Mail
Correo electrónico del sitio --> pescaconamigos@gmail.com
Remitente --> Pesca con amigos
Ruta de Sendmail --> /usr/sbin/sendmail
Autentificación SMTP --> No
Seguridad SMTP --> Ninguna
Puerto SMTP --> 25
Usuario SMTP --> Campo vacío
Contraseña SMTP --> Campo vacío
Hospedaje SMTP --> localhost

Creo que estos son los datos principales pero si hace falta algo mas, solicitármelo por favor.

Un saludo y muchas gracias por adelantado

Citar
Respondido : 16/08/2011 5:38 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

Para crear un crear un directorio por ejemplo joomla17:

Para realizar un backup de Joomla! de manera manual:

https://www.webempresa.com/videos/joomla-backup/joomla-backup.html

Para que veas el proceso de mover un Joomla! (entendiendo en el video que los conocimientos transmitidos son extrapolables a cambiar el sitio web de carpeta):

https://www.webempresa.com/videos/local-a-servidorwebempresa-1/local-a-servidorwebempresa-1.html

Cambiar Joomla! de directorio desde cPanel:L

https://www.webempresa.com/videos/cambiardedirectorio/cambiardedirectorio.html

---------------------------------------

Respecto al email que tienes en la configuración global, no pertenece al dominio pescaconamigos.com, prueba a crear una cuenta de email con el dominio, por ejemplo Contenido solo visible a usuarios registradosi y poner en el campo correo electrónico del sitio.

Saludos,

ResponderCitar
Respondido : 22/08/2011 8:46 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jorge
 Jorge
Estimable Member

Bon dia Jordi,

Siguiendo tus indicaciones acabo de crear la cuenta tal cual me indicabas y ya la he sustituido en la configuración del sitio, a ver si de esta manera consigo solucionar ese problema que tanto me incordia.
En cuanto lo haya probado te cuento como ha ido.

En relación al otro tema, me voy a estudiar con detenimiento los enlaces que me muestras y a ver que saco en claro de ellos, necesito meditarlo bien porque cargarme ahora el sitio sería un gran problema.

Un saludo y muchas gracias por tus labores de soporte

ResponderCitar
Respondido : 22/08/2011 10:53 am
Jorge
 Jorge
Estimable Member

Hola Buenos días,

Una vez creada la cuenta de correo Contenido solo visible a usuarios registrados en CPanel siguiendo las indicaciones dadas por Jordi y tras dejar pasar un par de días para que hubiera varios registros, y ver si me llegaba la notificación de los mismos a la nueva dirección añadida en Configuración Global del sitio, veo que en el gestor de correo de CPanel, la entrada sigue estando vacía y no ha existido notificación alguna.
El gestor de correo utilizado es el primero, denominado Horde.

Por otro lado y para comprobar las diferencias entre las versiones J1.5 y J1.7, revisando la configuración de Joomla 1.5, en este había que rellenar el campo Usuario SMTP, en Joomla 1.7 no hace falta?

Pienso que algo se me está pasando por algo, pero no consigo averiguar que es para que esto funcione correctamente.

Se os ocurre alguna otra cosilla?

Un saludo

ResponderCitar
Respondido : 25/08/2011 8:55 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

Un tema es la configuración global del sitio en referencia a la cuenta de Correo electrónico del sitio, que es la que hace de motor de envío, que lo correcto es rellenar los campos:
Gestor de correo: PHP Mail
Correo electrónico del sitio:Contenido solo visible a usuarios registrados
Remitente: Pesca con amigos (por ejemplo)
esto era igual en joomla 1.5, no hay que rellenar parámetros SMTP si no utilizamos ese sistema de envío.

Para recibir correos de sistema, no se reciben en esa cuenta, sino en la que tengas señalada en el usuario superadministrador, y que el mismo tenga activada la opción de "Recibir correos del sistema".

Lo más sencillo para probar si recibes o no emails de tu Joomla!, es crear un Contacto, con el componente Contactos, y una vez tengas el formulario en el frontal del sitio web, rellenar y enviar, y ver si recibes emails.

Saludos,

ResponderCitar
Respondido : 25/08/2011 9:10 am
Jorge
 Jorge
Estimable Member

Buenas tardes Jordi,

Aparte de asignar la dirección de correo creada Contenido solo visible a usuarios registrados a la Configuración Global del Sitio, también se la he señalado al superadministrador para que estén ambos sitios igual, con la opción Recibir de correos de sistema en SI remarcada, cosa que ya estaba.

Luego desde una cuenta gmail he enviado un mensaje de prueba a la dirección de correo ya comentada, he entrado en Horde (Webmail) y he visto que si llegan los correos, pero he tratado de enviar uno desde allí a varias cuentas externas y no se puede enviar ninguno pues sale el siguiente mensaje.

Podría ser este el problema de todo lo que hemos comentado desde el principio?

Un saludo

ResponderCitar
Respondido : 25/08/2011 3:35 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

En vez de usar Horde, ¿ por que no pruebas de usar Roundcube ?, que esta mucho mejor. Si en Roundcube te diera también error, escribe un ticket de soporte a nuestro departamento técnico.

Saludos,

ResponderCitar
Respondido : 25/08/2011 3:56 pm
Jorge
 Jorge
Estimable Member

Buenas tardes Jordi,

Antes que nada darte las gracias por tu paciencia y por la labor de soporte prestada.

Bueno, parece que hemos avanzado algo, ya que con Horde no me dejaba enviar, he utilizado Roundcube como me sugerías.
He probado a enviar y recibir mensajes tanto con la cuenta por defecto como con la de información y con ambas funciona correctamente, aunque para que funcionara la de información he tenido que añadir la opción de crear bandeja, con lo que se ha añadido a la que está por defecto y ahí están ambas funcionando correctamente.

Me queda probar a generar un contacto desde Joomla y ver que ocurre.
Voy a probar eso desde el backend y otro registro desde el frontend a ver si ya funciona todo como Dios Manda, en breve te comento a ver si podemos dar ya todo este tema por zanjado.

Un saludo

ResponderCitar
Respondido : 25/08/2011 5:06 pm

Cursos Gratuitos WordPress

Jorge
 Jorge
Estimable Member

Buenos días Jordi,

Tras leer los últimos enlaces técnicos que me mostrabas, he probado lo último que me faltaba según me indicaste en tu última respuesta, que era crear un contacto en Joomla 1.7 y realizar un envío desde el formulario de la web.

Comentarte que el envío llega sin problema al gestor de correo Roundcube, pero en cambio la recepción del aviso de los usuarios registrados sigue sin llegar, ha habido nuevos registros en la web y no llega notificación alguna de ese registro realizado.

Ahora si que estoy totalmente desconcertado, todas las pruebas que me has ido sugiriendo han funcionado finalmente pero no consigo que me lleguen los avisos cuando alguien se registra.

Se te ocurre algo mas que pueda mirar o hacer?

Un saludo y muchas gracias

ResponderCitar
Respondido : 26/08/2011 7:10 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

Perfecto que el formulario de contacto funcione, porque eso indica que la configuración global del sitio en relación al email está correcta.

Respecto a recibir correos de sistema, ya nos has indicado que el usuario superadministrador tiene activada la opción de "Recibir correos del sistema" y que es la misma cuenta que en la configuración global. En Joomla 1.7 hay una novedad respecto a versiones anteriores, que es que en administración --> usuarios --> gestor de usuarios --> opciones --> pestaña "configuración del componente" -->Activación de cuentas de usuario, desconozco que opción tienes activada de las tres (ninguno, por si mismo, administrador).

Saludos,

ResponderCitar
Respondido : 26/08/2011 8:13 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jorge
 Jorge
Estimable Member

Buenos días Jordi,

Está en por si mismo., no obstante, te paso una captura de como están configurados el resto de campos en ese apartado, comentarte que está por defecto tras la instalación de Joomla, yo no he cambiado nada.

Venga un saludo

ResponderCitar
Respondido : 26/08/2011 11:44 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

¿ Has probado a registrarte en el frontal del sitio web, y ver si recibes como usuario a registrar el correo con el código de confirmación ?

Saludos,

ResponderCitar
Respondido : 26/08/2011 12:00 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jorge
 Jorge
Estimable Member

Hola Jordi,

Desde el frontend creé un usuario para pruebas y SÍ me envió el email de activación al email de registro, o sea igual que les llega al resto de usuarios?

Por otro lado, desde el backend también creé un usuario interno para labores administrativas pero lo activé de forma manual, por lo que no llegue a ver lo del email de activación, lo que si me llegó posteriormente es un mensaje de que la cuenta había sido creada con los datos de usuario y contraseña y que el Administrador le había activado la cuenta.

Si quieres que realice alguna otra comprobación, coméntame por favor.

Un saludo

ResponderCitar
Respondido : 26/08/2011 1:11 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

Entonces el sistema está funcionando correctamente, ya que si llega el email de activación de registro al usuario y puede realizar el paso de registrarse.

Desde el backend si activas los usuarios de una manera o realizas el alta desde el gestor de usuarios, el sistema no envía email.

No me ha quedado claro, al final si un usuario se da de alta en el frontend, si recibes como administrador un email o aviso de ese registro ¿esta comprobación la has realizado después de realizar los últimos cambios en la configuración de email?.

Saludos,

ResponderCitar
Respondido : 26/08/2011 2:20 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jorge
 Jorge
Estimable Member

Buenas tardes Jordi,

Ese es el problema, que cuando un usuario se registra, yo como administrador no recibo ningún email o aviso de ese registro, sin embargo a ellos les llega bien el email con el enlace para activar la cuenta y se registra sin problema alguno.

También lo he comprobado después de realizar los últimos cambios en la configuración del email, ya que ha habido registros de usuarios realizados

Se te ocurre algo mas que pueda mirar?

Un saludo

ResponderCitar
Respondido : 26/08/2011 4:45 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

Se que ya se ha preguntado antes, pero insisto, en Gestor de Usuarios, tu usuario Super Admin tienes habilitado "Recibir correos del sistema" ¿correcto?.

La versión es 1.7.0 ¿correcto?
El correo en Configuración Global lo tienes habilitado correctamente ¿cierto?.

Saludos

ResponderCitar
Respondido : 26/08/2011 8:12 pm

Cursos Gratuitos WordPress

Página 2 / 3