Configuración PHP M...
Avisos
Vaciar todo

Configuración PHP Mail en Configuración Global del Sitio para recibir correos de Alta de Usuarios en Joomla! 1.7  

Página 3 / 3
 
Jorge
 Jorge
Estimable Member

Hola buenas tardes,

Me podríais indicar por favor como deberían quedar los siguientes parámetros para configurar el PHP Mail en la configuración global del sitio?
El tema está en que los usuarios se registran correctamente, les llega bien el email para activar la cuenta por medio del enlace y entran y salen perfectamente, pero a la cuenta de administración del sitio no llega la notificación del registro de los distintos usuarios.
La configuración está por defecto una vez instalado Joomla y es la siguiente:

Configuración global / Servidor

Configuración de la base de datos

Tipo --> MySQLi
Hospedaje --> localhost
Usuario --> nombre de usuario bd
Base de datos --> nombre de bd
Prefijo --> jalvn_

Configuración del correo electrónico

Gestor de correo --> PHP Mail
Correo electrónico del sitio --> pescaconamigos@gmail.com
Remitente --> Pesca con amigos
Ruta de Sendmail --> /usr/sbin/sendmail
Autentificación SMTP --> No
Seguridad SMTP --> Ninguna
Puerto SMTP --> 25
Usuario SMTP --> Campo vacío
Contraseña SMTP --> Campo vacío
Hospedaje SMTP --> localhost

Creo que estos son los datos principales pero si hace falta algo mas, solicitármelo por favor.

Un saludo y muchas gracias por adelantado

Citar
Respondido : 16/08/2011 5:38 pm
Jorge
 Jorge
Estimable Member

Buenos días Luis,

Aquí te pongo dos capturas de ambas cosas para que lo veas.

Si te refieres a si la versión es Joomla 1.7, es SÍ.

Podría tener algo que ver con algún parámetro de configuración en el hosting relacionado , lo pregunto porque creo que hemos mirado casi todo lo que es posible comprobar en Joomla y como sigue sin ir?

Si se os ocurre alguna otra cosa mas, yo sigo probando todo lo que me digáis hasta conseguir dar con la solución.

Un saludo y daros las gracias nuevamente por vuestra labor de soporte técnico

ResponderCitar
Respondido : 27/08/2011 8:38 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

Solo me resta preguntar si la cuenta que estas usando que tienes configurada en el servidor, en Correo de cPanel, recibe los correos normales o en "spam".

¿Has verificado ese detalle?.

Saludos

ResponderCitar
Respondido : 27/08/2011 9:48 pm
Jorge
 Jorge
Estimable Member

Buenas noches Luis,

Como me sugirió Jordi, creé una cuenta en Roundcube para comprobar esto que me comentas y los recibo sin problema tanto desde el módulo contacto como desde cualquier email, lo único que en la cuenta del Administrador no recibo los emails de aviso del sistema cuando un usuario se ha registrado, simplemente es es el problema.

Un saludo

ResponderCitar
Respondido : 27/08/2011 11:11 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

Una consulta, ¿podrías eliminar esa cuenta en cPanel, la que no recibe los mensajes y volverla a crear, con el mismo nombre, etc. y probar?

Solo para descartar que no sea un problema en la creación de la cuenta, ya que dices que es la única que no esta recibiendo.

Saludos

ResponderCitar
Respondido : 28/08/2011 12:16 am
Jorge
 Jorge
Estimable Member

Buenos días Luis,

Este problema no ha ocurrido solo con esta cuenta, sino con las dos probadas hasta ahora, me explico:

Al principio de todo, la cuenta por defecto asignada al administrador para recibir todos los avisos del sistema era una cuenta de gmail que era la con la que se creó el usuario.

Al ver que no se recibían estos avisos, me comentasteis que se la cambiara y le asignara la que se crea por defecto en CPanel con el usuario creado por defecto Contenido solo visible a usuarios registrados para comprobar que la cuenta por defecto inicial no tuviera ningún problema.
Para comprobar si se podían enviar y recibir desde esta cuenta, Jordi me sugirió usar Roundcube ya que Horde daba algún fallo al enviar; desde la cuenta informacion al igual que la de pescacon en Roundcube se pueden enviar y recibir correos sin problema, ya sea a través del módulo Contacto como desde las cuentas usadas por los usuarios para el registro. Les he indicado a varios usuarios que me enviaran correos a estas cuentas para comprobarlo.

En resumen que todo parece funcionar correctamente menos la recepción de avisos por parte del usuario Administrador independiente de la cuenta utilizada, cuando los usuarios han realizado los registros, a este debería llegarle esa notificación a una de esas 2 cuentas y no lo hace.

Espero haberme explicado correctamente y me entiendas.

Un saludo

ResponderCitar
Respondido : 28/08/2011 7:34 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

¿Cuando un usuario nuevo se registra, en el backend, en el Gestor Usuarios: Usuarios, las columnas Habilitado y Activado como se muestran para este usuario?

Saludos

ResponderCitar
Respondido : 28/08/2011 7:08 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

He realizado pruebas de todo tipo para el registro de usuarios en Joomla! 1.7 y recibo correctamente los correos de confirmación como usuario:

Hola, xxxxx:

Gracias por registrarte en Joomla! 1.7.0. Su cuenta ha sido creada y necesita ser verificada antes de que pueda usarla.
Para activar la cuenta, haga clic sobre el siguiente enlace o copie y pegue la URL completa en su navegador:
  http://pruebas.com/index.php?option=com_users&task=registration.activate&token=b03862aa13ea7c28a276d4bf0e65d090

Después de la verificación un administrador será advertido para que active la cuenta. Recibirá una confirmación cuando se haya hecho.
Una vez que la cuenta se haya activado, podrá acceder a http://pruebas.com/ usando el siguiente usuario y contraseña:

Usuario: xxxxxxxx
Contraseña: xxxxxxxxx

Y cuando confirmo el link me remite a la web y me muestra lo siguiente:

Su correo ha sido verificado. Una vez que el administrador apruebe su cuenta, se le notificará por correo electrónico y podrá identificarte en el sitio.

A ti cuando registras un usuario de prueba ¿te llega el correo de registro?.

Saludos

ResponderCitar
Respondido : 28/08/2011 7:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jorge
 Jorge
Estimable Member

Buenas noches Luis,

Este no es el problema, como puedes ver cuando un usuario se registra en mi web, el sistema le envía el siguiente mensaje para que active la cuenta, el mensaje que te pongo es igual que el tuyo.
Contenido solo visible a usuarios registrados

Hola Administrator,

Se ha registrado un nuevo usuario en Pesca con amigos.
Este mensaje contiene los detalles:

Nombre - xxxxxxxxx
E-mail - xxxxxxxxxxxx@xxxxxxxxxx.xxx
Nombre de usuario - xxxxxxxxxx

Todo funciona correctamente menos la recepción por parte del Administrador de un mensaje como este último mensaje que te he puesto encima.

Un saludo

ResponderCitar
Respondido : 28/08/2011 10:10 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

He estado realizando pruebas, y cuando en las opciones de usuario --> Activación de cuentas de usuario está seleccionado "ninguno" o "por si mismo" el administrador no recibe emails.

Pero en cambio si en las opciones de usuario --> Activación de cuentas de usuario está seleccionado "Administrador", se recibe un email (después de que el usuario ha realizado clic en enlace de activación del email recibido por él):

Hola, administrador:

Un nuevo usuario se ha registrado en Joomla 1.7.
El usuario ha verificado su correo electrónico y espera a que usted apruebe su solicitud de cuenta.
Este correo contiene sus detalles:

Nombre : xxxxx
Correo: xxxx@xxxxxx.xxx
Usuario: xxxxxxx

Puede activar al usuario haciendo clic en el enlace de abajo:
http://xxxxxxx.xxx/index.php?option=com_users&task=registration.activate&token=7ec0ac07fdef5ad5902aec38e24530

y el usuario:

Hola, xxxxx:

Su cuenta ha sido activada por un administrador. Ahora ya puede acceder e identificarte en http://xxxxxxx.xxx usando el usuario xxxxxx y contraseña que eligió durante el proceso de registro.

Saludos,

ResponderCitar
Respondido : 29/08/2011 9:00 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jorge
 Jorge
Estimable Member

Buenos días Jordi,

Si no he entendido mal, el Administrador solo recibirá los mensajes cuando sea él mismo quien active las cuentas desde el backend?

Bueno, si tiene que ser así en Joomla 1.7 pues nada habrá que darlo por bueno, por lo menos ya sabemos que no es un bug o error durante el proceso de registro, pero en mi opinión lo lógico sería que al Administrador le llegara siempre un último mensaje, en el que pudiera ver que finalmente todo el proceso se ha desarrollado de forma correcta.

Pues nada, os doy las gracias a todos por la enorme paciencia que habési tenido conmigo en todo este tema y por vuestra fenomenal labor de soporte.

No obstante, estaré atento por si algún día creyeran conveniente modificarlo los desarrolladores de Joomla y que el Administrador tenga conocimiento de como se desarrolla el proceso de registro en cualquiera de los 3 casos.

Un saludo y muchas gracias

ResponderCitar
Respondido : 29/08/2011 10:06 am
Página 3 / 3